D-Link Forums

D-Link Network Storage => DNS-320L => Topic started by: JavaLawyer on November 06, 2013, 05:12:44 AM

Title: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: JavaLawyer on November 06, 2013, 05:12:44 AM
D-Link released firmware version 1.03b04 for the DNS-320L hardware versions A1, A2, and A3.  :)

Post your comments and observations here!!!  :)  ;)  :)
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: JavaLawyer on November 06, 2013, 05:13:59 AM
The published release notes are now updated to reflect the changes in firmware version 1.03b04:
DNS-320L - Cumulative Firmware Release Notes (http://forums.dlink.com/index.php?topic=51629.0)

Firmware: 1.03 - Date: 09/04/2013

Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: Mausschubser on November 10, 2013, 01:31:59 PM
I cannot save a valid "Configuration Settings" file in the Management > System Management > System Settings section. The file "backup" goes to disk, but has a length of 0 (zero) bytes.

Cross checked this with a hex-editor and with Firefox and Internet Explorer. Restarted the NAS twice, once with power down, after firmware backup.

Some idea?
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: r0g3r on November 11, 2013, 10:47:40 AM
just tried it an works as usual, my size is 5,78KB btw.
check if firewall or antivirus is blocking, thats no fw bug.
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: yuryby on November 14, 2013, 07:30:39 AM
Samsung 40ES6340. Smart TV still not working. It still shows no content in the root folders.
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: JavaLawyer on November 14, 2013, 11:14:09 AM
I cannot save a valid "Configuration Settings" file in the Management > System Management > System Settings section. The file "backup" goes to disk, but has a length of 0 (zero) bytes.

Cross checked this with a hex-editor and with Firefox and Internet Explorer. Restarted the NAS twice, once with power down, after firmware backup.

Some idea?

Are other DNS-320L users experiencing this issue on FF and/or IE?
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: r0g3r on November 14, 2013, 03:16:23 PM
can confirm the Samsung TV bug, only works with 3rd-party ffp+twonky
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: martysport on November 15, 2013, 08:57:40 AM
Are other DNS-320L users experiencing this issue on FF and/or IE?

Works OK for me  ;) 7.58 KB (7,766 bytes)
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: JavaLawyer on November 15, 2013, 09:04:35 AM
I cannot save a valid "Configuration Settings" file in the Management > System Management > System Settings section. The file "backup" goes to disk, but has a length of 0 (zero) bytes.

Cross checked this with a hex-editor and with Firefox and Internet Explorer. Restarted the NAS twice, once with power down, after firmware backup.

Some idea?

Can you please try IE and/or FF using another PC on your LAN?
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: Typhos on November 16, 2013, 03:53:03 AM
why is there stil no support for mkv and no support for srt files ?
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: bobkeith on November 17, 2013, 02:49:18 AM
I had a little difficulty re-refreshing my media content after the update, again, but that aside early indications are better than I dared hope.

My content is browsable again via the PS3, a problem introduced with v1.02.
My content is accessible on my Samsung smart TV for the first time in any version.

The only problem that may or may not be related to this update is that I can no longer log on to the admin console over the web. It's been months since I last tried this as the problems in v1.02 left me with a glorified hard drive for a while so I've not needed to use this for a long time. I'd be interested in hearing if others are seeing this at all? I can still log in using the local ip address, just getting no response after I enter my login credentials over the web.
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: RicRoller on November 18, 2013, 04:55:23 AM
Cosmetic issue with current 1.03b4 (also occurred with the original 1.01 my DNS-320L was shipped with...)

In the "sytem status | resource monitor - the "bandwidth" graph auto-scaling of the Y axis does not handle data rates above 100Mbit/sec
(a) With the network (GbE) idle or with nothing above 100Mbit/sec the scale is drawn from 0 to 100, filling the whole of the Y-axis.
(b) When data rates above 100Mbit/sec occur, the graph itself appears to be drawn in the correct proportion, but the Y-axis labelling then becomes squashed towards the bottom. In the extreme case with a burst of full gigabit activity, all of the Y-axis labelling 0 to 100 gets drawn right at the bottom in an untidy mess.

Regards,
Richard
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: Picchio on November 19, 2013, 03:36:59 AM
why is there stil no support for mkv and no support for srt files ?

just restarting after upgrade. refreshing media library..... takes long....
need to try, but in previous versions I used to rename mkv files into avi and they run... don't know with this...

bye
G
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: bcorrea on November 19, 2013, 02:26:44 PM
For me, even from Windows 8, my library stays empty even after restart and manual refresh... What can i do to solve this? I have deleted everything from Multimedia Shares and recreate everything from scratch but no help even after days.

Another thing, I could swear I have seen something about Package Management, but now i cant seem to find this anymore? Was i crazy or is it available to download and install external application packages in this version?
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: bobkeith on November 20, 2013, 10:26:47 AM
Any time I access my media shares, I'm hit with the following message in a dialog.

"Please refresh the Multi-Service database to use UPnP normally."

Some times it only flashes up momentarily, other times it stays until I hit yes or no. The behaviour seems to change depending on whether my uPNP & itunes services are enabled.

If I hit yes, it acts as if it's initialising a refresh of all the multimedia services but it doesn't seem to do this.

I've refreshed all content twice and this is still occurring.
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: RicRoller on November 22, 2013, 02:44:50 AM
Minor issue in web UI display with USB backup:

(a) When USB backup is not enabled or is not running, the status in the web UI ("Local Backups | USB backup") shows as "--"
(b) If the backup is enabled and started by pressing the front panel button (in my case I was doing NAS to USB), no status is shown (the entry is blank).

IMO the status should at least show something such as "running" while the backup is in progress, it would be nice to have it show a "percentage complete" value or a "fuel guage" showing how far through the backup it has got.

Regards,
Richard
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: twtn on November 25, 2013, 05:08:51 AM
Having an issue with the media library (Content Classification) function which will generate media library for content stored in the NAS, and serves mobile apps and NAS applications (My Photos, My Music, etc).

The MP3 (music) "genre" are limited to 20 out of 100.
I'm not sure but I suspect that local Danish letters , & damage the media scan.

I'll try to convert the Danish letters to old Danish where = ae, = oe & = aa to see if this resolve the problem.

Regards,
Thomas
 
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: tiagorl on November 28, 2013, 12:48:46 AM
Hi have problem when login with SSL; sometimes the buttons are disabled. I must to do logout and do login again in order to be able to push them.
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: mrighetti on November 30, 2013, 02:58:10 PM
TV Samsung UN55F8000AG
TV Samsung UN40F5500AG
HT Samsung HT-F5500K/ZD

Refuses to read any folders; Not working with FW v1.0, v1.01, v1.02 and v1.03

  :'(
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: Nimril on December 01, 2013, 12:35:56 AM
Since updating the firmware the setup program will not identify the NAS.

Is there a newer version of the set up?

I updated the firmware first thing. This was with the premiss why learn where everything is when the firmware is just going to change it.

Only really wanting the set up so I can register the device to get the MyDlink Cloud. Tried with a different laptop with no firewall still the same. Is there an alternative way?

Any suggestions please.

I've only had this NAS for a week so still learning where things are, so go gentle please!
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: AmiGaGa on December 08, 2013, 05:02:56 AM
Hi !

just upgraded from 1.01 to 1.03b04 and... YESSSSSSSSSSSSS, DLNA works well with Samsung TV !
- UE40C6000 (MediaPlay)
- UE46EH6030 (AllShare)
I wish DLink will now make a firmware update for DNS320 as well.
Thank you Dlink (even if it take a "lot" of time to do it, i'm happy to use your hardware now!)
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: Psyc on December 09, 2013, 12:44:14 PM
I cannot enable P2P.  When I put a tick on "Enable" and save the settings, it just refresh and the tick is back to"Disable".

*** update

After tinkering, I tried to set P2P to "Enable" then disabled "Auto Download" and "Encryption".  Clicked on "Save Settings" and it saves it this time.  Tried to do a test download, it seems to be working now.
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: AmiGaGa on December 10, 2013, 03:40:54 PM
Hello, a quick return after some tests :

1) Same problem than RicRoller
LAN display is 100MBps even if it's 1000MBps LAN.

2) Same problem with Music than twtn.
Refresh/scan is not working perfectly.
Sometimes media scan says "initializing" and stays (all the night). 100% CPU is used with sqldb process.
Even if I click on "stop button" in the media scan, CPU stays 100% used by sqldb process. I have to reboot the NAS to "kill" the process and keep back few % CPU use.
After hours of testing, I found the problem : a 112kbps 44kHz encoded MP3.
FYI, files with (french) caracters like ", , ,..." works well.

3) Multimedia Services : better compatibility with TV but no automatic refresh anymore ?

4) Multimedia Services : on UE46EH6030 (AllShare) : compatibility problem. Exemple to be as clear as possible :
videos directory
 - subdirectory 1 (I go and stay in this directory on the TV)
 -- files 11 -> files 19 (doesnt displayed on TV)
 -- subdirectory 2
 --- files 21 -> 29 (displayed like directory in subdirectory 1 on TV)
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: Igodor on December 11, 2013, 06:43:40 AM
Dynamic DNS is not working properly with www.DynDNS.org (Free).
NAS sends to the DynDNS not external IP-address, but from the internal LAN IP-address.

While with www.dlinkddns.com and no-ip.DDNS everything works as it should be. If the function is implemented, then it should work the same on any service.
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: Igodor on December 11, 2013, 06:52:26 AM
Decided to test the "My Surveillance", which appeared in the latest firmware. The camera DCS-5020L is connected, all set up, like all great tunes and shows. But after any video recording play of this record does not work. In the "My Surveillance - Playback" any did not active, including button to open the list of recorded video "My Surveillance - Recording Information". Though as it turned out later (after installing fun_plug) in the corresponding hidden directories all the necessary files are recorded.

What could be the problem and working video playback in "My Surveillance" from someone on this firmware?
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: AmiGaGa on December 13, 2013, 08:21:40 AM
Hello,

formatting speed DNS320L fw1.03b04 and DNS320 fw2.04 :
Formatting a 3TB HD take 3x more time on DNS320L  :o
(DNS320 : ext3 - DNS320L : ext4)
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: smares on December 16, 2013, 03:17:22 AM
UPnP port forwarding not re-added on router reboot.

If you configure port forwarding via UPnP and the router is rebooted, the previously opened ports are not re-added. Would be nice if this could be changed as soon as the NAS detects a new link.
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: twtn on December 25, 2013, 05:32:02 AM
Amigaga:

Have you noticed if your music genre categories are limited to a small number.
Think that the DNS-320L are limited to some defaults and it's not possible to use/add your own.

Have checked and I don't have any problems with the Danish letters ", & ".
They are in files names on the NAS and I've also seen that the Genre includes ", & ".
The above I've seen through file explore on the DNS-320L mapped drive.

Regards
Thomas
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: DTSanchez on December 27, 2013, 03:13:15 PM
I have the problem when my multimedia index tries to refresh it gets stuck at 24% even if i leave it running 24 hours. If you press "pause" it gives the correct message "do you wish to pause the index". But if you then press the play button to restart you get the message "do you want to stop the indexing"  :(

overall i am not very happy with this product have been fixing problems for the last 5 days, almost ready to return it to the shop and switch brands.
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: sja on December 30, 2013, 03:23:23 PM
Hi there,

I have recently purchased a DNS-320L which I subsequently upgraded to the latest 1.03 firmware. If I try to refresh the multimedia services from the Application Management section, it starts as I would expect, and then appears to "get stuck" and a certain point. I have tried this numerous times, and the point where it gets stuck depends on how much is on the drive.

I have a single 3TB installed with approx. 400GB of multimedia data (music, and video). So far it has been sitting on 50% for about three days. It got to 50% within about 5 minutes, so I think there is definately something wrong with the process.

I have seen other users report similar issues either within the mulitmedia section, or the specific iTunes server. While it is doing the refresh, my Samsung TV cannot see any media files (it worked the first time I tried with only a few media files) and the D-Link "My Music" link doesn't either. Hopefully there is a fix or workaround soon.

Regards,

sja
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: jsslave on January 17, 2014, 01:58:57 AM
I update to the last firmware my new just bought DNS-320LW.
At the moment all is working fine and there are many improvement wrt the old firmware.

First update after 2 days of test:
BUG-> P2P: the "Remove Completed" button doesn't work
BUG-> DDNS: sometimes the IP is updated with the internal net IP and not the public one.
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: sarbash on January 21, 2014, 03:50:40 AM
Confirm the bug with DDNS client: sometimes the IP is updated with LAN IP and not the public one.
LOG: Can't set the number of displayed records per page from default 10 to a different value (I use language pack, maybe this is the issue).
"My Photos" and "My Music" icons are visible on admin's home screen only.

DNS-320L with the latest official firmware.
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: jsslave on January 22, 2014, 05:17:48 AM
Summary after 1 week of use:

BUG-> P2P: the "Remove Completed" button doesn't work
BUG-> P2P: the setting "Stop seeding when meet..." doesn't work
BUG-> P2P: start/stop button: when stop is pressed it comes back to start when screen auto refresh
BUG-> DDNS: sometimes the IP is updated with the internal net IP and not the public one (as reported also by sarbash)
BUG-> "My Music" and "My Surveillance" application visible only in the Home tab, not in the Application tab (as reported also by sarbash)
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: locolyric on January 25, 2014, 03:56:23 AM
bug : the log files said " Fan Is Unable To Spin Or Fan Doesn't Exist."
but the fan were really spinning well.
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: jls on January 25, 2014, 07:12:40 AM
Since the upgrade, this message appears in the log file:

Quote
Jan 25 15:33:00 HomeNAS airplay_daemon: Libgcrypt warning: missing initialization - please fix the application

airplay_daemon is still running despite the warning message

It may affect other processes:
Quote
lsof  | grep /usr/local/modules/lib/libgcrypt.so.11
airplay_d 16466             root  mem       REG        7,0   480932     2369 /usr/local/modules/lib/libgcrypt.so.11
afpd      18210             root  mem       REG        7,0   480932     2369 /usr/local/modules/lib/libgcrypt.so.11
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: buljaka on February 08, 2014, 01:23:07 AM
 It is clearly scheduled to work only during night time and hour and a half later it is still downloading at full speed even though next to torrent there is a graphic symbol of clock meaning it is scheduled to begin later ..

Any Ideas?

 (http://zaslike.com/files/62839k233t3r9kosx2l8_thumb.jpg) (http://zaslike.com/viewer.php?file=62839k233t3r9kosx2l8.jpg) (http://zaslike.com/files/egfh78hho0txw818qaq_thumb.jpg) (http://zaslike.com/viewer.php?file=egfh78hho0txw818qaq.jpg) (http://zaslike.com/files/7ic1q4fw1j3az54091wn_thumb.jpg) (http://zaslike.com/viewer.php?file=7ic1q4fw1j3az54091wn.jpg)
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: JonnieB2014 on February 16, 2014, 08:56:45 AM
Hi guys,

really frustrating. Just bought a dcs 7010L. Great camera and thought I could add it to the DNS 320L app. 'My Surveillance' along with my other Dlink cameras but it looks like it's not supported. I have 3 cameras supported and the one I really want on there, I can't add. Is there going to be another firmware to support it or do I need to upgrade my N AS?
Any guidance greatly appreciated
thankyou JB
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: jsslave on February 20, 2014, 03:56:13 AM
Don't worry Jonnie, select instead model DCS-2132L and the 7010 will work well.
I have two 7010L connected to the 320L and all is working ok.
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: drc954 on February 28, 2014, 08:10:29 AM
I decided to go with the 1.03 upgrade. Well, the password error bug is still there. Not sure if it's a Firefox thing, but I've saved the admin password, so that whenever I enter the URL for the ShareCenter, the password gets pre-entered. First click of the login button, will return the "You've entered an incorrect login name or password. Please try again." error message. Doing absolutely nothing but just pressing the login button a second time, it opens as expected.
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: JavaLawyer on March 04, 2014, 04:47:13 AM
I decided to go with the 1.03 upgrade. Well, the password error bug is still there. Not sure if it's a Firefox thing, but I've saved the admin password, so that whenever I enter the URL for the ShareCenter, the password gets pre-entered. First click of the login button, will return the "You've entered an incorrect login name or password. Please try again." error message. Doing absolutely nothing but just pressing the login button a second time, it opens as expected.

Have you tried clearing out your Firefox browser cache to purge any erroneous username/password entries?
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: drc954 on March 04, 2014, 07:32:17 AM
I had suspected it maybe due to the browser I use most of the time because when I use my iPad, the symptom is not there. Your suggestion to clear the cache seems to resolve this problem, but will continue to test it out. I use Firefox both on Ubuntu as well as Win7.
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: JavaLawyer on March 04, 2014, 08:01:13 AM
I had suspected it maybe due to the browser I use most of the time because when I use my iPad, the symptom is not there. Your suggestion to clear the cache seems to resolve this problem, but will continue to test it out. I use Firefox both on Ubuntu as well as Win7.

I've had the same thing happen myself.  .  . erroneous password saved to cache was the root cause.  ;)
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: Vipak on March 17, 2014, 10:55:29 AM
Hi, Anybody knows how to remove a video from my surveillance? I tested it for a couple of days and by (my) mistake it burned lots of space in my HDD, so now I have set "My surveillance" cameras to get on just by motion detection, but I'd like to recovere all the space It has been used first. I hope to have been cleare. Thanks a lot
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: JavaLawyer on March 17, 2014, 11:06:45 AM
Hi, Anybody knows how to remove a video from my surveillance? I tested it for a couple of days and by (my) mistake it burned lots of space in my HDD, so now I have set "My surveillance" cameras to get on just by motion detection, but I'd like to recovere all the space It has been used first. I hope to have been cleare. Thanks a lot

In the Recording Setup section you can set a Quota specifying the maximum amount of space used for recordings, which should free up space if you set the value low enough.  Alternatively, you can also configure files to delete automatically using the Keep the File within ___ (Days) option.
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: Vipak on March 17, 2014, 11:33:05 AM
Thanks for your fast reply,
actually I have set max space 50 Gb but the recording went on up to 90 Gb!
Now even if I reduce the space to a lower value, It still shows 90 Gb, that for me it's wasted space, that's why I'd like to erase everything, and start up again.
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: luzippu on April 16, 2014, 04:44:11 PM
hi, since the upgrade to firmware [DLINK_DNS320L(LW).1.03b04(3.07.0904.2013)] the sharecenter web ui doesn't respond well.

none of the settings under network management > lan setup cannot be saved or enabled

all the static ip fields are now blank.. i have t enter them everytime.

any idea??

or how can i revert back to a previous stable version?

cheers
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: JavaLawyer on April 16, 2014, 06:06:34 PM
hi, since the upgrade to firmware [DLINK_DNS320L(LW).1.03b04(3.07.0904.2013)] the sharecenter web ui doesn't respond well.

none of the settings under network management > lan setup cannot be saved or enabled

all the static ip fields are now blank.. i have t enter them everytime.

any idea??

or how can i revert back to a previous stable version?

cheers


what browser are you using?

Network Camera - IE11 Not Fully Compatible with All Network Camera Functionality (http://forums.dlink.com/index.php?topic=58272.0)
Network Cameras - Lost "Live View" After Installing Java Version 7 Update 51 (http://forums.dlink.com/index.php?topic=57476.0)
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: mangmagic on June 06, 2014, 11:00:42 AM
Hi,

I have two questions:

Is this version susceptible to the Heartbleed SSL bug?

Is there a later version of the DNS 320-L (A2) firmware?

Thanks.
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: mnlvidrec on July 03, 2014, 03:50:16 AM
After logging into web gui 192.168.1.xxx, the app for My Surveillance if color gray. And when I click on it, nothing happens. Also when on mydlink.com->applications->My Surveillance it opens a new window and says "404 not found"

Does anyone having the same problem?

I'm a new Dlink DNS-320L user trying to connect and record my ip cam using the My Surveillance app on the DNS-320L but failed.

Firmware 1.04
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: JavaLawyer on July 23, 2014, 07:04:27 AM
D-Link published firmware version 1.04b07. A link for this latest release is located on the first post of the following thread: DNS-320L - Firmware Version 1.04b07 - Comments & Observations (http://forums.dlink.com/index.php?topic=60182.0)
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: Supercooper52 on July 24, 2014, 10:25:16 AM
Are we meant to guess what has changed in this latest release then?!
Title: Re: DNS-320L - Firmware v1.03b04 Comments & Observations
Post by: JavaLawyer on July 24, 2014, 12:59:49 PM
Are we meant to guess what has changed in this latest release then?!


Until a change log is posted, this is the best I can do.