D-Link Forums

The Graveyard - Products No Longer Supported => Routers => DIR-506L => Topic started by: chris2027 on August 13, 2013, 03:54:15 AM

Title: Is it broken?
Post by: chris2027 on August 13, 2013, 03:54:15 AM
So I recently purchased a DIR-506L as I am in need of a wifi repeater and this seemed to tick all the boxes.

After a few attempts of setting the DIR-506L in to repeater mode, I just couldn't get it to work.  It would become unresponsive too.

I found that there was a newer firmware version which stated improvements to wireless modes so after a reset I attempted to do an upgrade of the firmware.

This was done through chrome, on windows 8, (yes; over ethernet cable) and it got stuck at 18% (in the chrome status bar not as a percent on the actual webpage).  After about an hour I came back and had no choice but to restart the device.

Now the device takes a few moments and then the lights respond in a strange way.  The USB is flashing and the internet light stays on.  however no connection can be made to the device via ethernet (and no access point is available).

I have tried holding reset on startup for various amounts of time, and I have tried holding reset after start up for various amounts of time.

Sounds dead right?  anyone know of a hidden recovery mode or such?

Thanks.

Chris.
Title: Re: Is it broken?
Post by: FurryNutz on August 13, 2013, 07:06:33 AM
Try this:
Emergency Recovery Mode (http://forums.dlink.com/index.php?topic=44909.0)
Use FF to perform this.

Please follow this for doing any FW updates:
FW Update Process (http://forums.dlink.com/index.php?topic=42457.0)

If the recovery doesn't work or you can't get it back into a ready state, you'll need to phone contact D-Link support and get it into RMA.
Title: Re: Is it broken?
Post by: chris2027 on August 14, 2013, 04:46:26 PM
Thank you for the reply, unfortunately after many attempts I am still unable to access the recovery mode.

I'll contact dlink, atleast I know I have attempted everything I could try.

Thanks again
Title: Re: Is it broken?
Post by: FurryNutz on August 15, 2013, 07:27:55 AM
Let us know how it goes.

Good Luck.
Title: Re: Is it broken?
Post by: primetimelive on August 04, 2014, 01:48:42 PM
This might be too late.  But I recently ran into the same problems you did.

I followed the recovery procedure, unfortunately the recovery page wasn't there.

What I did was that I used an IP Scanner to find out what the router was broadcasting it's IP Address to be and logged on using that.  In my case it was 192.168.123.254 

Hope this can help anyone else that might run into this problem.
 
Title: Re: Is it broken?
Post by: FurryNutz on August 04, 2014, 02:14:18 PM
Thank you for posting this info.

So the default IP address did not work for this model router?



This might be too late.  But I recently ran into the same problems you did.

I followed the recovery procedure, unfortunately the recovery page wasn't there.

What I did was that I used an IP Scanner to find out what the router was broadcasting it's IP Address to be and logged on using that.  In my case it was 192.168.123.254 

Hope this can help anyone else that might run into this problem.
 
Title: Re: Is it broken?
Post by: primetimelive on August 07, 2014, 07:09:59 PM
Hey FurryNutz,

What happened was I experience a bad flash.  I was trying to update the router firmware over a spotty wireless connection.  (Note: BAD IDEA!!)  As the firmware was uploading, the wireless connection cut off and didn't finish. 

I was still able to access the router admin panel, but when I restarted the router it had the same issues at the OP.

1)  Ethernet light on the router constantly on.
2) USB light flashing.

I immediately looked up Dlink DIR 506L bricked on Google and it led me to the Recovery Process listed on these forums.  Unfortunately, it didn't work as intended which led me to try to either buy a new travel router or try to find a way to fix this one.

What I noticed was that a hard wired computer could still establish a connection to the router in the soft bricked state.  This meant that the router was capable of still connecting, but the default recovery IP was not working. So basically I did the following:

Hope this helps anyone.
Title: Re: Is it broken?
Post by: FurryNutz on August 08, 2014, 07:40:38 AM
Please always follow this for doing any FW updates:
 FW Update Process (http://forums.dlink.com/index.php?topic=42457.0)

This will ensure a good clean install of FW.

What was the IP address that you found for the DIR-506L in recovery mode?  ???
Title: Re: Is it broken?
Post by: primetimelive on August 10, 2014, 10:35:14 PM
Please always follow this for doing any FW updates:
 FW Update Process (http://forums.dlink.com/index.php?topic=42457.0)

This will ensure a good clean install of FW.

What was the IP address that you found for the DIR-506L in recovery mode?  ???

192.168.123.254
Title: Re: Is it broken?
Post by: FurryNutz on August 11, 2014, 07:03:57 AM
Thank you, I'll add this information to the recovery post.  ;)