D-Link Forums

The Graveyard - Products No Longer Supported => Routers => DIR-850L => Topic started by: Koll on May 22, 2013, 12:56:35 PM

Title: Where's the DIR-845L forums?
Post by: Koll on May 22, 2013, 12:56:35 PM
I have some questions about the DIR-845L router that I bougt recently, because it drops my VPN connection after 30 mins. I've found loads of similar posts here and tried the same things, but with no success.

But where's the actual DIR-845L forums? Is it too new or is it just not supported?

I run with the latest firmware:
Current Firmware Version : 1.01
Current Firmware Time : 02/05/2013 12:08:00

I used the DIR-655 before "upgrading" and it didn't have the problems. So the only thing I changed is the router and the problems startet occuring. Same OS, ISP etc.
Title: Re: Where's the DIR-845L forums?
Post by: FurryNutz on May 22, 2013, 01:07:35 PM
Please post here in the 850L forums.

Link>Welcome! (http://forums.dlink.com/index.php?topic=41537.0)

What region are you located?
Are you wired or wireless connected to the router?

What ISP Service do you have? Cable or DSL?
What ISP Modem Mfr. and model # do you have?
Check ISP MTU requirements, Cable is usually 1500, DSL is around 1492 down to 1472. Call the ISP and ask. Link>Checking MTU Values (http://forums.dlink.com/index.php?topic=53008.0)
For DSL/PPPoE connections on the router, ensure that "Always ON" option is enabled.

Some things to try: - Log into the routers web page at 192.168.0.1. Use IE, Opera or FF to manage the router.
Turn off ALL QoS (http://vonage.nmhoy.net/qos.html) or Disable Traffic Shaping (DIR only) GameFuel (DGL only and if ON.) options. Advanced/QoS or Gamefuel.
Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual or under Setup/PARENTAL CONTROL/Set to>None: Static IP or Obtain Automatically From ISP.
Enable Use Unicasting (compatibility for some ISP DHCP Servers) under Setup/Internet/Manual.
Turn on DNS Relay under Setup/Networking. Link>Finding Faster DNS Addresses using Name Bench (http://forums.dlink.com/index.php?topic=53222.0)
Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking. This ensures each devices gets its own IP address when turned on and connected, eliminates IP address conflicts and helps in troubleshooting.
Ensure devices are set to auto obtain an IP address.
If IPv6 is an option on the router, select Local Connection Only or Disable IPv6 options under Setup/IPv6.
Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall.
Enable uPnP and Multi-cast Streaming under Advanced/Networking. Disable uPnP for testing Port Forwarding rules. Enable IPv6 Multi-cast Streaming for routers that have a Media Server option. Disable IPv6 Multi-cast Streaming if IPv6 or Media Server is not being used.
Turn off WISH, and WPS under Advanced.
WAN Port Speed set to Auto or specific speed? Some newer ISP modems support 1000Mb so manually setting to Gb speeds can be supported by the router. Advanced/Advanced Networking/WAN Port Speed
Set current Time Zone, Date and Time. Use an NTP Server (http://forums.dlink.com/index.php?topic=48695.0) feature. Tools/Time.

Can you test by inputting a MAC Filter and putting the PC that is using the VPN into this option and setting it for ALLOW and test once more. I thought i saw a thread were someone did this and it fixed there VPN connection issue.
Title: Re: Where's the DIR-845L forums?
Post by: Koll on May 22, 2013, 02:30:18 PM
Thanks for the quick reply! Here's my input:

What region are you located?
Denmark, Europe

Are you wired or wireless connected to the router?
Wired

What ISP Service do you have? Cable or DSL?
Cable

What ISP Modem Mfr. and model # do you have?
HitronTechnologies, model: BVG-3653

Check ISP MTU requirements, Cable is usually 1500, DSL is around 1492 down to 1472. Call the ISP and ask. Link>Checking MTU Values
I can see that I run with 1500 and my internet connection is "Dynamic IP (DHCP)".

For DSL/PPPoE connections on the router, ensure that "Always ON" option is enabled.
N/A

Some things to try: - Log into the routers web page at 192.168.0.1. Use IE, Opera or FF to manage the router.
Turn off ALL QoS or Disable Traffic Shaping (DIR only) GameFuel (DGL only and if ON.) options. Advanced/QoS or Gamefuel.

Already turned off QoS. I don't have the other options.

Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual or under Setup/PARENTAL CONTROL/Set to>None: Static IP or Obtain Automatically From ISP.
Don't have Advanced DNS Services.

Enable Use Unicasting (compatibility for some ISP DHCP Servers) under Setup/Internet/Manual.
Wasn't enabled, enabled it.

Turn on DNS Relay under Setup/Networking. Link>Finding Faster DNS Addresses using Name Bench
Already enabled.

Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking. This ensures each devices gets its own IP address when turned on and connected, eliminates IP address conflicts and helps in troubleshooting.
Ensure devices are set to auto obtain an IP address.

I've already added my PC, which runs on 192.168.0.100.

If IPv6 is an option on the router, select Local Connection Only or Disable IPv6 options under Setup/IPv6.
IPv6 connection is already set to "Local Connection Only".

Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall.
Already set to "Endpoint Independent" for both  TCP and UDP (one of the things I tried reading other topics).

Enable uPnP and Multi-cast Streaming under Advanced/Networking. Disable uPnP for testing Port Forwarding rules. Enable IPv6 Multi-cast Streaming for routers that have a Media Server option. Disable IPv6 Multi-cast Streaming if IPv6 or Media Server is not being used.
Turn off WISH, and WPS under Advanced.

Multicast Streams is already enabled for both IPv4 and IPv6.
UPnP IGD is already enabled.

WAN Port Speed set to Auto or specific speed? Some newer ISP modems support 1000Mb so manually setting to Gb speeds can be supported by the router. Advanced/Advanced Networking/WAN Port Speed
It's set to Auto.

Set current Time Zone, Date and Time. Use an NTP Server feature. Tools/Time.
"Automatically synchronize with D-Link's Internet time server" is checked and running against ntp1.dlink.com.

Can you test by inputting a MAC Filter and putting the PC that is using the VPN into this option and setting it for ALLOW and test once more. I thought i saw a thread were someone did this and it fixed there VPN connection issue.
Haven't tried this yet, I have nothing to select in the "DHCP Client List" dropdown, maybe it's because I have the PC in the DHCP reservation list?

I did a new test with above and the VPN dropped after 30 mins. Shall I try the MAC Filter thing? Do I then need to setup all my devices for them to keep the internet connection?
Title: Re: Where's the DIR-845L forums?
Post by: FurryNutz on May 22, 2013, 02:34:36 PM
Yes give the Mac Filter a try. If you have already reserved the IP address under Setup/Networking, then use Advanced/Network Filter I believe and input or select from the list the 1 PC. Allow the filter to manage this setting. Don't deny.

Let us know how this works.
I'll look up your modem information to see if this might be important as well.
Title: Re: Where's the DIR-845L forums?
Post by: Koll on May 23, 2013, 09:39:46 AM
Same thing, it still happens. I get these lines in the Event Viewer (Security):
Name resolution for the name pcname.domain.local timed out after none of the configured DNS servers responded.
CoID={DA7D1596-F09C-473D-9101-A188159E882D}: The connection to VPNConnection made by user Michael using device VPN3-1 was disconnected.

I guess the problem could be local and not router? Or maybe related to the type of VPN connection I use. It's just Windows 8 built-in VPN. My wife uses OpenVPN on another computer and doesn't have the problem, I learned today :)
Title: Re: Where's the DIR-845L forums?
Post by: FurryNutz on May 23, 2013, 09:41:43 AM
If this is your model ISP modem:
HitronTechnologies BVG-3653 (http://www.hitrontech.com/en/cable_detail.php?id=6)

I believe it has a built in router already...If this modem has a built in router, it's best to bridge the modem. Having 2 routers on the same line can cause connection problems: Link>Double NAT (http://www.practicallynetworked.com/networking/fixing_double_nat.htm) and How NAT Works (http://cognitiveanomalies.com/cisco-nat-how-nat-works/).
To tell if the modem is bridged or not, look at the DIR routers web page, Status/Device Info/Wan Section, if there is a 192.168.0.#  or similar address in the WAN IP address field, then the modem is not bridged.
If the modem can't be bridged then see if the modem has a DMZ option and input the IP address the router gets from the modem and put that into the modems DMZ.

This could be effecting VPN connections...

I would talk to your VPN provider and ask if there is any additional configuration information they can help with as well.
Title: Re: Where's the DIR-845L forums?
Post by: Koll on May 23, 2013, 09:46:58 AM
Yes, that's the modem!

My WAN infos are like these, just "scrambled" before posting here, but the first digit is correct:

IP Address : 89.213.252.24
Subnet Mask : 255.255.255.0
Default Gateway : 89.213.252.1
Primary DNS Server : 82.143.198.50
Secondary DNS Server : 82.143.199.51

So that's fine if I understand what you wrote :)
Title: Re: Where's the DIR-845L forums?
Post by: Koll on May 23, 2013, 09:48:20 AM
I've tried deleting the VPN connection and I've set it up again from scratch, I'll see how that works also.
Title: Re: Where's the DIR-845L forums?
Post by: FurryNutz on May 23, 2013, 10:02:03 AM
OK, keep us posted.
Title: Re: Where's the DIR-845L forums?
Post by: Koll on May 23, 2013, 10:28:29 AM
No luck, it happened Again  :-\
Title: Re: Where's the DIR-845L forums?
Post by: Koll on June 06, 2013, 12:51:44 PM
I'm I really the only one running PPP type VPN with this router and have the problem? :)
I'm considdering getting rid of it for another, it's really annoying... It also seems like the router can be slightly unstable each hour or something like that. As if the internet connection sets out and comes again quite fast. Enough for a game to show delay/disconnect prompt, but then quickly go away again. I don't have these problems when connected directly to my modem.
Title: Re: Where's the DIR-845L forums?
Post by: FurryNutz on June 06, 2013, 01:01:01 PM
I recommend that you have your ISP check the cabling going to the ISP modem, check signal levels going to the ISP modem. Check for t.v. line splitters and remove them as they can introduce noise on the line and lower the signal going to the ISP modem. Connecting to the ISP modem could result in a false positive as the signal to the modem could be just enough to that point then adding on a router, could see problems. The router operation is dependent upon getting good data flow from the ISP modem and the modem is dependent upon getting good signal from the ISP Service.

One thing you could try, un-bridge the ISP modem then put the IP address that the 845 gets from the ISP Modem into the modems DMZ if it has this feature then test.

You could also configure the 845 in AP mode mentioned on page 11 of the user manual if you use the ISP modem as your main host router and see if the problem persists.

If the problem persists, I would contact your regional D-Link support office and inquire about this. It seems there could be an issue between the ISP modem and this router.
Title: Re: Where's the DIR-845L forums?
Post by: Koll on June 13, 2013, 09:59:44 AM
The issue is resolved... but I'm afraid to say it was my ISP which was unstable! Sorry for the trouble, since they checked it and fixed it I haven't had any problems :)
Title: Re: Where's the DIR-845L forums? (RESOLVED)
Post by: FurryNutz on June 13, 2013, 10:19:07 AM
Good to hear they took action and got it figured out.

Come back and visit if you need.

Enjoy.  ;)