D-Link Forums

The Graveyard - Products No Longer Supported => Routers => DIR-857 => Topic started by: mleise on April 13, 2013, 06:30:16 PM

Title: iPhone 4S won't connect automatically
Post by: mleise on April 13, 2013, 06:30:16 PM
Hello, I recently had to reset my DIR-857. When I was going through the set up via original cd I noticed the router assigned two different access points. One for 2.4 and a second default named dlink-media for 5ghz. My iPads are able to connect to the dlink-media and they connect automatically when I turn them on. My iPhone 4S however will no longer connect automatically forcing me to enter my password every time. I have already reset the iPhones network settings and still it will no longer connect with out me entering the password. Also I should not when I enter the password and click join it says "failed to join dlink" I click join again with out changing anything and it will join. Is there a setting I need to check/change? Thanks in advance for your help.
Title: Re: iPhone 4S won't connect automatically
Post by: FurryNutz on April 14, 2013, 10:14:43 AM
Link>Welcome! (http://forums.dlink.com/index.php?topic=41537.0)
Link>What Firmware (http://forums.dlink.com/index.php?topic=47512.0) version is currently loaded? Found on routers web page under status.
What region are you located?

Some things to try: - Log into the routers web page at 192.168.0.1. Use IE, Opera or FF to manage the router.
Turn off ALL QoS (http://vonage.nmhoy.net/qos.html) or Disable Traffic Shaping (DIR only) GameFuel (DGL only and if ON.) options. Advanced/QoS or Gamefuel.
Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual or under Setup/PARENTAL CONTROL/Set to>None: Static IP or Obtain Automatically From ISP.
Enable Use Unicasting (compatibility for some ISP DHCP Servers) under Setup/Internet/Manual.
Turn on DNS Relay under Setup/Networking.
Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking. This ensures each devices gets its own IP address when turned on and connected, eliminates IP address conflicts and helps in troubleshooting.
Ensure devices are set to auto obtain an IP address.
If IPv6 is an option on the router, select Local Connection Only or Disable IPv6 options under Setup/IPv6.
Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall.
Enable uPnP and Multi-cast Streaming under Advanced/Networking. Disable uPnP for testing Port Forwarding rules.
Turn off WISH, and WPS under Advanced.
WAN Port Speed set to Auto or specific speed? Some newer ISP modems support 1000Mb so manually setting to Gb speeds can be supported by the router. Advanced/Advanced Networking/WAN Port Speed
Set current Time Zone, Date and Time. Use an NTP server feature. Tools/Time.

What wireless modes are you using? Under Setup/Wireless/Manual.
Ensure you change the default SSID name of each radio to something different different, can be anything and make it fun.
Try single mode G or mixed G and N on 2.4Ghz and single mode N on 5Ghz?
Channel Width set for Auto 20/40Mhz or try 20Mhz only.
Try setting a manual channel to a open or unused channel. 1, 6 or 11. 11 for single mode N if the channel is clear.
What security mode are you using? Preferred security is WPA-Personal. WPA2/AES Only. Some WiFi adapters don't support AES, so you might want to try TPIK only or Auto.
Any cordless house phones?
Any other WiFi routers in the area? Link> Use InSSIDer (http://www.metageek.net/) to find out. How many?

Enable WMM Enable (http://forums.dlink.com/index.php?topic=50738.0) Under Advanced/Advanced Wireless.
Title: Re: iPhone 4S won't connect automatically
Post by: mleise on April 17, 2013, 08:27:13 AM
Thanks for getting back to me on this. There is a lot of things to try here so it may take me a few days before I get to all of them. I really don't want to disable my qos as that is the main reason for purchasing this router. At any one time I have 2people streaming Netflix and multiple tablets running. I have a qos rule for my Xbox live only. I will try everything else first. I will follow up once I have a chance to try all your suggestions.
Title: Re: iPhone 4S won't connect automatically
Post by: FurryNutz on April 17, 2013, 08:43:06 AM
If you have others streaming Netflix and surfing internet, you'll need to review this as well:
DIR-857 Gaming and Gamefuel for XBL (http://forums.dlink.com/index.php?topic=47344.0)

Keep us posted.
Title: Re: iPhone 4S won't connect automatically
Post by: mleise on April 17, 2013, 09:39:35 AM
Thanks, I have already set up the QOS per your very well written instruction. I know I have never updated the firmware, you helped me before and recomended not upgrading firmware unless I was having some type of issue. Do you recomend updating firmware now? If so I know there is a way to save the current router settings as a file then I can import thoses saved settings once the update is done however I have not seen anywhere to do that within the router. Is there a step by step topic on this already? I am not smart when it comes to networks, but I can follow step by step instructions pretty darn good.
Title: Re: iPhone 4S won't connect automatically
Post by: mleise on April 17, 2013, 09:45:22 AM
I am also a little concerned about all the things you have listed to try. Everytihing is working fine except the iphone will no longer connect automatially. Will changing any of these other settings like unchecking DNS affect other areas of the network? My thought is that the router is now running dual band, witch it wasnt before has something to do with this. I would like to go back to just  2.4 however the ipads would not connect by themselfs when logging into side. I had to sign them into the 5ghz side in order to get them to connect with out having to enter the password every time.
Title: Re: iPhone 4S won't connect automatically
Post by: FurryNutz on April 17, 2013, 09:52:31 AM
What version of FW is currently loaded?
Lets try some of the suggestions mentioned in my first reply and see if that helps out first. It should.
Title: Re: iPhone 4S won't connect automatically
Post by: mleise on April 17, 2013, 10:11:48 AM
running firmware 1.0  Are there any of the original suggestions that you think may be more likely than then others. the first suggestion says to disable QOS. However running 2 tv's streaming netflix and trying to play xbox live the QOS is 100% the reason I bought this router. If I have to disable the QOS I may as well just go back to my WTR54G.
Title: Re: iPhone 4S won't connect automatically
Post by: FurryNutz on April 17, 2013, 10:41:46 AM
Keep QoS enabled. Check the suggested wireless settings.
Title: Re: iPhone 4S won't connect automatically
Post by: mleise on April 17, 2013, 11:02:41 AM
Sounds good, might not get to this until the weekend but I will follow up either way on this. Thanks Furry - Mike
Title: Re: iPhone 4S won't connect automatically
Post by: FurryNutz on April 17, 2013, 11:04:16 AM
 ;)
Title: Re: iPhone 4S won't connect automatically
Post by: mleise on April 19, 2013, 07:51:31 AM
ok I had a chance to try this. iphone still makes me enter password every time and I have to manually join network.

Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual or under Setup/PARENTAL CONTROL/Set to>None: Static IP or Obtain Automatically From ISP. DEFAULT SET THIS WAS
Enable Use Unicasting (compatibility for some ISP DHCP Servers) under Setup/Internet/Manual. ENABLED BY DEFAULT
Turn on DNS Relay under Setup/Networking. COULD NOT FIND THIS SETTING
Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking. This ensures each devices gets its own IP address when turned on and connected, eliminates IP address conflicts and helps in troubleshooting. DONE
Ensure devices are set to auto obtain an IP address. NOT SURE HOW TO DO THIS BUT PHONE USED TO CONNECT NO PROBLEMS
If IPv6 is an option on the router, select Local Connection Only or Disable IPv6 options under Setup/IPv6. SET THIS WAY BY DEFAULT
Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall. COULD NOT FIND THIS SETTING
Enable uPnP and Multi-cast Streaming under Advanced/Networking. ENABLED BY DEFAULT
Disable uPnP for testing Port Forwarding rules. COULD NOT FIND THS SETTING
Turn off WISH, and WPS under Advanced.
WAN Port Speed set to Auto or specific speed? AUTO Some newer ISP modems support 1000Mb so manually setting to Gb speeds can be supported by the router. Advanced/Advanced Networking/WAN Port Speed
Set current Time Zone, Date and Time. Use an NTP server feature. Tools/Time. DONE

The one thing the router is doing different than before is running dual band. I dont have a problem switching back to 2.4 only however the ipads would not stay connected when I first joined that part of the network. I would have to join the network manually and enter password every time. Once I joined the dlink-media wich I assume is the 5ghz they connect automatically as they used to.

What wireless modes are you using? Under Setup/Wireless/Manual.
Ensure you change the default SSID name of each radio to something different different, can be anything and make it fun.
Try single mode G or mixed G and N on 2.4Ghz and single mode N on 5Ghz?
Channel Width set for Auto 20/40Mhz or try 20Mhz only.
Try setting a manual channel to a open or unused channel. 1, 6 or 11. 11 for single mode N if the channel is clear.
What security mode are you using? Preferred security is WPA-Personal. WPA2/AES Only. Some WiFi adapters don't support AES, so you might want to try TPIK only or Auto.
Any cordless house phones?
Any other WiFi routers in the area? Link> Use InSSIDer to find out. How many?

Enable WMM Enable Under Advanced/Advanced Wireless.
Title: Re: iPhone 4S won't connect automatically
Post by: FurryNutz on April 19, 2013, 08:15:10 AM
Ensure you change the default SSID name of each radio to something different different, can be anything and make it fun.
Channel Width set for Auto 20/40Mhz
Preferred security is WPA-Personal. WPA2/AES Only.


What iOS is loaded on the iPhone? Mine got 6.1.2...
Title: Re: iPhone 4S won't connect automatically
Post by: mleise on April 19, 2013, 08:34:29 AM
Sorry, forgot to finish filling this out  :o
Try single mode G or mixed G and N on 2.4Ghz and single mode N on 5Ghz? CHANGED TO SINGLE MODE
Channel Width set for Auto 20/40Mhz or try 20Mhz only. CHANGED TO 20mhz
Try setting a manual channel to a open or unused channel. 1, 6 or 11. 11 for single mode N if the channel is clear. COULDNT FIND THIS SETTING
What security mode are you using? Preferred security is WPA-Personal. WPA2/AES Only. Some WiFi adapters don't support AES, so you might want to try TPIK only or Auto. WPA-PERSONAL
Any cordless house phones? YES BUT NOT IN USE SHOULD THEY BE UNPLUGGED?
Any other WiFi routers in the area? Link> Use InSSIDer to find out. How many? 1 OTHER ROUTER IN AREA INSIDDER SHOWS ME ON CHANNEL ONE AND THE OTHER ON CHANNEL 11.

Oh and I changed SSID on both bands... I wont know until tonight if it will connect auto.
Title: Re: iPhone 4S won't connect automatically
Post by: FurryNutz on April 19, 2013, 08:40:01 AM

Sorry, forgot to finish filling this out  :o
Try single mode G or mixed G and N on 2.4Ghz and single mode N on 5Ghz? CHANGED TO SINGLE MODE
Channel Width set for Auto 20/40Mhz or try 20Mhz only. CHANGED TO 20mhz
Try setting a manual channel to a open or unused channel. 1, 6 or 11. 11 for single mode N if the channel is clear. COULDNT FIND THIS SETTING Uncheck Auto Channel Scan and then you should see a drop down menu to manually select channels from.
What security mode are you using? Preferred security is WPA-Personal. WPA2/AES Only. Some WiFi adapters don't support AES, so you might want to try TPIK only or Auto. WPA-PERSONAL
Any cordless house phones? YES BUT NOT IN USE SHOULD THEY BE UNPLUGGED? Could run a test with them unplugged. They shouldn't interfere if there not in use. Are they running on or near the 2.4Ghz frequency?
Any other WiFi routers in the area? Link> Use InSSIDer to find out. How many? 1 OTHER ROUTER IN AREA INSIDDER SHOWS ME ON CHANNEL ONE AND THE OTHER ON CHANNEL 11.
Just make sure your not running on the same channel as the other neighboring WiFi is different. I think your ok for now.
Oh and I changed SSID on both bands... I wont know until tonight if it will connect auto.

What iOS is loaded on the iPhone? Mine got 6.1.2...
Title: Re: iPhone 4S won't connect automatically
Post by: mleise on April 19, 2013, 10:34:25 AM
iPhone is running 6.1.3.  It hasn't been updated since the router reset though. What do you recomenvtrying next? Setting the channel to 1?  The cordless phones are 2.4 however they are on there base and didn't seem to interfere before the reset.
Title: Re: iPhone 4S won't connect automatically
Post by: FurryNutz on April 19, 2013, 12:21:26 PM
I don't think there is any issue or changes we can do the router as it seems that your iPhone is having the problem remembering the last working wireless connection.

What current FW is loaded right now?
Title: Re: iPhone 4S won't connect automatically
Post by: mleise on April 19, 2013, 12:38:34 PM
FW is 1.0. same as it was before I did the reset. I wouldnt mind updating the FW, isnt there a way to save the current settings on the router and then just reload that file once the FW is updated? I would hate to have to reconfig everything as I just did that last saturday.

I know it would seem the phone is the issue however I had no problems with it up until the point I pushed the reset button. I am not sure how it could be the phone when it worked fine before the reset. According to the Apple forums this has happend to other users with various routers and the fix is to clear the network settings. I have done this and it did not rectify my issue. Again it just started doing this after I pushed the reset button.

Thank you for trying
Title: Re: iPhone 4S won't connect automatically
Post by: FurryNutz on April 19, 2013, 12:48:45 PM
I'll recommend that you do the following and upgrade to v1.04:
FW Update Process (http://forums.dlink.com/index.php?topic=42457.0)

After the final factory reset, do not reload the saved configuration file, set up the router from scratch initially, change the SSID on the radios to something different, configure both to use WPA2 and AES only and Leave AutoScan enabled and Auto 20/40Mhz. Test the iPhone.

My 4S works well with these settings however you are on a newer version of iOS.

Let us know how it goes.
Title: Re: iPhone 4S won't connect automatically
Post by: mleise on April 20, 2013, 09:10:08 AM
Wow, I can't believe the one thing I thought would make absolutely no difference made all the difference in the world. Changed the network name and iPhone connects every time now! Thanks for the help!
Title: Re: iPhone 4S won't connect automatically (RESOLVED)
Post by: FurryNutz on April 20, 2013, 12:09:36 PM
Enjoy.  ;)
Title: Re: iPhone 4S won't connect automatically
Post by: mleise on April 20, 2013, 09:32:03 PM
You "DA" man furry!
Title: Re: iPhone 4S won't connect automatically
Post by: FurryNutz on April 21, 2013, 09:08:11 AM
 ::)