D-Link Forums

The Graveyard - Products No Longer Supported => DIR-655 => Routers => Europe DIR-655 => Topic started by: Cigaras on February 12, 2013, 03:54:13 AM

Title: LG SmartTV remote error
Post by: Cigaras on February 12, 2013, 03:54:13 AM
Hello, I have some problems with mu DIR-655 B1 router, some time ago multicast streaming didn't work, so I flashed Russian version (http://forums.dlink.com/index.php?topic=42193.0) and some time later I connect LG 42LW650s TV to this router through wire and installed LG TV Remote app (https://play.google.com/store/apps/details?id=com.clipcomm.WiFiRemocon&hl=en) on my phone, everything worked fine.

A few days ago, I needed to set up a static DHCP, to reserve some ip addresses and wasn't able to do so with my old firmware, so I updated it to a later Russian version, DIR655_FW200RUB13Beta06.bin (http://ftp.dlink.ru/pub/Router/DIR-655/Firmware/REV_B/) and thats were stuff went downhill: multicast streaming works, DHCP works, however LG Remote app no longer works, phone is unable to connect with TV.

I am not a networking expert or something, but IF I understand correctly, thats how phone-tv connecting works:So the problem is that my phone doesn't recive the first answer from TV somewhy, TV knows that someone is trying to connect, shows the connection dialog box, but doesn't show the pairing code because my phone doesn't confirm himself. However everything works with my older DIR-300 router, phone and PC are easily paired, however DIR-300 is too slow for me :(

So I retried all of the Russian firmwares, done factory reset for the router multiple times, tried all three firmwares from http://www.dlink.com/uk/en/support/product/dir-655-wireless-n-gigabit-router with no success, DIR-655_fw_revb_205b06_ALL_de_20120118 worked for the first time, however when I tried to reconect, I was unable to locate the TV again, so I am starting to think it's not firmwares fault, any thoughts?
Title: Re: LG SmartTV remote error
Post by: FurryNutz on February 12, 2013, 09:52:08 AM
Link>Welcome! (http://forums.dlink.com/index.php?topic=41537.0)
What Hardware version is your router? Look at sticker under router.
Link>What Firmware (http://forums.dlink.com/index.php?topic=47512.0) version is currently loaded? Found on routers web page under status.
What region are you located?

Has a Factory Reset been performed before and after the FW update?
Are these devices wired or wireless?

Some things to try: - Log into the routers web page at Use IE, Opera or FF to manage the router.
Turn off ALL QoS (http://vonage.nmhoy.net/qos.html) or Disable Traffic Shaping (DIR only) GameFuel (DGL only and if ON.) options. Advanced/QoS or Gamefuel.
Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual.
Turn on DNS Relay under Setup/Networking.
Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking. This ensures each devices gets its own IP address when turned on and connected, eliminates IP address conflicts and helps in troubleshooting.
Ensure devices are set to auto obtain an IP address.
If IPv6 is an option on the router, select Local Connection Only or Disable IPv6 options under Setup/IPv6.
Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall.
Enable uPnP and Multi-cast Streaming under Advanced/Networking. Disable uPnP for testing Port Forwarding rules.
WAN Port Speed set to Auto or specific speed? Some newer ISP modems support 1000Mb so manually setting to Gb speeds can be supported by the router. Advanced/Advanced Networking/WAN Port Speed
Set current Time Zone, Date and Time. Use an NTP server feature. Tools/Time.
Title: Re: LG SmartTV remote error
Post by: Cigaras on February 13, 2013, 11:03:43 AM
H/W ver. B1
I am located in Lithuania, so don't know what region it belongs to

Curently I'm using FW ver. 2.05, 18, Jan, 2012 (DIR-655_fw_revb_205b06_ALL_de_20120118)
QoS disabled
No Advanced DNS Services
No DNS Relay
DHCP is set, working properly
for IPv6 I need more information, I can't find how disable it or how to select Local Connection Only
Endpoint Independent set
uPnP and Multi-cast Streaming enabled, working properly
WAN port speed set to auto
Time set

No luck :(
Title: Re: LG SmartTV remote error
Post by: FurryNutz on February 13, 2013, 11:13:47 AM
Have you tried to downgrade to that Russian version that was working?

I would try this, before you do, Disconnect the ISP modem from the router. Connect 1 WIRED PC to the LAN port on the back of the router. Do a factory reset before and after sending the FW file. Then set up the router from scratch with the TV.

You should be able to set a IP reservation for the TV and phone.
Title: Re: LG SmartTV remote error
Post by: Cigaras on February 14, 2013, 11:09:52 PM
I tested some older RU and WW and it looks that factory reset before and after flashing drasticaly improves everyting, one more this to note - there is something buggy with soft rebooting the router, because usualy after setting it up and doing soft reboot nothing works properly, but after hard reboot, turning off the power supply, everything works. However with newer firmawares (dated for end of 2012 year and begining of 2012) internetn connection is very usntable, speed gradualy drops to like 30% and then goes back... I'll do more testing this weekend.
Title: Re: LG SmartTV remote error
Post by: FurryNutz on February 15, 2013, 07:43:17 AM
What ISP Service do you have? Cable or DSL?
What ISP Modem make and model do you have?
Title: Re: LG SmartTV remote error
Post by: FurryNutz on February 21, 2013, 07:18:44 AM
Any status on this?  ???
Title: Re: LG SmartTV remote error
Post by: ZMEU.NET on March 05, 2013, 02:10:25 AM
It is the same problem with my printer  and i suspect my wifi tv :))  These devices are not always connected and can not auto reconnect like PCs do after a router reboot.