D-Link Forums

The Graveyard - Products No Longer Supported => Routers => DIR-857 => Topic started by: FurryNutz on November 20, 2012, 02:32:10 PM

Title: DIR-857 v1.03 FW Released
Post by: FurryNutz on November 20, 2012, 02:32:10 PM
Get it here:
DIR-857 v1.03 FW Released (http://forums.dlink.com/index.php?topic=51265.0)

Let us know how it works for you.
Title: Re: DIR-857 v1.03 FW Released
Post by: coldeagle on December 21, 2012, 10:11:37 PM
I've been having issues of wireless dropping from a couple of devices. Tonight I came home and had to power cycle the router. Then a few minutes later the connection dropped on my laptop. I got signal, had an IP still, not able to ping. I love the router when it works, but having to reset my wireless adapter daily is getting annoying. I know it's not interference because I've got it set on A preference (not able to do simultaneous dual-band unfortunately) and I'm 10 feet away.

Based on the release notes I was hoping that the wireless issue would have been resolved, but it appears as if no such luck (the release notes are really scanty btw, I used to work for Linksys and guess I'm used to getting the more nitty gritty releases lol). I haven't tried a full factory reset, but I'm interested to see if anyone else has had luck before I go about that. I know it has a back up feature, but I know often times the same bugs you're trying to fix are going to re-appear when you use a backup (well in Linksys models that's the case and I know D-Link and Linksys use a lot of the same ODM's, heck you used to be able to swap firmware between D-Link and Linksys units back when I did tech support on the original 802.11b devices :P), and I'm not sure I want to go about re-setting doing my settings.

Anyways, any recommendations? When I was researching this router I know it was a reported issue (http://reviews.cnet.com/routers/d-link-dir-857/4505-3319_7-35117978-2.html), but I was hoping that the latest firmware would fix the issues. I love the routers performance, can't be beat hands down!
Title: Re: DIR-857 v1.03 FW Released
Post by: coldeagle on December 21, 2012, 10:16:17 PM
Oh and I forgot to mention, already did the troubleshooting steps outlined in a couple of other threads. Most of the problems I've seen there are usually when they're not using 802.11a, which I'm forcing my wireless devices to use simply because I've got about 5 other wireless networks in the area and prefer to have an uncluttered network connection.
Title: Re: DIR-857 v1.03 FW Released
Post by: FurryNutz on December 22, 2012, 08:43:43 PM
Link>Welcome! (http://forums.dlink.com/index.php?topic=41537.0)

What region are you located?
Has a Factory Reset been performed before and after the FW upgrade? What version of FW was previously loaded? Was there a reason to upgrading? Was this happening before upgrading?

What ISP Service do you have? Cable or DSL?
What ISP Modem do you have? Stand Alone or built in router?
What ISP Modem make and model do you have?
If this modem has a built in router, it's best to bridge the modem. Having 2 routers on the same line can cause connection problems.
Double NAT (http://www.practicallynetworked.com/networking/fixing_double_nat.htm)
To tell if the modem is bridged or not, look at the routers web page, Status/Device Info/Wan Section, if there is a 192.168.0.# address in the WAN IP address field, then the modem is not bridged.
If the modem can't be bridged then see if the modem has a DMZ option and input the IP address the router gets from the modem and put that into the modems DMZ.

Some things to try: - Log into the routers web page at
Turn off ALL QoS (http://vonage.nmhoy.net/qos.html) or Disable Traffic Shaping (DIR only) GameFuel (DGL only and if ON.) options. Advanced/QoS or Gamefuel.
Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual.
Turn on DNS Relay under Setup/Networking.
Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking
Ensure devices are set to auto obtain an IP address.
Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall.
Enable uPnP and Multi-cast Streaming under Advanced/Networking. Disable uPnP for testing Port Forwarding rules.
WAN Port Speed set to Auto or specific speed? Some newer ISP modems support 1000Mb so manually setting to Gb speeds can be supported by the router. Advanced/Advanced Networking/WAN Port Speed

What wireless modes are you using? Under Setup/Wireless/Manual.
Try single mode G or mixed G and N on 2.4Ghz and single mode N on 5Ghz?
Channel Width set for Auto 20/40Mhz or try 20Mhz only.
Try setting a manual channel to a open or unused channel. 1, 6 or 11. 11 for single mode N if the channel is clear.
What security mode are you using? Preferred security is WPA-Personal. WPA2/AES Only. Some WiFi adapters don't support AES, so you might want to try TPIK only or Auto.

Any cordless house phones?
Any other WiFi routers in the area? If you have 5, you should see what channels are being used by they other 5 and adjust the manual channel on the router accordingly and set for a clear and unused channel.
Turn off WISH, and WPS under Advanced.
Try turning off Short GI. Under Advanced/Advanced Wireless.
Enable WMM Enable (http://forums.dlink.com/index.php?topic=50738.0) Under Advanced/Advanced Wireless.

Turn off all anti virus and firewall programs on PC while testing. 3rd party firewalls are not generally needed when using routers as they are effective on blocking malicious inbound traffic.
Turn off all devices accept for one wired PC while testing.
Title: Re: DIR-857 v1.03 FW Released
Post by: coldeagle on December 22, 2012, 09:00:14 PM
LOL as I said in my previous post, I'm working on 802.11a not g. Already did those recommendations. I've got a stand alone cable modem. It's not an ISP issue, nor WAN related issue. The problem is communication to the router wirelessly. Hardwired everything is fine and I have my adapter set to A only so I know it's not an interference issue. There are no 802.11a capable networks near me based on the site survey. There are only 3 "real" channels within the 2.4 GHz (1,6,11) the rest cross (again, I used to do advanced tech support for Linksys. It was 9 or 10 years ago, but what made me a great tech support person hasn't gone away even though I do IT related functions that make more money now). I've tried going static too and the problem still crops up. The only thing that appears to work is to "reset" the adapter by turning off the adapter and turning it back on.
Title: Re: DIR-857 v1.03 FW Released
Post by: FurryNutz on December 22, 2012, 09:05:32 PM
Does this happen with other modes? G or N?
Is the routers channel on any of the same other channels being used?
Does this happen with ALL wifi devices or only one specific device?

I presume that somethings have changed in 10 years as well.
Title: Re: DIR-857 v1.03 FW Released
Post by: coldeagle on December 22, 2012, 09:15:34 PM
I haven't tried it with this firmware version, but that's why I switched to A in the first place because I suspected the same thing. I only have one device on the network wirelessly constantly. My iPhone and iPad will go into sleep mode and disconnect from the wireless network so I can't be sure that they're going to present the same issue. I can try to leave my work laptop on and see if it presents the same issue.

LOL not that much has changed :P Things have gotten faster, and I still kept my hands in until about 5 years ago (I had to, because I designed a lot of the troubleshooting tools). The basics don't change much as far as figuring out wireless interference issues, WAN and all that kind of stuff. I still do technical stuff, just not as much on the networking side any more :P
Title: Re: DIR-857 v1.03 FW Released
Post by: FurryNutz on December 22, 2012, 09:21:44 PM
You might find somethings have changed, some things.

Try a factory reset and reconfigure the router for Mixed G and N or or leave it Mixed ALL modes and test. I don't see this with my iphones, macbook and DWA-160 connected devices. However I run Mixed G and N modes on 2.4Ghz and single mode N on 5Ghz.

Try changing some of the options as well, specially disable Short GI and see. You could test the iphone and ipad to see..disable them from sleeping.
Title: Re: DIR-857 v1.03 FW Released
Post by: coldeagle on January 05, 2013, 11:12:07 AM
Still occurring across multiple devices :( Did all the recommendations. Simply restarting the wireless on the device seems to resolve the issue though.
Title: Re: DIR-857 v1.03 FW Released
Post by: FurryNutz on January 05, 2013, 11:23:52 AM
Does this still happen if you turn off the 2.4Ghz radio and leave the 5Ghz radio going? I would then test both radios off to make sure that Wired connections still work as well. I presume wired LAN isn't effected.

Just seems like something in your area is causing the WiFi to act up. Kargo27 has the same problem with his. He sent me 2 857s last year to test, both testing fine here at my house. One item that he does have to deal with is that his ISP has additional WiFi for video in his out, both 2.4Ghz and 5Ghz. He also had his 857 sitting right next to the 2.4Ghz modem. We got him to move the 857 father away and did some other settings. Helped some, yet sometimes he gets some disconnects. I think his area is just congested with WiFi. I only have one other neighbor here with WiFi so i think my area is fairly clean. I'm currently running my 857, however do have 2 other APs going. One in 5Ghz only and another in the living room with both 2.4Ghz and 5Ghz. The one in the living room is set up for low power, while the 5Ghz is set for high serving a roommate down stairs for xbox. I set the 857 in the next room over for medium power on 5Ghz. Left 2.4Ghz on HIGH. All radios are using different channels, 1, 6 and 11 and using same SSIDs.

Any chance you can test this out in a different area and see if the problem follows? At a friend or families place maybe? I would also try setting the Power Output of the router from HIGH to medium and see if this might help some.