D-Link Forums

D-Link Network Storage => DNS-320L => Topic started by: sylk78 on November 12, 2012, 12:35:37 PM

Title: Mail configuration
Post by: sylk78 on November 12, 2012, 12:35:37 PM
Hello :)

Here an how-to:

I use a gmail account

fw 1.0

Username: myemail@gmail.com
Password: my gmail password
Port: 587
SMTP server: smtp.gmail.com
Sender Email: myemail@gmail.com
Receiver Email: myemail@gmail.com
use : STARTTLS

That work for me :)

Tips:
As sender Email use myemail+[label]@gmail.com for an easier filtering.
example : titifoo+nas@gmail.com

Regards,
Cedric.
Title: Re: Mail configuration
Post by: Turcy086 on June 21, 2013, 11:18:59 AM
Yes is know, you write your issue more than half year, but check this:

http://email.about.com/od/accessinggmail/f/Gmail_SMTP_Settings.htm

Maybe the port that you write is bad :\
Title: Re: Mail configuration
Post by: zdravo on November 02, 2015, 10:38:54 AM
This topic is pretty dead, but I am having the same problem.

So, I cannot configure it to send me a notification mail from my gmail account.
Why?

FW 1.04
Title: Re: Mail configuration
Post by: FurryNutz on November 02, 2015, 11:29:00 AM
Link>Welcome! (http://forums.dlink.com/index.php?topic=48135.0)



What Mfr and model is the main host router?
Is the DNS getting a Dynamic IP address from the main host router? I recommend using a Static IP address ON the DNS set to 192.168.#.34 or .40.

Setting up email on DCS series cameras FAQ - http://forums.dlink.com/index.php?topic=63536.0 (http://forums.dlink.com/index.php?topic=63536.0)

This topic is pretty dead, but I am having the same problem.

So, I cannot configure it to send me a notification mail from my gmail account.
Why?

FW 1.04
Title: Re: Mail configuration
Post by: ivan on November 03, 2015, 08:36:29 AM
First thing, the settings for sending must be correct.

The user name/password are what is used to log in to the NAS shares from a computer on the network.

For the port and SMTP Server see https://support.google.com/a/answer/176600?hl=en (https://support.google.com/a/answer/176600?hl=en)  Although they mention printer etc. it is the same for the NAS.

The sender should be something to define the NAS (example: my.nas@myhome.com)

SMTP Auth - see the info in the above link.

Finally do a test send to check it is up and running.

Don't forget to save settings and also set what information you want to get from the NAS box.

The receiver is your gmail name@gmail.com
Title: Re: Mail configuration
Post by: s0litaire on January 15, 2016, 09:06:01 PM
If you are sending to a legitimate Google email then:

Select "ANONYMOUS"
use Port "25"
Then use this SMTP server "aspmx.l.google.com"
Enter in the email you wish to send to in the "Sender E-Mail" box (This can be your gmail email adderss)
Enter in your Gmail address in the  "Reciever E-mail" box
Set "Secure Connection" to "NONE"

That is what I'm using and Iím getting emails from my NAS weekly

This only works if you are sending TO a google address, sending to other addresses will not work.

If you are still not getting emails check your SPAM folder as google might place them in there.
Also you might need to check if port 25 is blocked or opened on your router (most routers have a "port forwarding" or "port opening" option make sure it is set to allow port 25 from your NAS) check the routers help pages or ISP's website of you can't find the option.
Title: Re: Mail configuration
Post by: Don_CA on May 26, 2018, 05:10:58 AM
My email used to work, then stopped a few months ago with no changes on my end.  Anyone else still using gmail for this? 
Title: Re: Mail configuration
Post by: FurryNutz on May 26, 2018, 08:49:40 AM
Check with Google mail and see if there service configurations have changed. Usually this is the case if you haven't done anything to the DNS...

My email used to work, then stopped a few months ago with no changes on my end.  Anyone else still using gmail for this?
Title: Re: Mail configuration
Post by: GreenBay42 on May 29, 2018, 07:17:10 AM
Follow these steps:

https://support.dlink.com/FAQView.aspx?f=EtsWnye%2f5hsweBlN5IYO0A%3d%3d (https://support.dlink.com/FAQView.aspx?f=EtsWnye%2f5hsweBlN5IYO0A%3d%3d)
Title: Re: Mail configuration
Post by: Fabiano Pinheiro on May 30, 2018, 07:57:39 AM
you will have to change the security settings on google

https://myaccount.google.com/security

Allow less secure apps: ON

and work again  ;) ;)
Title: Re: Mail configuration
Post by: FurryNutz on May 30, 2018, 08:51:20 AM
Hope this helps future users. Thanks for posting this information.

you will have to change the security settings on google

https://myaccount.google.com/security

Allow less secure apps: ON

and work again  ;) ;)