D-Link Forums

The Graveyard - Products No Longer Supported => IP Cameras => DCS-942L => Topic started by: Juancito on June 19, 2012, 08:56:43 AM

Title: DCS-942L Issue
Post by: Juancito on June 19, 2012, 08:56:43 AM
Hello everybody.
I bought the DCS-942L like 3 week ago and been fighting with it on and off since then, first with the activex issue, then with some firewall problem. Then I had it running and the only problem was the camera was freezing after 4 or 5 hours of upstreaming. It would have green LED but it was not possible to access on dlink cloud website or iphone app. Only solution was turn power to camera off and the on again. So I improved my upstream speed to see if this would help( from DSL Lite to DSL Xtreme). This didn't do it. Last I did was upgrading firmware from original 1.00 522 to 1.11 1426 WW ( I'm in US), and this made it worse. Not when I go to Advanced settings ( I always get the certificate error message, but always hit "go to website anyway"), I get the gray and orange page, but every tab on top ( SETUP, MAINTENACE, STATUS, HELP) shown nothing but a blank space underneath, no menus no buttons to hit, just white space. I almost to the point off tossing camera in the forgotten items closet. Any help would be greatly appreciated.
Title: Re: DCS-942L Issue
Post by: adillon63 on June 20, 2012, 07:17:42 AM
Good Morning,
   My 942L was working fine on the old firmware but I was hoping the upgrade would more closely match the features of the 932L. After upgrading the firmware to 1.11 I had the same issue when accessing the camera. All the menu items were blank. I performed a hard reset and reconfigured the camera again. All the menus returned and I was able to start getting the settings the way I like them. But as soon as I set it to static IP. I lost all the menus again  :(. Performed another hard reset and they returned. I will do more testing tonight when I get home but the camera is working right now but with DHCP addressing.
Is anyone else having a problem with 1.11?
Title: Re: DCS-942L Issue
Post by: Juancito on June 21, 2012, 07:23:07 AM
Hi Adillon, thanks for the info.
 I had tried the hard reset already( paper clip in tiny hole hold 5 or 6 sec, light flash red/green), and the crazy thing is after I install camera again with wizard, camera firmware is still 1.11 1426, I wouldn't go back to 1.00 522, which is the original in my case. The other crazy thing is all content in advanced settings is blank only in English, as for some reason (trying this and that), when in "Live Video tab" I changed language from English to one of the 2 Asian languages, and voila !!!, everything is there, yes all options and buttons, BUT they are in Chinese/ Taiwanese or something.
Good stuff I found a way around this. When you hit "advanced settings" it opens second IE window in secure mode, but address is camera IP, so I just open this on my own, cut and paste, but without the little "s" in the http, and it shows no certificate errors and all options work fine in English.
They advertise camera as :"mydlink-enabled network cameras were designed to be installed by people just like you - not IT experts" <---- from their website, not accurate at all. Just saying.
Title: Re: DCS-942L Issue
Post by: smeat2000 on June 23, 2012, 06:21:20 AM
I get the blank menu thing as well on firmware 1.11 1426. Looking to go back to fw 1.02 1030 but can't find it anywhere!
Title: Re: DCS-942L Issue
Post by: Travelmate on June 25, 2012, 04:47:35 PM
Hi  everyone,

I'm using the 1.11 firmware without issue.

DO NOT UPGRADE THE FIRMWARE USING WIRELESS for it'll corrupt the software. Re-upgrading/downgrading of firmware will not solve the problem. You'll need to send the camera back to  the service centre.

Title: Re: DCS-942L Issue
Post by: theknow on July 09, 2012, 05:56:06 PM

i had the blank menus.. just dump your browser cache and it works fine.

1.11 is all good.

Title: Re: DCS-942L Issue
Post by: Juancito on July 14, 2012, 09:49:42 AM
Mr. TheKnow, you've given me the best tip since I'm in this board. Dumping cache solved blank menu problem  , even "camera freezing and been non responsive problem"
Thanks a lot and have a nice weekend. :D