D-Link Forums

The Graveyard - Products No Longer Supported => Routers => DIR-601 => Topic started by: beruli on April 14, 2012, 12:54:55 AM

Title: Router drops connection
Post by: beruli on April 14, 2012, 12:54:55 AM
Hello all, ive been searching for an answer for a while, my internet provider says its the router and will not help, so i thought i would try here to see if i can get an answer.

I have a DIR-601 and the wireless part of the router as far as i can tell, it drops for about a minute and then reconnects on its own, any thoughts? This i getting rather frustrating because it also does with my previous router. I have changed all the wires included the cable from the wall to the main cable box.
Title: Re: Router drops connection
Post by: FurryNutz on April 14, 2012, 12:33:46 PM
What Hardware version is your router? Look at sticker under router.
What Firmware version is currently loaded? Found on routers web page under status.
What region are you located?
Are you wired or wireless connected to the router?

What ISP Service do you have? Cable or DSL?
What ISP Modem do you have? Stand Alone or built in router?
What ISP Modem make and model do you have?
If this modem has a built in router, it's best to bridge the modem. Having 2 routers on the same line can cause connection problems.
To tell if the modem is bridged or not, look at the routers web page, Status/Device Info/Wan Section, if there is a 192.168.0.# address in the WAN IP address field, then the modem is not bridged.

Some things to try:
Turn off ALL QoS or Disable Traffic Shaping (DIR only) GameFuel (DGL only and if ON.) options. Advanced/QoS or Gamefuel.
Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual.
Turn on DNS Relay under Setup/Networking.
Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking
Ensure devices are set to auto obtain an IP address.
Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall.
Enable uPnP and Multi-cast Streaming under Advanced/Networking.

What wireless modes are you using? Under Setup/Wireless/Manual.
Try single mode G or mixed G and N?
Channel Width set for Auto 20/40Mhz or try 20Mhz only.
What security mode are you using? Preferred security is WPA-Personal. WPA2/AES Only. Some WiFi adapters don't support AES, so you might want to try TPIK only or Auto.
What wireless devices do you have connected?
Any cordless house phones?
Any other WiFi routers in the area? Use InSSIDer (http://www.metageek.net/) to find out.
Turn off Short GI, WLAN Partition and Extra Wireless Protection if you have it. Under Advanced/Advanced Wireless.


Turn off all anti virus and firewall programs on PC while testing. 3rd party firewalls are not generally needed when using routers as they are effective on blocking malicious inbound traffic.
Turn off all devices accept for one wired PC while testing.
Title: Re: Router drops connection
Post by: beruli on April 14, 2012, 01:51:17 PM
Hardware version is A1
Firmware version is 1.02NA
Im in Canada
I use both wired and wireless connections
I use cable internet
cable modem is a Motorola Surfboard SB5101n

I tried the settings use suggested but the problem still pops its head up.
Title: Re: Router drops connection
Post by: FurryNutz on April 14, 2012, 02:18:07 PM
What wireless modes are you using? Under Setup/Wireless/Manual.
Any cordless house phones?
Any other WiFi routers in the area? Use InSSIDer (http://www.metageek.net/) to find out.

Hardware version is A1
Firmware version is 1.02NA
Im in Canada
I use both wired and wireless connections
I use cable internet
cable modem is a Motorola Surfboard SB5101n

I tried the settings use suggested but the problem still pops its head up.
Title: Re: Router drops connection
Post by: beruli on April 14, 2012, 02:26:23 PM
I am using mixed  N and G

I have cordless phones but they are not in the area of the router

There are no other routers interfering with me as far as i can tell.
Title: Re: Router drops connection
Post by: FurryNutz on April 14, 2012, 02:30:42 PM
Does the connection drop with only one device connected to the wireless? Turn off ALL others and test with one. Then test with the WiFi disconnected to see if the same thing happens while wired to the router.

Are there any log entries when this occurs? Might be the ISP modem going down and the router is just reflecting that condition.
Title: Re: Router drops connection
Post by: beruli on April 14, 2012, 03:23:22 PM
Yes, at this time there is only 1 device connected to the router, its connected through wireless, while its wired. There are no log entries pertaining to this.
Title: Re: Router drops connection
Post by: dwt1020 on April 15, 2012, 07:31:15 AM
I am having the exact same issue.   Was working just fine for over 1 year and now it drops or resets many times in a hour.

The only thing in my logs is this..
Blocked incoming TCP Ack packet from 74.125.227.1
17:443 to 71.8.116.237:55798 with unexpected sequence.


I have D-Link Cable Modem purchased from my ISP...

Help..

d
Title: Re: Router drops connection
Post by: FurryNutz on April 15, 2012, 07:37:28 PM
What Hardware version is your router? Look at sticker under router.
What Firmware (http://forums.dlink.com/index.php?topic=42458.0) version is currently loaded? Found on routers web page under status.
What region are you located?
Are you wired or wireless connected to the router?

What ISP Service do you have? Cable or DSL?
What ISP Modem do you have? Stand Alone or built in router?
What ISP Modem make and model do you have?
If this modem has a built in router, it's best to bridge the modem. Having 2 routers on the same line can cause connection problems.
To tell if the modem is bridged or not, look at the routers web page, Status/Device Info/Wan Section, if there is a 192.168.0.# address in the WAN IP address field, then the modem is not bridged.
If the modem can't be bridged then see if the modem has a DMZ option and input the IP address the router gets from the modem and put that into the modems DMZ.

Some things to try:
Turn off ALL QoS or Disable Traffic Shaping (DIR only) GameFuel (DGL only and if ON.) options. Advanced/QoS or Gamefuel.
Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual.
Turn on DNS Relay under Setup/Networking.
Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking
Ensure devices are set to auto obtain an IP address.
Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall.
Enable uPnP and Multi-cast Streaming under Advanced/Networking.

What wireless modes are you using? Under Setup/Wireless/Manual.
Try single mode G or N or mixed G and N?
Channel Width set for Auto 20/40Mhz or try 20Mhz only.
Try setting a manual channel to a open or unused channel.
What security mode are you using? Preferred security is WPA-Personal. WPA2/AES Only. Some WiFi adapters don't support AES, so you might want to try TPIK only or Auto.
What wireless devices do you have connected?
Any cordless house phones?
Any other WiFi routers in the area? Use InSSIDer (http://www.metageek.net/) to find out.
Turn off Short GI, WLAN Partition and Extra Wireless Protection if you have it. Under Advanced/Advanced Wireless.

Turn off all anti virus and firewall programs on PC while testing. 3rd party firewalls are not generally needed when using routers as they are effective on blocking malicious inbound traffic.
Turn off all devices accept for one wired PC while testing.

Check cable between Modem and Router, swap out to be sure. Cat6 is recommended. (http://www.networkcablingdirectory.com/articles/structured-network-cabling-id_1151.htm)

I am having the exact same issue.   Was working just fine for over 1 year and now it drops or resets many times in a hour.

The only thing in my logs is this..
Blocked incoming TCP Ack packet from 74.125.227.1
17:443 to 71.8.116.237:55798 with unexpected sequence.


I have D-Link Cable Modem purchased from my ISP...

Help..

d
Title: Re: Router drops connection
Post by: kargo27 on June 08, 2012, 05:59:06 PM
Mine would do this and then I disabled Advanced DNS Services under setup>internet>manual connection setup.

I also have to leave IPv4 muticast streams disabled (under Advanced>Advanced Network>IPv4 Multicast Streams).

So far it's working fine, very stable and no wifi drops.
Title: Re: Router drops connection
Post by: FurryNutz on September 05, 2012, 10:28:36 PM
Technician huh? Really?

I think he has tried that already though.