D-Link Forums

D-Link FAQ => Router FAQ => FAQs => Topic started by: avggeek on January 22, 2012, 07:06:32 PM

Title: Any way to get WOL working? [SOLVED]
Post by: avggeek on January 22, 2012, 07:06:32 PM
Hi,

I'm trying to send a WOL packet from the Internet to wake up a PC on my LAN. I've read through a number of threads on different hacks to get WOL working in D-Link routers beyond the one-minute mark, but so far haven't found anything that works on the DIR-825. What I've tried so far:

- In Virtual Server, set the IP Address to 192.168.0.255 using the Firebug hack. (Did not work)
- Changed subnet to 255.255.255.128, set IP in Virtual Server to 192.168.0.127 (Did not work)
- In Virtual server, set the IP address to 192.168.0.0 using the Firebug hack (Did not work)
- In Virtual server, set the IP address to 0.0.0.0 using the Firebug hack (Did not work)
- Disabled SPI and modified TCP/UDP Filtering to be Endpoint Independent (Did not help).

At this point, I'm out of ideas. I'm almost ready to install DD-WRT on the router, even though I know there's an issue with WAN download speeds. Any suggestions?

Version info: DIR-825, HW Version:B1 running 2.05WW Beta03
Title: Re: Any way to get WOL working?
Post by: FurryNutz on January 22, 2012, 07:11:52 PM
Might review the DGL-4500 or the DIR-655 forums for the WOL stickys. Not sure if it will help on a 825. Might. Let us know if it does.
Title: Re: Any way to get WOL working?
Post by: defiant on January 22, 2012, 11:23:51 PM
I created a virtual server like this:

Name: Wake-on-lan
IP Address: 192.168.0.255
Public port: 22441 (this is the port to send the magic packet to, you may change the port to your liking)
Private port: 7
Protocol: UDP
Schedule: Always
Inbound Filter: Allow All

I can wake all three of my PC's (individually) from internet by sending a magic packet from an Android phone or iPhone to the Public port.
I did not need to use any tools or hacks to configure the router.

To see if the packet arrives on you lan you can use Wake on Lan Monitor http://www.depicus.com/wake-on-lan/wake-on-lan-monitor.aspx
Title: Re: Any way to get WOL working?
Post by: avggeek on January 23, 2012, 04:02:18 AM
I created a virtual server like this:

Name: Wake-on-lan
IP Address: 192.168.0.255
Public port: 22441 (this is the port to send the magic packet to, you may change the port to your liking)
Private port: 7
Protocol: UDP
Schedule: Always
Inbound Filter: Allow All

I can wake all three of my PC's (individually) from internet by sending a magic packet from an Android phone or iPhone to the Public port.
I did not need to use any tools or hacks to configure the router.

To see if the packet arrives on you lan you can use Wake on Lan Monitor http://www.depicus.com/wake-on-lan/wake-on-lan-monitor.aspx

Tried the settings you have mentioned:

Name: Wake-on-lan-7
IP Address: 192.168.0.255 (Although I can't find a way to enter this IP without triggering an error by default)
Public port: 11277
Private port: 7
Protocol: UDP
Schedule: Always
Inbound Filter: Allow All

The Wake on LAN Monitor tool does not show any packets being received :(

Edit: If I change the IP Address to a specific machine IP (say 192.168.0.100) then Wireshark reports receiving the Magic packet. So the virtual server configuration is fine - it's just that when I change it to the broadcast IP (192.168.0.255), nothing happens.
Title: Re: Any way to get WOL working?
Post by: defiant on January 23, 2012, 05:10:28 AM
It's seems they have changed something since made this virtual server. I also get an error when trying to input 192.168.0.255 in a new virtual server.  :-\.  (I have used this config since forever)

Not all WOL Clients support sending packets over internet. Make sure it is working on your LAN first.
Make sure the packets can reach WOL Monitor (if there are any local firewalls on your client)
I added WOL Monitor as an exception to the windows firewall to make sure the packets are received.


I tried this webpage (use it own risk) and it worked for me. http://wakeonlan.me/

IP or host name: the external IP Address and the public port on your router (e.g. 8.8.8.8:22441)
MAC: mac address to the device you want to wake (e.g 10-1d-8e-09-e6-2e)







(I'm on firmware  2.05EU B09beta06, 07, Oct, 2011)

Title: Re: Any way to get WOL working?
Post by: avggeek on January 23, 2012, 09:09:59 PM
It's seems they have changed something since made this virtual server. I also get an error when trying to input 192.168.0.255 in a new virtual server.  :-\.  (I have used this config since forever)

Not all WOL Clients support sending packets over internet. Make sure it is working on your LAN first.
Make sure the packets can reach WOL Monitor (if there are any local firewalls on your client)
I added WOL Monitor as an exception to the windows firewall to make sure the packets are received.


I tried this webpage (use it own risk) and it worked for me. http://wakeonlan.me/

IP or host name: the external IP Address and the public port on your router (e.g. 8.8.8.8:22441)
MAC: mac address to the device you want to wake (e.g 10-1d-8e-09-e6-2e)


(I'm on firmware  2.05EU B09beta06, 07, Oct, 2011)


Works fine inside the LAN - both Wake on Lan Monitor (running on the PC sending the magic packet) and Wireshark (on the Linux machine that's the target) can see the Magic packets when I send it to 192.168.0.255. It just doesn't seem to work from the router :(
Title: Re: Any way to get WOL working?
Post by: defiant on January 24, 2012, 04:04:49 AM
I fiddled around a bit and discovered that on the "Virtual Server Page" there are a per-defined "Application Name" in the drop-down list called "Wake-On-LAN".
If I choose this and click "<<"  I can set the IP Address to 192.168.0.255 without getting an error.
Title: Re: Any way to get WOL working?
Post by: avggeek on January 25, 2012, 03:04:01 AM
I fiddled around a bit and discovered that on the "Virtual Server Page" there are a per-defined "Application Name" in the drop-down list called "Wake-On-LAN".
If I choose this and click "<<"  I can set the IP Address to 192.168.0.255 without getting an error.

Thank you so much! It worked! I had used the dropdown Wake-on-LAN option before but I had changed the name which seems to break the functionality.

I selected the Wake-on-LAN dropdown, left the ports unchanged as Public port 9 and private port 9, then entered the IP 192.168.0.255. I was able to save this entry without any hacks and the WOL packet got sent to the target machine successfully.

For anybody else reading the thread, I'm on 2.05 WW Beta 3.
Title: Re: Any way to get WOL working? [SOLVED]
Post by: goslow2gofast on February 23, 2012, 11:04:52 AM
Great that worked for you, interesting.  Sadly I tried it on my DIR-645 and even when picking the Wake-On-Lan selection from the drop down it still won't allow the .255 address to be specified, it just returns a "The input hostid is out of the boundary." error message when trying to save.

What do you have for "Default Subnet Mask" and "DHCP IP Address Range" on the Network setup tab, something like "255.255.255.0" and "2 to 199"?

~gs2gf
Title: Re: Any way to get WOL working? [SOLVED]
Post by: defiant on February 23, 2012, 11:28:28 AM
I use these:

Router IP: 192.168.0.1
Subnet Mask: 255.255.255.0

DHCP IP Address Range: 192.168.0.100 -- 192.168.0.250

Can't find any "Default Subnet Mask"?!


Title: Re: Any way to get WOL working? [SOLVED]
Post by: goslow2gofast on February 23, 2012, 11:39:57 AM
I use these:

Router IP: 192.168.0.1
Subnet Mask: 255.255.255.0

DHCP IP Address Range: 192.168.0.100 -- 192.168.0.250

Can't find any "Default Subnet Mask"?!

Sorry, worded that wrong, it is the "Subnet Mask" field, and I meant to say are you using the default value of 255.255.255.0.

Sadly it looks like the edit checking on the DIR-645 is different than your device as I still get an error if I try to save the broadcast address in the Virtual Server settings.  Drat.

~gs2gf
Title: Re: Any way to get WOL working?
Post by: frangi on January 21, 2013, 10:36:03 PM
I fiddled around a bit and discovered that on the "Virtual Server Page" there are a per-defined "Application Name" in the drop-down list called "Wake-On-LAN".
If I choose this and click "<<"  I can set the IP Address to 192.168.0.255 without getting an error.

How do you click "<<" to enter the IP Address to 192.168.0.255 without getting an error  ?
Title: Re: Any way to get WOL working? [SOLVED]
Post by: FurryNutz on January 22, 2013, 06:40:25 AM
does entering 192.168.0.254 work?
Title: Re: Any way to get WOL working?
Post by: FurryNutz on January 28, 2013, 02:08:18 PM
Any status on this?

How do you click "<<" to enter the IP Address to 192.168.0.255 without getting an error  ?
Title: Re: Any way to get WOL working?
Post by: goslow2gofast on January 28, 2013, 04:48:06 PM
Any status on this?

Yes, very interested in that, I always get an error popup at that point.

~gs2gf
Title: Re: Any way to get WOL working?
Post by: FurryNutz on January 29, 2013, 07:24:53 AM
I was asking you if does entering 192.168.0.254 work?

Yes, very interested in that, I always get an error popup at that point.

~gs2gf
Title: Re: Any way to get WOL working? [SOLVED]
Post by: goslow2gofast on January 29, 2013, 07:46:12 AM
It passes the edit, but does not allow the computer to be woken up remotely.  My understanding is that 255 is special, and will broadcast the packet to all devices on the network, while 254 only send to that one IP, which is not a valid machine.

~bp
Title: Re: Any way to get WOL working? [SOLVED]
Post by: FurryNutz on January 29, 2013, 07:48:32 AM
Possible that the 825 FW might not support the 255 address.  :-\
I've noticed that on most DIR series routers, .255 in any rule is not valid however using .254 is. I noticed this in the QoS section. On DGL series routers .255 can be used.  ::)
Title: Re: Any way to get WOL working? [SOLVED]
Post by: cyadron on November 25, 2013, 08:55:19 AM
Hi,
I own a d-link DIR-826L.
I have managed to get WOL working from the internet only with firmware 1.02. 1.00 or 1.01 or the latest 1.04 did not work. The settings were:
Go to Advanced -> Virtual Server check one of the check-boxes, from the Application Name list choose Wake -ON-LAN (the last one) and click on the << button to load it. For the IP put 192.168.0.255 (or whatever your IP class broadcast is). And it should work.
Good luck!
Title: Re: Any way to get WOL working? [SOLVED]
Post by: FurryNutz on November 25, 2013, 08:58:10 AM
Thank you for sharing.

Hi,
I own a d-link DIR-826L.
I have managed to get WOL working from the internet only with firmware 1.02. 1.00 or 1.01 or the latest 1.04 did not work. The settings were:
Go to Advanced -> Virtual Server check one of the check-boxes, from the Application Name list choose Wake -ON-LAN (the last one) and click on the << button to load it. For the IP put 192.168.0.255 (or whatever your IP class broadcast is). And it should work.
Good luck!
Title: Re: Any way to get WOL working? [SOLVED]
Post by: zazzmaster on May 23, 2017, 08:49:05 AM
I got WOL working on my Dir-825 by using daedao's Firefox Firebug hackfix posted in the The DIR-655 WOL Knowledgebase Thread. I have HW: A1 FW:1.01.  http://forums.dlink.com/index.php?topic=16404.0 (http://forums.dlink.com/index.php?topic=16404.0)
Title: Re: Any way to get WOL working? [SOLVED]
Post by: FurryNutz on May 23, 2017, 08:52:11 AM
Thank you for posting. I presume the firebug mod is for the out of IP range?

I got WOL working on my Dir-825 by using daedao's Firefox Firebug hackfix posted in the The DIR-655 WOL Knowledgebase Thread. I have HW: A1 FW:1.01.  http://forums.dlink.com/index.php?topic=16404.0 (http://forums.dlink.com/index.php?topic=16404.0)