D-Link Forums

The Graveyard - Products No Longer Supported => D-Link Storage => DNS-321 => Topic started by: steve on February 16, 2009, 07:06:24 PM

Title: DNS-321 iTunes error -39 import/convert
Post by: steve on February 16, 2009, 07:06:24 PM

I have recently moved my iTunes library to my DNS-321.  iTunes is able to read the folder I have set up without problem.

I have an album in WMA that I'm trying to add to my iTunes library. This process has always worked in the past when my iTunes library was stored on a local drive, but now, the following happens:

1. in iTunes, click to "Add File to Library" or "Add Folder to Library"
2. select WMA file/folder in question
3. select "Convert..."
4. after enumerating files, and starting the conversion process, iTunes tells me:

"Error occurred while converting the file "<whatever>".  An unknown error occurred (-39)."

Any ideas?  I've searched far and wide for a solution, with no luck.

Any help would be greatly appreciated.

Title: Re: DNS-321 iTunes error -39 import/convert
Post by: pops2992 on April 25, 2009, 08:33:29 PM
I have been having the same problem.  So far I'm not using the iTunes server; rather, I turned on LLTD to allow Vista Ultimate x64 to see the drive, and set my documents, pictures, and music folders to folders that are located on the 321 (welcome to thoughts as to if this is a good/bad idea). 

In iTunes, I just added my "My Music" folder, and access everything that way (I'm thinking about playing with the iTunes server).

Anyways, with this setup, I encountered the exact same problem, especially frustrating once I've waited hours for it to load 1000's of files and then fail and lose all the work.  At first I thought it was specific WMA files causing the problems, but now I've realized it can't touch the WMAs on the network to convert.  Not sure if activating the iTunes server will resolve this.

Regardless, (sorry for the rambling), I worked around the issue by:
1) Downloading one of the many free WMA<->MP3/other format converters that exist (I used Free WMA MP3 Converter 1.8 from download.com at http://download.cnet.com/Free-Mp3-Wma-Converter/3000-2140_4-10442362.html?tag=mncol)
2) Searching my root music folder (all my music is in one folder with hundreds of subdirectories) for *.wma (in Vista, finds all WMAs including those in subfolders)
3) Dragging and dropping the files into the converter window in ~500-1000 file increments (I noticed a significant performance drop processing more files than that in one batch)
4) The converter converts the files, and saves the MP3 (or whatever format you choose - AAC, etc...) in the same folder the WMA was located
5) Delete the WMA files from the folders where converted files were created (I created a backup outside my music folder to avoid iTunes finding the files again and erroring out)
6) Reload the "My Music" into the library on itunes to initiate a re-scan
7) Voila, the converted files are included into iTunes.

Hope that helps - I'm still learning a lot as I go.
Title: Re: DNS-321 iTunes error -39 import/convert
Post by: steve on April 27, 2009, 07:04:30 AM
Thanks for the response.  On another board, someone told me about this very simple solution that worked great:

In iTunes, go to Preferences;
General tab, click the "Import Settings" button;
Change the "Import Using" value from AAC to MP3.

That's it--worked like a charm for me.  Turns out this is a bug in iTunes, not this device.

Hope that helps.
Title: Re: DNS-321 iTunes error -39 import/convert
Post by: xingu on September 18, 2009, 08:09:10 PM
Sorry to bump and old topic, but I came across the exact same problem and wanted to add to the posted solution.  I've seen several threads here and on the Apple support forums discussing this problem.  I haven't yet seen any specific NAS named other than the 321, but some posters didn't disclose what they were using, so it's hard to tell if this issue is really with iTunes or with the 321.  The problem appears to be with both AAC and Apple Lossless (ALAC) files, both of which carry the m4a extension.  Streaming both file types from iTunes is no problem, but ripping a CD with a conversion to either results in a -39 unknown error.  Same goes for converting an existing file within iTunes to AAC or ALAC.  Importing and/or converting using any of the non-Apple encoders (mp3/wav/aiff) works just fine.  So there are currently two workarounds:

1: Rip/convert within iTunes directly to the NAS using a non-Apple format.
2: Rip to the local drive using a different program in whatever format and then copy the folder(s)/files to the NAS and add to the iTunes library.

Another solution likely includes not using iTunes, but I own an iPod so that's not an option.
Title: Re: DNS-321 iTunes error -39 import/convert
Post by: Amp300 on September 23, 2009, 07:15:18 PM
This is a permissions problem when using the default settings on the DNS-321. Through trial and error, I was able to get "Create AAC Version" to work by doing the following:

1. Log into your DNS-321
2. Go to the Advanced tab --> Users / Groups
3. Create a new User
4. Go to the Advanced tab --> Network Access
5. Select the User you just created from the drop down
6. Browse for your iTunes folder (or use the entire drive, depending on your setup)
7. Select "R/W : Read/Write" in the permissions drop down
8. Set Oplocks to "Yes"
9. Click "Save Settings" at the top of the window
10. In Windows select "Map network drive"
11. Browse to the folder you just gave your user permissions for above
12. Check the "Connect using different credentials" check box and click "Finish"
13. A window will pop up. Select "User another account" and enter in the username and password for the user you just created above. Click "OK"
14. Hold down shift and click on the iTunes icon
15. Select the iTunes Library.itl file from your newly mapped drive

NOTE: I'm using Windows 7 RTM x64 and iTunes x64
Title: Re: DNS-321 iTunes error -39 import/convert
Post by: xingu on September 23, 2009, 08:43:23 PM
Thanks for the input.  I started messing with settings after reading your post and came across an even easier fix that worked for me, which bypasses the need to create a new/separate user:
- Login/Advanced/Network Access
- Under SMB Access List, click the Modify settings icon for the relevant volume
- Set Oplocks to Yes
- Click to save/modify this setting.

Note - the above applies when default settings are being used without any specific users or groups, in which case each volume has an open access rule.  Regardless, the key appears to be switching the Oplocks option to Yes.