D-Link Forums

D-Link FAQ => Network Camera FAQ => Topic started by: mrr1 on May 21, 2011, 09:33:58 PM

Title: mydlink email settings
Post by: mrr1 on May 21, 2011, 09:33:58 PM
Got my DCS 930L hooked up and working no problem, except email notifications won't send out.
I'm on telus and have put in all settings as required:

SMTP server: smtp.telus.net
Port: 25
Email: xxxx@telus.net
send to: zzzz@telus.net
account username
account password
No SSL

I know the account user and password are correct  as it works for all other setups like my phone.
I am running Norton and a Cisco router.
Is there something I'm missing or something unique to telus?
All I get is :cannot connect to smtp server or invalid user/password.
Is there something blocking this?
Any info from other telus customers would be appreciated!
Title: Re: mydlink email settings
Post by: tubadag on May 23, 2011, 11:46:55 AM
Same problem here.  I've tried the email from two different computers, (both connected to charter)with the camera both hard wired to the router and wireless, with the same result: "invalid user name/password".  Hope someone has a solution.
Title: Re: mydlink email settings
Post by: JavaLawyer on May 23, 2011, 01:22:50 PM
Got my DCS 930L hooked up and working no problem, except email notifications won't send out.
I'm on telus and have put in all settings as required:

SMTP server: smtp.telus.net
Port: 25
Email: xxxx@telus.net
send to: zzzz@telus.net
account username
account password
No SSL

I know the account user and password are correct  as it works for all other setups like my phone.
I am running Norton and a Cisco router.
Is there something I'm missing or something unique to telus?
All I get is :cannot connect to smtp server or invalid user/password.
Is there something blocking this?
Any info from other telus customers would be appreciated!

Try port 587
Title: Re: mydlink email settings
Post by: tubadag on May 24, 2011, 05:14:16 PM
Tried "port 587"= unable to connect to SMTP server.  Thanks for the idea.
Title: Re: mydlink email settings
Post by: spare parts on May 30, 2011, 10:31:38 PM
If problem is on going, for SMTP server type in PoP.Telus.net.If there is a SMTP box check it.
Title: Re: mydlink email settings
Post by: djwebb on June 21, 2011, 08:40:30 PM
Just thought I would check in and see if MRR1 or Tubadag have found resolution to this issue.  I am currently having this same issue.  I have tried with 2 different email accounts, and all the obvious combinations.  Any thoughts or findings would be appreciated.
Title: Re: mydlink email settings
Post by: DaddyOwns on July 06, 2011, 04:43:34 PM
It's me again.  ;D

Having the same problems with gmail acc, could it be hence my password has 32 carathers?  :D

I've tried SSL with 465, STARTTLS with 587 port, just getting the "Invalid username/password" in test.
Title: Re: mydlink email settings
Post by: nikolaidiz on August 06, 2011, 06:15:16 AM
I do have the problem as well.

Though I'm sure that my username and password of the emailaccount is correct,
because I just tried it in my email program.

The installation was though easy until now but now I have a problem.

Does anyone know the solution?

Thanks in advance.
Title: Re: mydlink email settings
Post by: mcqueen on December 15, 2011, 08:59:40 AM
I am having the same issue.

After all this time, has anyone found a solution or at least the source of the problem?

Thanks in advance for any info/help :)
Title: Re: mydlink email settings
Post by: warriorfullight on December 16, 2011, 01:56:39 AM
I am also running on the same issue and have also tried all the ports you guys provided. I am not sure what seems to be the problem, hopefully I can find the solution soon.
Title: Re: mydlink email settings
Post by: gjagelink on December 26, 2011, 11:31:15 AM
Hi. I had the same problem and found the answer on another forum

or the server address ..  "smtp.gmail.com"
SMTP Server Port:   587
Sender E-mail Address: "myname"@gmail.com
Receiver E-mail Address: "myname"@gmail.com 
User Name: "myname"
Password:  my e-mail account password
 Use SSL-TLS/STARTTLS:  check for STARTTLS

also of course enable POP in gmail settings.


I have created a gmail account at www.gmail.com, tested my dlink camera with the above settings and it works perfectly fine ! Good luck
Title: Re: mydlink email settings
Post by: Onthesamepath on January 22, 2012, 11:56:34 AM
Thank you 1572 times.  I have spent about 10 hours trying to get gmail settings right.  Dlink web tech support for this very common task is pathetic and no help at all. This thread has been viewed 1572 times -- maybe they should get a clue and put the info in your email in the online manuals or even FAQ. Based on other forum info I was about to think it was impossible or that I was going to have to buy a NAS device to store the images via FTP.  I suppose this is a rant, but really! I hope the dlink powers that be see it for what it is -- a user frustrated by lack of basic information.
Title: Re: mydlink email settings
Post by: JavaLawyer on January 25, 2012, 05:31:10 AM
Thank you 1572 times.  I have spent about 10 hours trying to get gmail settings right.  Dlink web tech support for this very common task is pathetic and no help at all. This thread has been viewed 1572 times -- maybe they should get a clue and put the info in your email in the online manuals or even FAQ.

D-Link is in the process of setting up a board dedicated to FAQs.  As soon as this new board is up (hopefully in a few months), I'll start posting FAQs for the DCS series.

Title: Re: mydlink email settings
Post by: asparrow30 on March 03, 2012, 08:06:38 PM
Just wondering if anyone has the fix to this as I have the same problem. Acutally all was working great until I had to do the hard wire firmware update...then it all crashed.  Maybe I did something wrong...any takers???

Thanks in advance!
Title: Re: mydlink email settings
Post by: nave on July 10, 2012, 08:00:53 AM
Hi Guys,

I know I'm reviving an old thread, but I've run into the issues with invalid username/password before. Try copying your computers time to the camera instead of using an NTP server. For some reason this seems to fix it for me.

Hope it helps,
Title: Re: mydlink email settings
Post by: Al A on December 24, 2012, 02:54:52 AM
None of these answers helped me.  I found the problem for me was that it failed to send an email while I had a static IP address.  Computer time, firewall settings, antivirus settings, email accounts, ports, etc. were all irrelevant.  As soon as I changed back to DHCP, the test and all subsequent automatic emails worked as expected. 
Title: Re: mydlink email settings
Post by: PhrozenSoft on March 12, 2013, 10:34:49 AM
I had the same issue and finally I manage to solve it, I know why 95% of people here got some issue, you simply forgot to save the settings before testing the email :)
Title: Re: mydlink email settings
Post by: FurryNutz on March 13, 2013, 09:59:16 AM
These are reliable too:
http://forums.dlink.com/index.php?topic=48695.0 (http://forums.dlink.com/index.php?topic=48695.0)
Title: Re: mydlink email settings
Post by: desparky on April 22, 2013, 07:33:15 AM
I stuffed about for hours trying to get my DCS-942 to send emails....with no luck.
I finally got it to work be turning off Motion Detection, Recording etc. (Save Settings on each page). Only after all the other features are turned off, then set up the email page, save and test.
Voila... well it worked for me!

Then go back and set up your motion detection etc.
Title: Re: mydlink email settings
Post by: NBGl on December 24, 2013, 04:09:26 AM
same problem here. I've tried the different solutions. I reset the cam because I thougth I may have forgottten to click "save cha,ge" the first time I tried. I "tried to turn it off and on again" (of course). I'm SURE about my password and login. (gmail, i even tired xxx@gmail.com and just xxx as the login). my cam is on dhcp, not static. I tried to config this juste after resetting, before doing anything else in the menus. But nothing works.

I'm on win 8, my cam is the 932L

any other idea?
Title: Re: mydlink email settings
Post by: NBGl on December 24, 2013, 04:11:35 AM
and I have the last firmware. and i tried with the port 465 / ssl and 587 / starttls. so...
Title: Re: mydlink email settings
Post by: NBGl on December 25, 2013, 02:50:20 AM
ok I got it, and i guess this can help other people around.

Another possibility if you encounter a problem with this if you are trying to use a gmail acount: have you activated the two step verification for gmail?

if so, you have to generate an "application specific code" from the security settings of your google account.
https://support.google.com/accounts/answer/185833?hl=en

et voilą!
Title: Re: mydlink email settings
Post by: drexellake on December 31, 2013, 06:34:25 PM
I had this problem setting up my first camera.  I ended up getting with my ISP, and after 15 years with them I found that they had several different settings and ports.  The settings I was using in Live Mail and Outlook for years didn't work for the D-Link setup.  I found they have three different SMTP server settings and ports that can be used if others don't work.

I would recommend calling or chatting with them to see.  My ISP actually has for counting one for mobile devices.

Example:

pop-server.sc.rr.com
smtp-server.sc.rr.com (I used these for years without issue)

pop-mail.sc.rr.com
smtp-server.roadrunner.com

pop-server.sc.rr.com
smtp-server.carolina.rr.com
Title: Re: mydlink email settings
Post by: jcman on February 19, 2014, 10:52:52 PM
I was also having this problem trying to use gmail smtp to send snapshots. It turned out to be because I had set the camera up to use a Static IP Address, but had not set the Primary and Secondary DNS addresses up correctly, so it couldn't resolve the smtp server name. Filling those out correctly fixed it for me.

Title: Re: mydlink email settings
Post by: ASHMEU on January 04, 2015, 01:29:17 PM
It was pain in the *ss for me also to configure the email settings.

BUT...

Here is THE hint I did realize and worked for me  :

using gmail smtp server :

SMTP Server : smtp.gmail.com
SMTP Server port : 587
Sender : myname@gmail.com
Receiver : myname@gmail.com
Username : myname@gmail.com
Password : "mygmailpwd"

STARTTLS option checked.

Now..... THE thing missing in this thread is TO CHANGE YOUR GOOGLE ACCOUNT SECURITY SETTINGS !!!

Going through https://myaccount.google.com, you have to active the "less secured apps"  access option.

It immediately worked for me.

I hope it will help you to not trash your camera !  ;)


Title: Re: mydlink email settings
Post by: kobodera on January 16, 2015, 12:14:39 PM
It was pain in the *ss for me also to configure the email settings.

BUT...

Here is THE hint I did realize and worked for me  :

using gmail smtp server :

SMTP Server : smtp.gmail.com
SMTP Server port : 587
Sender : myname@gmail.com
Receiver : myname@gmail.com
Username : myname@gmail.com
Password : "mygmailpwd"

STARTTLS option checked.

Now..... THE thing missing in this thread is TO CHANGE YOUR GOOGLE ACCOUNT SECURITY SETTINGS !!!

Going through https://myaccount.google.com, you have to active the "less secured apps"  access option.

It immediately worked for me.

I hope it will help you to not trash your camera !  ;)

That USED to work for me. Unfortunatly google have som limitation on their SMTP service... and after one of my cameras started flickering like crazy (generating motion events constantly) it started spamming google smtp server with mails... so in the end I was basicly banned from the service.

In the end I had to install and run my own SMTP server, which works pretty good.

The server I am using is hmailserver which can be found here https://www.hmailserver.com/ (https://www.hmailserver.com/) it is a free open source mail server.

Initially i started messing about all over it and I managed to get banned from my own server :p I reinstalled it and started from scratch. This time it went perfectly. I could send mails from my cameras to hotmail without any trouble (first ended up in the junk mail but after setting it to "safe" it worked flawlessly.
Title: Re: mydlink email settings
Post by: respect on August 25, 2015, 01:54:26 AM
It was pain in the *ss for me also to configure the email settings.

BUT...

Here is THE hint I did realize and worked for me  :

using gmail smtp server :

SMTP Server : smtp.gmail.com
SMTP Server port : 587
Sender : myname@gmail.com
Receiver : myname@gmail.com
Username : myname@gmail.com
Password : "mygmailpwd"

STARTTLS option checked.

Now..... THE thing missing in this thread is TO CHANGE YOUR GOOGLE ACCOUNT SECURITY SETTINGS !!!

Going through https://myaccount.google.com, you have to active the "less secured apps"  access option.

It immediately worked for me.

I hope it will help you to not trash your camera !  ;)

Thanks,thanks and thanks!!!

This is the clue: CHANGE YOUR GOOGLE ACCOUNT SECURITY SETTINGS to active the "less secured apps" access option.

I changed it and it finally worked fine on my Dlink share Center DNS-320
Title: Re: mydlink email settings
Post by: BStrummin on November 06, 2015, 06:19:13 PM
Thank you all for this thread!  I've been fighting with a 932 and a 5009 for three days to get ANY kind of notification to work, and this solved the gmail problems.

For anyone else who finds this:
Although the less secure apps option works too, you don't have to do this!  You also have the option of enabling two step verification, and THEN general app specific passwords for each camera.  Worked perfectly.  THANK YOU!

Now to get ftp working to a hd plugged into a netgear router.....
Title: Re: mydlink email settings
Post by: BStrummin on November 06, 2015, 06:21:07 PM
And now I see there is a sticky with this information in this section.... LOL.  Oh well.  I happened upon this thread via google and didn't see that.  Here's the sticky with all this information:
http://forums.dlink.com/index.php?topic=63536.0 (http://forums.dlink.com/index.php?topic=63536.0)
Title: Re: mydlink email settings
Post by: FurryNutz on November 07, 2015, 10:44:09 AM
Hope it works for you. Let us know.