D-Link Forums

The Graveyard - Products No Longer Supported => Routers => DIR-615 => Topic started by: superuser on April 29, 2011, 10:40:43 AM

Title: Keeps disconnecting a session
Post by: superuser on April 29, 2011, 10:40:43 AM
Hi everyone,

I log in to work from home and if I am inactive for 5-10 minutes, I lose connection to my work server.  If I bypass the router, this problem doesn't happen.  Anyone know how I can change settings to keep my session alive?  Thanks in advance!

BTW, I am not a network guy, so please provide enough details in your response that I can follow.  Thank you!
Title: Re: Keeps disconnecting a session
Post by: FurryNutz on April 29, 2011, 10:45:39 AM
What is your ISP service? Cable or DSL?
What is your ISP modem? Stand alone or built in router?
How are you connecting to the router? Wired or wireless?
How are you connecting to the work server? VPN, HTTP?
What program are you using to connect? SW? Web Broswer?
What OS are you using?
Title: Re: Keeps disconnecting a session
Post by: superuser on April 29, 2011, 10:49:16 AM
Sorry for not providing this info before.  Here are the answers:

1.  ISP is Time Warner Cable.
2.  Modem is a Cisco 2100 Cable Modem.
3.  I am connecting via wireless.
4.  Use HTTP to connect to work.
5.  Web Browser.
6.  Windows 7 Home Edition, 64-bit. 

Thanks again!
Title: Re: Keeps disconnecting a session
Post by: FurryNutz on April 29, 2011, 10:54:05 AM
Does the same thing happen if wired to the router?
Try changing the WiFi mode from Mixed to Single mode G to test.
Try using a different browser like Opera or FF or Flock. Same thing happen?
Title: Re: Keeps disconnecting a session
Post by: superuser on April 29, 2011, 11:04:15 AM
OK, I'll give each of these a try and report back in a few.  Thanks.
Title: Re: Keeps disconnecting a session
Post by: superuser on April 29, 2011, 11:39:14 AM
The same thing happens with all these suggestions.   :-\
Title: Re: Keeps disconnecting a session
Post by: FurryNutz on April 29, 2011, 01:47:47 PM
Ok,
Lets try setting up a static IP address for the PC your using on the routers web page under Setup/Networking.
Down at the bottom of this page will be a section. You should see your PCs IP address here along with the MAC address and maybe a name. If not a name then we can change that. Select the Reserve word link to the right in this row for your PC. This will auto fill in the section above. Here you can change the Name and even IP address if you wish to something else in the last number. Leave it if you want to. Once your done, select Add or Save button.
Ensure DNS Relay is ON. You might try turn it off as a test. You'll need to reset the router and PC if you do this.
Ensure that Primary and 2ndary DNS addresses are being filled in under Setup/Internet/Manual.
Turn off Advanced DNS Services if you see this option.
Turn off QoS.
Set up Firewall settings to Endpoint Independent for TCP and UDP.

It's possible that we might have to set up a port or application rule to help maintain the connection. Something is getting dropped and turned off prematurely.

Are there any PC Anti-Virus or 3rd party firewall programs installed? These can effect connection if you don't tell them to allow certain things. Just checking here.

Let us know.
Title: Re: Keeps disconnecting a session
Post by: superuser on April 29, 2011, 02:36:08 PM
Thanks, I reserved the IP.  For now I left DNS Relay to ON.  Will also try turning that off later to see if that will fix it, but for now I'l test with that setting turned on. 

Primary/Secondary DNS are filled.

Advanced DNS Services was already off.

I'm going to look for QoS and the Firewall settings now and will configure them as you suggested.

I am running Symantec Internet Security.  However, I don't think that this is a problem, since I don't have any problems when I have bypassed the D-Link router. 

I'll make the QoS and Firewall changes and test to see if the problem persists.  Will update you shortly. 

And again, thank you!!!
Title: Re: Keeps disconnecting a session
Post by: FurryNutz on April 29, 2011, 02:45:32 PM
Understand about not seeing the same issue with Norton IS loaded and you connected with out the router, however introducing a device to the system and now that your having to go thru another kinda of Firewall, this can possibly introduce connection issue. IMO, running extra firewall SW is a bit too redundant when you have HW firewall going at the same time.

I would be a good test to turn off Norton IS or at least the FW side of it and see if you exhibit the same symptom. Hope we can help figure this out. Keep us posted.
Title: Re: Keeps disconnecting a session
Post by: superuser on April 29, 2011, 03:37:36 PM
Oh man, thank you so much, it's fixed!!!!  So, what do you think was the problem? 
Title: Re: Keeps disconnecting a session
Post by: FurryNutz on April 30, 2011, 10:10:19 AM
Im thinking that having 2 firewalls on the same network and norton probably was the issue here. If you think you really need Norton FW installed I would try to set it up to allow what ever connection, port or address thru. Personally I would only run Norton AV only and let the router hand the Firewall stuff.
Title: Re: Keeps disconnecting a session
Post by: superuser on April 30, 2011, 07:45:11 PM
Got it, I'm going to turn off the Norton firewall. 

It feels so good to not have to log in 20 times to work...just log in once and stay logged in for days I guess!  Love it!!  Thanks again!
Title: Re: Keeps disconnecting a session (RESOLVED)
Post by: FurryNutz on May 01, 2011, 09:52:33 AM
Glad it's working now. Enjoy.
Title: Re: Keeps disconnecting a session
Post by: superuser on June 06, 2011, 10:00:20 AM
The problem is back!!!  :(((((

I've been dealing with it for a couple of weeks now, because I didn't have the time to deal with it.  I just tried everything in this thread once again, but this time the problem still persists.  Any suggestions on what to do next?  Thank you!
Title: Re: Keeps disconnecting a session
Post by: FurryNutz on June 06, 2011, 10:05:22 AM
And you turned off Norton FW I presume?
Ensure that Primary and 2ndary DNS addresses are being filled in under Setup/Internet/Manual.
Turn off Advanced DNS Services if you see this option.
Turn off QoS.
Set up Firewall settings to Endpoint Independent for TCP and UDP.
Try turning off uPnP under Advanced/Networking

Are there any log entries noting of something during this time frame when you see this disconnection?  ???
Title: Re: Keeps disconnecting a session
Post by: superuser on June 06, 2011, 10:10:59 AM
Hi again,

Yes, FW is turned off in Norton.

All the settings were set up as you asked, except for the uPnP, which I just changed.  I'll let you know in the next 20-30 minutes if the change worked.

Unfortunately there are no logs whatsoever. 
Title: Re: Keeps disconnecting a session
Post by: FurryNutz on June 06, 2011, 10:13:18 AM
Make sure cabling is good and it's recommended to use CAT5e or Cat6 cabling between router and ISP modem.

Any other WiFi that could be new to the area?
Title: Re: Keeps disconnecting a session
Post by: superuser on June 06, 2011, 10:36:21 AM
Just an update that the previous change didn't work.

The problem occurs even with wifi, so I am pretty sure that it's not a cable issue. 

Haven't been keeping up with the networks in my apartment.  Not sure.  Just curious (so that I can learn more), why is that important?
Title: Re: Keeps disconnecting a session
Post by: FurryNutz on June 06, 2011, 11:02:06 AM
Other near by WiFi networks and routers can cause interference and random drops when using WiFi.

Seems like the problem went away since the last time you posted then all of a sudden it's back.

What wireless mode are you using now and what channel? Is Auto scan off?
Title: Re: Keeps disconnecting a session
Post by: superuser on June 06, 2011, 12:10:58 PM
So sorry for confusing you. 

I was using wireless for the past 2 weeks.  Today, since I have the time to work on this, I am connected using my NIC card. 

Again, sorry for the confusion. 
Title: Re: Keeps disconnecting a session
Post by: FurryNutz on June 06, 2011, 12:36:27 PM
So so wired connection is going down right?
Title: Re: Keeps disconnecting a session
Post by: superuser on June 06, 2011, 03:34:42 PM
Yes sir, wired connection goes down as well.  And so does wireless. 
Title: Re: Keeps disconnecting a session
Post by: FurryNutz on June 06, 2011, 08:24:21 PM
Any chance you can take this router or a friends or neighbors place with board band to see if the problem tracks?
Title: Re: Keeps disconnecting a session
Post by: superuser on June 07, 2011, 12:33:08 PM
Absolutely, good idea, I will do that this coming weekend and let you know. 

BTW, when I connect directly to the cable modem, I don't have this issue.  So, does that mean that the problem is the router?  If yes, then I guess I don't have to take the router to a friend's place. 
Title: Re: Keeps disconnecting a session
Post by: FurryNutz on June 07, 2011, 12:37:07 PM
Possible that it could be the router. Make sure all cables are good.
Still if you can take it to a friends place and put on there network and see if you see the same problem. Might ask if you can maybe do a swap router for a few days to make sure testing is complete and see any issues. Or go buy a different router that you can return for a refund and test for a bit. This will let you know,. Keep us posted.
Title: Re: Keeps disconnecting a session
Post by: superuser on June 08, 2011, 05:01:21 PM
OK, things just got a whole lot more confusing.  I got a new laptop from work as my secondary laptop, I logged in with that laptop and was not disconnected at all!!!  So, with that laptop, using wifi, I was able to stay connected without getting disconnected.  On my first laptop, I get disconnected when connected to the router, but stay connected when I am directly connected to the cable modem.  Makes no sense at all anymore.   ???

I'm going to try to connect directly to the cable modem and see if my connection ever disconnects...now I am second guessing my memory, maybe I was being disconnected even with the cable modem.  Actually, I hope that I do get disconnected, this way we can pin-point it to my first laptop and then try to find the app that is causing it.

Thanks for sticking with me through all this by the way!!
Title: Re: Keeps disconnecting a session
Post by: FurryNutz on June 09, 2011, 07:04:09 AM
This is good. You have something different to try and it's working.

Does the 1st LT stay connected over a wired connection to the router?
I'm wondering if there is something driver related maybe on the 1st LT, both wireless and wired that the driver need to be re-installed or updated?

What kind of wireless is the new LT have? Broadcom or Atheros or something like that? Make sure the new LT can stay connected over wired as well. Keep us posted.