D-Link Forums

The Graveyard - Products No Longer Supported => IP Cameras => DCS-930L => Topic started by: TD99 on March 24, 2011, 11:24:49 AM

Title: myD-Link "Live Video" function and Firefox 4 (DCS-930L)
Post by: TD99 on March 24, 2011, 11:24:49 AM
I just upgraded from Firefox 3.6.1.5 to version 4.0 on one of my systems and now the Live Video function no longer works. There is simply no picture. No black box, nothing. Here's a screenshot.

Has anyone else experienced this problem???

I'm not having this issue with IE8 + ActiveX, just with Firefox + Java.

(http://img858.imageshack.us/img858/7594/mydlink1.png)


Title: Re: myD-Link "Live Video" function and Firefox 4 (DCS-930L)
Post by: TD99 on March 25, 2011, 09:47:49 AM
I've since disabled and removed all Java-related add-ons in FireFox 4.0, removed everything Java-related on the computer via "Add/Remove Programs" (this is an XP system), rebooted, went back to mydlink.com where I was told to download and install the latest Java Run-time.

Did all that, still same issue.
Title: Re: myD-Link "Live Video" function and Firefox 4 (DCS-930L)
Post by: Terryl on March 27, 2011, 02:01:01 AM
I have the same problem, FireFox does not support the OCX.DLL Active X control for the video from the DVR's, I have to use IE, you can post a complaint about it in the FireFox forums. 

Code: [Select]
http://forums.mozillazine.org/index.php?c=4
Title: Re: myD-Link "Live Video" function and Firefox 4 (DCS-930L)
Post by: TD99 on March 28, 2011, 09:55:37 AM
I have the same problem, FireFox does not support the OCX.DLL Active X control for the video from the DVR's, I have to use IE, you can post a complaint about it in the FireFox forums. 

Code: [Select]
http://forums.mozillazine.org/index.php?c=4

Ahh I see. Well, that prompted me to remove Firefox 4.0 and reinstall 3.6.16 just moments ago.

Everything is fine now. I don't see any compelling reason to go to 4.0.
Title: Re: myD-Link "Live Video" function and Firefox 4 (DCS-930L)
Post by: limkoDesFF on March 29, 2011, 12:42:14 AM
I did have encountered the same problem but I did have it work. It is that you didnít got it working after installing the latest java-runtime because I got it working on mine. Maybe you have not installed the java runtime correctly, better yet try to post on the firefox forum maybe they can help you.


Try our indianapolis seo (http://www.computerseo.com/) with seo services (http://www.computerseo.com/)
Title: Re: myD-Link "Live Video" function and Firefox 4 (DCS-930L)
Post by: TD99 on March 29, 2011, 02:58:02 PM
I did have encountered the same problem but I did have it work. It is that you didnít got it working after installing the latest java-runtime because I got it working on mine. Maybe you have not installed the java runtime correctly, better yet try to post on the firefox forum maybe they can help you.

Pretty sure I installed JRE correctly: Next > Next > Finish...
Title: Re: myD-Link "Live Video" function and Firefox 4 (DCS-930L)
Post by: acellier on April 01, 2011, 12:43:32 PM
I have the **identical problem** with Firefox 4 on a Mac (10.6.7) - system is fully updated with Java. It worked with Firefox 3.6.15
Thanks for pointing to Firefox 4 as the problem. True in both 64- and 32- bit modes.
It works still, on Safari; had to check in Preferences to enable Java. Firefox does not seem to have a control.
I submitted feedback to Firefox (Mozilla), suggest others do also.
Title: Re: myD-Link "Live Video" function and Firefox 4 (DCS-930L)
Post by: TD99 on April 05, 2011, 12:16:39 PM
Is it a Firefox issue, or a D-Link one (e.g. they need to update the myDlink site to properly detect and support the 4.0 browser)?
Title: Re: myD-Link "Live Video" function and Firefox 4 (DCS-930L)
Post by: xploremore on April 05, 2011, 05:29:23 PM
I do have the live video feed working with Firefox 4 so it can work with this browser. The only issue; if I migrate away from the dlink browser page, when I come back to it I have to re-click the Java button again.

I think that active-x is only supported within IE, not Firefox. However, this is remedied by choosing the Java option for live feeds when using Firefox.

I doubt this is the case but I believe it is also possible to call on earlier versions of Java. I would make sure that you have at least 6v19-20 or above. In almost all cases you can uninstall all earlier versions prior to your latest version from within add remove programs.
Title: Re: myD-Link "Live Video" function and Firefox 4 (DCS-930L)
Post by: three_jeeps on April 06, 2011, 12:28:30 PM
um, my experience is different than what you all stated above.  I have no problems when using FF 4.0 works fine.  I do, however, have a problem with 3.6.16.  Keeps saying I need to install the Java plugin, I install the plugin, relaunch FF 3.6.16, clean the cache, etc. and try again...same problem: need to install the plugin.  I checked the JVM on the machine and it indeed tells me the current  JVM is installed...and my other Java based apps work fine...So, IDK what is messed up...
It is strange b/c on other machines, BOTH FF 3.6.16 and  4.0 work.   Go figure...

If I run into that problem, and just revert to using IE, which is the *only* reason I use IE...well except to talk to sharepoint (but that is another M$ captive application...)

-J