D-Link Forums

The Graveyard - Products No Longer Supported => D-Link Storage => DNS-320 => Topic started by: patrapao on February 20, 2011, 11:35:23 AM

Title: DNS 320 File/Folder permissions issue
Post by: patrapao on February 20, 2011, 11:35:23 AM

I've been having a major issue with permissions. I'm not exactly sure if the fact that I primarily use Maac OS X has to do with anything. Nonetheless I've tried the repair steps below through windows and Mac.

After trying to activate the iTunes server on my NAS, the library kept building and then at around 30% the NAS froze and then whenever I turned it back on again, it would be going on an infinite loop, starting to build the library and freezing at 30% and so on. I couldn't find a way to disable the iTunes server other than restoring factory settings. Now, my permissions are all messed up, thankfully I have read access to everything but can't write. Creating a new sharing rule for the root directory only permits me writing on the root directory, none of the subfolders :-S
So i tried running a scandisk for the permissions to be repaired, but once i click to initiate the scan, after several seconds of initializing the bar goes directly to 100% and I get a grand ol' failed. I have none of the internal apps running and I haven't added "funplug" or whatever that is, I've let the NAS alone...

Question 1: What could be preventing scandisk from running?
Question 2: Possible solutions for the scandisk and/or permissions problem?
Question 3: Could d-link please implement an option to schedule a disk check right after the NAS is restarted, it would make our lives so much easier!
Question 4: The iTunes Library can't be built, will it be fixed?