D-Link Forums

The Graveyard - Products No Longer Supported => D-Link Storage => DNS-343 => Topic started by: nataku316 on September 24, 2008, 09:32:06 PM

Title: System random lockup
Post by: nataku316 on September 24, 2008, 09:32:06 PM
I have been experiencing random system lockup from time to time, it could be in the middle of use or unused for hours vary random. The NAS is not accessible at all, not by web or ping. The display on the device seem to show everything as normal but the system its self does not respond, furthermore it cannot be shutdown, itíll get to the halting system part and freeze there Iíll had to pull the power every time. This gets better, the most recent time this happened it asked me to reformat 1 of my 4 drives, even better is the format stops at 94%. Now I know the format freeze thing was a problem on the DNS-323 didnít know it was also a problem on this one too.

All 4 drives are Seagate ST3500320AS 500GB

Would someone happen to know if there will be a firmware update coming sometime soon, I had this for about a week and have seen more problems than any.

If someone from D-Link is reading this, there are a lot of problems with this device that needs to be addressed.
Title: Re: System random lockup
Post by: D-Link Multimedia on September 25, 2008, 11:15:01 AM
Posted a firmware today. Also, if you are having specific issues with the device's functionality list them here or start a new thread with your feedback. The more details the easier it is to look into and address.
Title: Re: System random lockup
Post by: nataku316 on September 25, 2008, 10:44:38 PM
thanks for the quick replay, i upgraded to 1.02 and was able to format that one drive. however when i restarted, the RAID5 was gone.... the volume was gone and so is all my data :'( I backed up some of my main data ahead of time so it's not too bad but still not happy about it. I have since tried to reformat all 4 drives on RAID5 that end up getting freezing on 94% too, did it again it finished the 2nd time created a volume but when i restart the device the volume was gone and the RAID5 was gone too, it asked me to reconfig the drives again.
Title: Re: System random lockup
Post by: marklagrande on November 17, 2008, 11:48:46 AM
I am also having a similar problem with random lockups.  OLED panel is normal, but there is no network accessibility to the 343, via ether web interface, easy search utility, or network shares.  Shutdown and reboot fixes the problem temporarily, but it reoccurs within anywhere from 15 minutes to 12 hours later.  Interestingly, I've had the 343 running for almost 2 weeks but this problem didn't occur until after it had been running problem free for 4 or so days.  Since then there have needed to be 2-4 reboots per day.

One possible clue.  I got a 1G Ethernet switch and a new 1G NIC for my main PC to upgrade to a higher networking speed.  I had just enabled the jumbo MTU feature on the 343 sometime shortly before I started getting the lockup problem.  I've switched back to the normal MTU size, which appears to have no effect on this problem.  Still running it at 1G connection speed, though.  Maybe just a coincidence?

I'm running the 1.02 firmware, have 4 750 GB Hitachi disks in a RAID-5 config.  I had no problem with inital disk formatting (it just took a way long time.)  It works great when it works, so I'd like to find a solution for this problem.

I sent a problem report on this into tech Support via the web email form a number of days ago, but have had no reply.  Have there been layoffs there recently?
Title: Re: System random lockup
Post by: marklagrande on November 18, 2008, 10:18:38 AM
Lockup problem seems to be solved.  At least it's been over 24 hours since the last lockup, so at the very least it's much, much improved.

Saved my 343 configuration.  Reset to factory defaults (via the web interface.)  Restored my configuration.  Haven't had a lockup since.

Sometime when I have more time on my hands than I know what to do with, I may experiment with the jumbo frames feature and see if that might have been linked to this problem.
Title: Re: System random lockup
Post by: mk1184 on January 04, 2009, 12:10:28 AM
Had a similar experience with exact same symptoms.  Lost connectivity to the unit in mid-copy and in my case the lockup seemed to occur right when the fans kicked into HIGH mode for what I believe was perhaps the first time ever on this brand new unit, but certainly the first since upgrading the firmware.

Had to yank the power cord to reset it, of course, and upon reboot it predictably launched into a re-sync of the RAID-5 volume.  Locked up again as soon as the the temp reached 48 C (which didn't take but a minute or two).  Reset it a second time and thus far it's several hours into the re-sync without incident.  The fans have been oscillating OFF-LOW-HIGH-OFF throughout.  :-\

(4 x Hitachi 1TB "approved" drives).

UPDATE #1  1/4:  Well, sometime 8+ hours into the rebuild it apparently failed, leaving Volume_1 in a "degraded" state.  With no way to force a rebuild there was little choice but to restart.  Of course it then launched into another 900+ minute rebuild -- but no indication of drive failure, etc.  At that point I decided it would be faster to reset the config to defaults, kill the partitions on the drives, and start over.  So I did and everything went smoothly -- RAID-5, EXT3, formatted quickly, off we go.  I then copied about 80 gb of data over the course of several hours to it, when all of a sudden -- BANG -- lockup.  Unreachable via the network interface.  Could still cycle the OLED, although it had stopped refreshing.  Temp was 45įC at lockup, so I know it wasn't an overheat situation.  Perhaps I have a bum drive in the mix, however these are drives that got the full Hitachi diags run on them prior to install.  Grrrr.  I'm really regretting having updated the firmware at this point...  :(


UPDATE #2  1/14:  Finally ferreted out an intermittently faulty disk that was causing the rebuild to fail.  The DNS never failed the disk, however.  Since replacing it I've experienced lockups on two additional occasions right at the moment the unit kicks the fan to high-speed at 49 C.  Doesn't happen every time, but at this point I believe it's more than just coincidental.  Definitely something quirky going on there....   ???

Title: Re: System random lockup
Post by: Malacoda on January 27, 2009, 04:08:43 PM
I have the new 1.5TB drives and 1.02a firmware with 4 drives in Raid 5.  I'm using gig-E.

I can copy large files fine, but I can reliably get the lockup when copying or deleting a large number of files (not large files) to the unit from my Mac systems via SMB.  Windows seems to treat it better, but more testing is needed.

The system would run the fan at full speed, freeze at System Halting when I go to shut it down, and refuse to respond to ping or web requests.  Pulling the cable returns it to normal, but it also cause the Raid to resync for an estimated 1300 minutes.

Thinking that this may be some system-level software issue, my current test was to revert to factory settings and reinitialize every drive as an individual drive.  If it locks up after the same file copy, then I know it was some setting that didn't upgrade well with the firmware or that its a problem with the Raid software (since I imagine individual drives would use a simpler driver).

My suggestion to tech support is to test 1.02a with a large number (40k+) of small files and delete them.  Also check upgrading 1.01 to 1.02a settings.
Title: Re: System random lockup
Post by: JaLooNz on January 29, 2009, 05:56:30 PM
You might be affected by the 1.5TB drives with lockup issues.
Title: Re: System random lockup
Post by: rooney on February 24, 2009, 12:43:15 PM
I am also seeing the lockup issue with firmware 1.02A. It is connected via Gig-E using DHCP and no jumbo frames. I have 4 Seagate ST31500343AS 1.5TB disks configured for RAID 5. I have it mounted via CIFS from a linux server. It locked up and was unresponsive via ping/www/CIFS. I was still able to see information via the OLED, however I had to power it off and back on before I could establish any connection with it.

It would be useful if there was a method to access the syslog on this unit.
Title: Re: System random lockup
Post by: nataku316 on February 27, 2009, 09:36:21 PM
still seeing system lockups, better than before but just had one the other day. still has a lot of issues with this
Title: Re: System random lockup
Post by: kjb on March 01, 2009, 12:36:21 AM
I, too am seeing random lockups during transfers. I am using 4 Seagate ST31500341AS 1500 GB drives in RAID 5 configuration. I am using v103 for firmware. Tried 102 and 102a, neither would format the 1.5TB Drives. Finally formatted three into raid 5 and added the fourth.
Still bothered by the random lockups. Would be real nice to get this resolved soon. I can't recommend it if it doesn't work.
Title: Re: System random lockup
Post by: kjb on March 01, 2009, 12:49:24 AM
Also, ref my previous, my syslog shows all four drives fail simultaneously.  My drives are not included in the seagate firmware list.
Title: Re: System random lockup
Post by: JaLooNz on March 01, 2009, 05:20:50 AM
Are you on the Seagate 1.5TB drives? Almost all 1.5TB drives are affected except for those on CC1H/CC1J firmwares (ie a firmware has been released to fix the freezing issue and the problem with the drives being suddenly undetectable, but the website is not really that reliable earlier on in identifying the affected drives). Maybe you can try using the drive on a PC for a while and see if it can isolate your issue. AFAIK having all 4 drives fail within such a short while is definitely not normal.

I am using 4x 1.5TB CC1H on firmware 1.02A and so far everything has been fine (filled around 2TB). The only issue I have is with the vibrations of the drives and one of the drive "clicking" somewhat, but otherwise fine for storage.
Title: Seagate drives and system offline
Post by: kjb on March 06, 2009, 11:53:41 PM
None of my drives are on the seagate list of those affected. I don't think is the drives but the firmware. It appears others arr have their 343 "lockup", "go offline" or other descriptions. Bottom line is that the firmware is having difficulties w/1 and 1.5 TB drives w/94% format freezing and their system become invisible to the network. I tried to download the 1.06b firmware but they seem to be limited as to who can download. Can we get a Dlink techie on this format?
Title: Re: System random lockup
Post by: mike343 on March 24, 2009, 02:59:33 AM
I'm experiencing the exact same problems as outlined in this thread.  343 (1.02) locks up mid file transfer (typically during 1GB+ files sizes) and is unresponsive to Windows Explorer, ping and the front-panel control buttons.  Connected via GigE, no Jumbo Frames, using three Samsung 500GB drives, RAID5.

A few hours ago I had to yank the power to reset the 343. Upon reboot the display and the web interface show "Temp HOT" but the unit's temp is 45C.  :-\  The RAID5 was still there and it's synching right now...I'm not touching it until the sync is done.  I'll probably soft-boot it then to see if the "hot" indicator goes away.

I read some other similar posts here and to be fair, though I have a static IP set on the 343, it's IP was within the DHCP scope given out by my switch. I.E. my scope goes from .2 to .100 BUT, I don't have enough devices taking IPs (only 5 devices on my network) to even get close to the IP that's set on the 343 (.30)

I have since changed my DHCP scope to stop assigning before it reaches the IP of the 343.  I honestly don't think that's the problem...I think there are firmware issues.  But I'll report back later and LYK how it's going.
Title: Re: System random lockup
Post by: roflcopter666 on March 24, 2009, 05:36:20 AM
Mine was faultless for 3 weeks, and started locking up yesterday.

I have to pull the power to get it active again.  Cannot access firmware, but can ping ip of NAS.

I have static IP set on it - have also tried dynamic with router assigning via DHCP to mac of NAS, but same.

I have 3 x 1TB WD drives in RAID 5.

I thought it coincided with enabling FTP server, but have disabled it and same issue.

Also had it coincide with refresh AV server sticking @ 67% on 2 occasions.

If I reset to defaults, then restore config as mentioned earlier, will I lose any data or RAID configuration??
Title: Re: System random lockup
Post by: mike343 on March 24, 2009, 06:24:55 AM
Disk sync completed successfully. I soft-booted from the web console and the "hot" warning is gone from the display.  I just copied a 1.2GB file from my PC to the NAS; it completed successfully but took slightly more than 3 minutes.

I'm not too concerned about speed; I want data security and device reliability.  I want to be 100% (or darn close to it) positive that when I try to hit the shared drive that is my NAS that it will pop up all the time.  Right now that's not happening.

I take very few chances though.  The data on my RAID5 array is also backed up to an external 1TB USB HD.  Good idea, yes, but shouldn't be a "forced necessity" IMO.
Title: Re: System random lockup
Post by: roflcopter666 on March 24, 2009, 02:00:23 PM
Interesting about the system overheat hot warning - mine also displayed this after hard reboot, however when rebooted again only displayed temp as 44deg.

Is there any log file that can be extracted to try and work out what is happening?
Title: Re: System random lockup
Post by: mike343 on March 24, 2009, 02:28:10 PM
AFAIK, there is no viewable/exportable log file for the 343.  IIRC, that's been on the "firmware wishlist" for awhile. 

The 343 has the potential for greatness; it just needs some more attention by DLink.  If PC motherboard manufs can release a new BIOS every couple of weeks (if need be) I don't see why it takes so long to work out bugs on a much simpler device like the 343.
Title: Re: System random lockup
Post by: roflcopter666 on March 24, 2009, 04:16:02 PM
Should we be calling DLINK support to raise support cases? 
I am unclear if this is an issue across the board, or whether it may be a batch and RMA/Warranty would fix.
Title: Re: System random lockup
Post by: roflcopter666 on March 26, 2009, 10:24:01 PM
Did a system reset and re-configure - so far so good..
Title: Re: System random lockup
Post by: mk1184 on March 27, 2009, 12:20:02 AM
Stick with 1.01 unless there's some feature you just can't live without.  And yes, you can downgrade this unit despite what support may tell you.
Title: Re: System random lockup
Post by: roflcopter666 on March 28, 2009, 12:24:07 AM
Locked up again as soon as tried to share root on uPNP AV server.
Every time I refresh AV server, I get 93% then "there was a problem with the request" popup error.
I have disabled i Tunes server.
Anyone know a fix?
Does this need to be raised with DLINK support?
Mate has QNAP 409 and has no problems with his NAS and I am starting to think I should have followed his lead, being they have regular firmware updates and an active forum.
Title: Re: System random lockup
Post by: rbascom on March 29, 2009, 04:05:43 PM
I have been reading your comments here and despite the problems I've seen, I went out and bought a DSN-343 along with four Seagate 1.5TB 32MB SATA Bulk/OEM Hard Drive ST31500341AS (firmware ver: CC1H). I figured that by the time that I got them, maybe the problems would be resolved. NOT so!!!!

I am experiencing the same frustration with the DSN-343 that I see others here are having; "hangs at 94%" being at the top of the list.

The first thing I did was upgrade the firmware to 102a. Now I know its beta, BUT that's the only way to get 1.5 TB supported, right? I tried different browsers (IE6 and Firefox, clearing cached cookies, waiting up to 48 hours on the 94% before giving up and in week's time, I still have not been able to get the four 1.5TB drives to format in RAID 5, RAID 1, RAID 0, or even just individual drives without the "hangs at 94%" issue.

I am almost at the point where I am ready to put this in the box, return it to amazon.com, and ask for a refund. And that's a shame, because I believe as you all seem to, this could be a such a GREAT little box "IF" the problems can be worked out.

Before I completely throw in the towel here, I intend to down grade to v102 (maybe 101) and use 400Mb drives. I'd just like to see if they will complete any RAID format or even individual drives.

DLINK techies definitely need to be brought in on this. It's not just a random happening. I am reading way too many other threads where others are in similar positions and are not happy.

Title: Re: System random lockup
Post by: Aquilae on April 01, 2009, 06:18:59 PM
Same issue.

Randomly freezes (usually when transferring files to it), can not even ping.

When I power down, it just stays on the halting screen. Have to manually power it down by removing the power cable.

Has happened 3 times now.

When I power back up, it resyncs for 500 minutes.

Each time I reset to defaults and it occurs again.

This is ridiculous.

Config:
Firmware: 1.02b10  (newest, as per the www.dlink.com.au website)
RAID 5
HDDs: 4x WD 500GB HDDs, these are on the list of compatible HDDs
I've tried EXT3 and EXT2
Title: Re: System random lockup Resolved!!!!!!!!!
Post by: kjb on April 11, 2009, 12:16:23 PM
I found a firmware upgrade for my Seagate ST31500341AS drives.
The problem of the system lockup (with the 1.02a firmware) and these drives is that they will drop out of the array periodically.  I found this on the seagate site:
http://seagate.custkb.com/seagate/crm/selfservice/search.jsp?DocId=207931

Google is my friend.
hth
Title: Re: System random lockup
Post by: sliderwkw on June 15, 2009, 08:00:26 PM
actually I have read many reviews and forums post and found that DNS 343 has many issues with seagates harddrives and the only solution is to manually update all the seagate harddrives with the latest firmwares especially with 1.5TB drives. I have seen reports that seagate harddrives suddenly unplugs until shutting down and powering up DNS 343 again and after the guy updated all the Seagate harddisks, everythign works fine....
Title: Re: System random lockup
Post by: ECF on June 16, 2009, 10:31:16 AM
Yeah Seagate was actually having issue with the drives and had to create new firmware. Seagate did not create new firmware firmware just for use with the DNS-343 they has issues to work out.
Title: Re: System random lockup
Post by: gsrider on July 08, 2009, 06:06:21 PM
I have the same issue as everyone else in this thread, I had been using the 1.03 beta, but went back to 1.02... I do have two seagate drives, will it break the raid to update the firmware? And is there any way to update firmware inside the DNS or do they have to come out?

TIA
Title: Re: System random lockup
Post by: Bhavik on July 09, 2009, 12:15:00 AM
I upgraded my 4x Seagate 1.5TB drives firmware after I had created RAID 5 on the DNS-343. You will only see the locking up issue with the Seagate drives in RAID configuration.

I did not loose any data in this process. This is what I did.

1. Power down the DNS-343
2. Pull 1 drive out and then put it into PC
3. Upgrade the firmware
4. Put the drive back into the slot I took it out of.
5. Repeat for all the drives.

Note: Just because I did not loose any data in this process, doesn't mean you will. I recommend you backup all your data first.