D-Link Forums

The Graveyard - Products No Longer Supported => D-Link Storage => DNS-321 => Topic started by: dkarim on January 02, 2011, 05:43:34 PM

Title: DNS-321 folder permissions problem
Post by: dkarim on January 02, 2011, 05:43:34 PM
I just bought my DNS-321 and up until yesterday I was moderately happy with it. As soon as I turned on the folder permissions, my perception has changed. I have been having all sorts of issues with it and I am about to throw this thing out the window. I consider myself pretty knowledgeable and I have noticed that there are a lot of people having problems with the folders changing permissions for no reason. That is what happened to me. For some reason, some folders went to read-only and I can't change them back. I did a factory reset, as has been suggested and that only fixed the problem with one folder. There have been suggestions to install this fun_plug to give me telnet access and change the permissions through Linux. Why do I need to bother? Doesn't D-Link care enough to fix this issue which apparently has been around for at least a couple of years? I would appreciate some help; I would appreciate even more some support from D-link.
Title: Re: DNS-321 folder permissions problem
Post by: jamieburchell on January 02, 2011, 06:48:28 PM
Were you using a Mac to create these files/folders? How did you create them?
Could you describe the symptoms in more detail? What do you mean by read-only? Prompted for credentials/access denied on write/delete?....
Title: Re: DNS-321 folder permissions problem
Post by: dkarim on January 02, 2011, 07:06:18 PM
Yes I was using a MAC when creating them. For example, right now I have an empty folder which I cannot delete. I get a message which says: The operation canít be completed because you donít have permission to access some of the items.
Title: Re: DNS-321 folder permissions problem
Post by: dkarim on January 02, 2011, 07:35:34 PM
Also, the folder which I am trying to delete shows as "You have custom access" under Sharing & Permissions on my Mac. I think that's fine but the parent folder shows "You can only Read" under Sharing & Permissions. So that's why I can't delete that folder. Also, I can't drag any files onto that parent folder. I already tried restarting the D-link and restoring to factory defaults as well as rebooting the Mac.
Title: Re: DNS-321 folder permissions problem
Post by: jamieburchell on January 03, 2011, 11:48:44 AM
This thread may help explain the issue

http://forums.dlink.com/index.php?topic=11331.msg93163#msg93163 (http://forums.dlink.com/index.php?topic=11331.msg93163#msg93163)

It seems that when files and folders are created on the NAS with a Mac, the permissions are set differently to Windows users.

There are some work arounds and related threads that might come in useful.
Title: Re: DNS-321 folder permissions problem
Post by: dkarim on January 03, 2011, 02:58:05 PM
Thanks Jamie, I certainly do appreciate the help. That article sure helped since it hadn't occurred to me to go to the mounted NAS drive and edit the permissions using chmod via terminal. Unfortunately although I was able to change one folder's permissions, for some reason I wasn't able to change the other even after defaulting the box again. But I am now feeling that this issue is certainly more Mac related than D-link related so I am not about to throw out my DNS yet. I decided to reformat and after also finding the article below I decided to do something about these nasty little .DS_Store files that Macs create since they may also cause some problems.

http://forums.dlink.com/index.php?topic=12715.0 (http://forums.dlink.com/index.php?topic=12715.0)

That forum post led me to an article about how to disable the .DS_Store files. I noticed that these were created as read-only so I decided it's best to disable them from NAS drives. They were also the only files present in one of the folders I couldn't delete before. This is the terminal command to do it:

defaults write com.apple.desktopservices DSDontWriteNetworkStores true

Also, I am giving in and installing the fun_plug just in case I have issues again in the future since that seems like it should allow for easier change of permissions (I hope). I also read somewhere else that apparently permissions are not changed when files are moved from a Mac but when they are moved from a Windows machine they are set as 777 by default. This might also explain why there are more Mac related issues than Windows. I will put my files back on the DNS and I will report later. Hopefully I won't see more issues.

UPDATE: So far after several days of use (today is 1/12), no issues with folder permissions.
Title: Re: DNS-321 folder permissions problem
Post by: atcontroller on January 22, 2011, 05:45:33 AM

This seems to be my issue but I cannot seem to resolve!  Mainly, I have a MP3 located at /Volume_1/MP3 that keeps all of our music for the house..  The Windows and Ubuntu machines have no problem reading it.

My iMac has a huge problem reading anything past the /Volume_1/(Root)...  It can see all the folders but when I go to open a folder, it just hangs and can't read.   I have done the  .DS_Store fix...  but I'm really confused on the permissions stuff...  I installed fun_plug as well but not sure if I did it right.  I have a folder on there called Alan...  While using fun_plug, I attempted to reset the permissions of this folder.. Voila, I can read it now from my iMac...   I then did the same thing on the MP3 and nothing...    All of the folders/files on the DNS-321 were written from my Window's computers.   

So I've moved iTunes back to my PC, again.   I would much rather put it on the iMac but not being able to add music from my MP3 folder just makes it useless...   

Any suggestions or ideas based on what you were able to accomplish?

I'm running Snow Leopard 10.6.6..

Title: Re: DNS-321 folder permissions problem
Post by: jamieburchell on January 22, 2011, 12:40:19 PM
I'm not sure, but I've now read a few posts that specifically mention Snow Lepoard as the contributing factor to the issue.
Title: Re: DNS-321 folder permissions problem
Post by: dkarim on January 28, 2011, 11:21:53 AM
atcontroller, you said you weren't sure if you installed fun_plug correctly but then you said you reset permissions using fun_plug. If you are still not sure if you installed it correctly, the first question is can you telnet or ssh into your DNS? if you can, then you should do an 'ls -l' on the directory you are trying to reach. The files in it should show rwxrwxrwx. If not, then do a chmod 777 on them. Also, check the parent directory and its parent, etc to make sure they have 777 permissions also.