D-Link Forums

D-Link IP Cameras for Home => DCS series Network Cameras => Topic started by: cornelshs on May 17, 2008, 02:33:58 AM

Title: Silverlight and Dlink 6620G
Post by: cornelshs on May 17, 2008, 02:33:58 AM
Hello

I have a Dlink 6620G Wlan IP camera.
I have Windows Vista and silverlight installed.

I get the http 400 error message
How do i fix this?
Title: Re: Silverlight and Dlink 6620G
Post by: ECF on May 19, 2008, 10:11:03 AM
The Silverlight add-on is not supported in the IE broswer with the DCS-6620/6620G camera's currently. We are working to find a resolution for this issue.
Title: Re: Silverlight and Dlink 6620G
Post by: cornelshs on September 15, 2008, 09:18:53 PM
Found any solutions or what?
Can i use the crappy dlink program to view my camera?
Or do i have to buy a new camera from an other company?
Title: Re: Silverlight and Dlink 6620G
Post by: ECF on September 16, 2008, 11:14:46 AM
The D-link software has never had a problem with Silverlight this was only seen in the browser and has since been resolved as Silverlight is no longer beta and SP3.

Please use D-VIewCam 2.02 from the support website.

 
Title: Re: Silverlight and Dlink 6620G
Post by: usernameandpass on September 21, 2008, 07:59:43 AM
Well it isn't resolved with the 3220. I had the latest version installed and I've been having problems managing the cameras from my laptop (gettting HTTP400 bad request pages). I just uninstalled Silverlight and the web page now works. I had been screwing around with this laptop for a month trying to figure out what the problem was using IE6 and IE8 beta, as I thought the browser was the issue. What gives? Who needs to address the issue? You or Microsoft?
Title: Re: Silverlight and Dlink 6620G
Post by: ECF on September 23, 2008, 02:58:56 PM
Well our camera works fine it just seems to not be working after Microsoft created Silverlight and people are using the addon in there browser. However this issue seemed to have gone aways since SP3 and newer versions of Silverlight. To my knowledge the issue was gone I have it working fine on XP SP3 and Vista SP1 with Silverlight so I cannot replicate the issue any longer.
Title: Re: Silverlight and Dlink 6620G
Post by: cornelshs on September 23, 2008, 08:02:51 PM
It is NOT working!

I've installed sp1 and all the other patches from Microsoft on my latop with Windows Vista Ultimate 64bit.
Have you tried 64bit?

The point of having this camera is that you can check status on things wherever you are in the world, not to be bound to one computer with one app installed. Cant install DView on all the computers in the world.

Title: Re: Silverlight and Dlink 6620G
Post by: ECF on September 24, 2008, 11:40:09 AM
I am not using 64bit Vista I will have to test this to see if it is just a 64bit issue now. Do you only have this once PC

This camera is supported in IE 6 or 7 and can be accessed from anywhere and it does work fine in both of these browsers as stated on the box, however Microsoft has created and add-on called Silverlight that has added a header to the browser and creates and environment that does not allow you to access the camera if you are using this addon. Now what needed to be determined is if D-Link needs to create new firmware for every camera to allow them to work with this one addon or if Microsoft has fixed it so network device such as an IPs camera do not have an issue in IE. Since newer version of Silverlight and XP sp3 and Vista SP1 the issue for the most part has seemed to go away I have not herd much about it. I am currently unable to replicate the issue in our lab so before we go and just make new firmware for every camera we have just for an addon Microsoft created this issue will have to be replicated and the cause determined and what is the best course of action to be taken.
Title: Re: Silverlight and Dlink 6620G
Post by: lapimate on September 29, 2008, 07:52:03 PM
Well our camera works fine it just seems to not be working after Microsoft created Silverlight and people are using the addon in there browser. However this issue seemed to have gone aways since SP3 and newer versions of Silverlight. To my knowledge the issue was gone I have it working fine on XP SP3 and Vista SP1 with Silverlight so I cannot replicate the issue any longer.

Unfortunately the issue has not gone away with XP Pro SP3; it apparently depends on the current size of a particular registry key in your particular system.

See MBPs & coryb891s items of 5 Aug 08 in
HTTP 400 Bad Request+SilverLight
http://silverlight.net/forums/p/7452/77779.aspx

They provide an explanation. It looks like it could be fixed (a buffer length) in the camera software by D-LINK.
Title: Re: Silverlight and Dlink 6620G
Post by: lapimate on September 29, 2008, 10:48:53 PM
... It looks like it could be fixed (a buffer length) in the camera software by D-LINK.
DCS-6620G firmware 1.05 5 Aug 08 Firmware Release Note states that it fixes the Silverlight issue (inter alia), and that seems to be the case so far.

Another welcome aspect of 1.05 is being able to set the e-mail SMTP port.
Title: Re: Silverlight and Dlink 6620G
Post by: usernameandpass on November 30, 2008, 08:41:05 AM
I recently sent an email to DLink support about the downgrade from IE8 beta back to IE6. (I am on the beta team hand have since completed my testing). Below is the thread posted on Silverlight's forum and apparently IE8 Beta left behind the key referenced by a couple posters here. I removed it and everything works fine. One thing I did notice is that my registry did not contain the 'accepted length' key referenced by a few posters.

http://silverlight.net/forums/p/7452/77779.aspx

IE6 SP1, IE7, and XP SP3 upgrades did not fix the issue. Be aware that IE8 appears that it will be installing silverlight by default and the removal of IE8 or silverlight will not remove the key. Odd though, IE8 Beta after it was installed did not exhibit this behavior. Only after it's removal and downgrade did the issue arise.
Title: Re: Silverlight and Dlink 6620G
Post by: usernameandpass on November 30, 2008, 08:56:09 AM
It appears that Silverlight 2.0 and XP SP3 has been fixed to correct the issues with my cameras. I installed both and everything appears to be functioning as it should.
Title: Re: Silverlight and Dlink 6620G
Post by: beesknees on February 28, 2009, 09:28:22 AM
Where can I find this 1.05 firmware upgrade for the 6620G?  I have all these same problems.  The Dlink support site only offers 1.04.