D-Link Forums

The Graveyard - Products No Longer Supported => DIR-655 => Routers => Europe DIR-655 => Topic started by: gociii on May 07, 2008, 11:22:31 AM

Title: 802.11n ... No way
Post by: gociii on May 07, 2008, 11:22:31 AM
I have switched from former TrendNET BEW-631BRP router to DLink DIR-655 for 3 reasons:

1. Gigabit ethernet (which is pretty useful when moving gigs of data from one pc to another)
2. Detachable antennas
3. Web Interface for controlling router was pretty much like the TrendNET's router

Well as soon as I set up the router using the recommended setting and with the following firmwares, :

1.11 MSBetaB39

802.11n and g only
Auto 20/40MHz

I have also tried tried :

802.11n only
Disabled encryption (but this one would mean letting my neighbors using my expensive internet connection)

with all the other possible combinations of the listed 3 options.

BUT! :

(1) I could not get the thing to work to 300Mbps
(2) I could not get encryption to work connected to my MacBook Pro whereas with TrendNET I could have done so easily straightaway

There where times where other laptops said they could not identify network type and at times totaly undetectable.

I am totally disappointed and going back to TrendNET, that just plugs at 300Mbps. I guess I'll have to sell this shi***y router at a very cheap price if I can't arrange things with its previous owner. Or else I will just wait for a decent firmware version to come out... I just hope that the limitations complaints mentioned most in this forum will fall on the engineers' and developers ears.

Please, if you know of something 1 could do to have things sorted out with this router, kindly let me know. Thanks.
Title: Re: 802.11n ... No way
Post by: AWDL on May 07, 2008, 02:00:57 PM
I think you did all you could do, minus environmental information.
I am guessing you have a Hw RevA becasue of all the firmware chronologically, but that isn't your issue since all revs are capable of saying 300mbps in MS client utility. Sorry it didn't work for you.
Title: Re: 802.11n ... No way
Post by: gociii on May 07, 2008, 04:12:22 PM
So far testing...I managed to get a 270Mbps using the DIR655 router... but no encryption... as soon as I turn encryption the router can't be seen on air or it just goes up to a 130 or 54 Mbps link. An yet my MacBook is just beside the router... doh.
Title: Re: 802.11n ... No way
Post by: Lycan on May 08, 2008, 11:06:09 AM
What is the model of the client adapater that you are using?
Also what are you using to determine the connection speed?
Title: Re: 802.11n ... No way
Post by: gociii on May 11, 2008, 01:51:24 AM
WiFi Adapter: MacBook Pro's built-in Airport Extreme Card (Atheros 802.11n Draft 2.0 based)

Using Wireless Zero Config (for Windows) and via Mac OS X 10.5(Airport Extreme menubar) to get information from OS regarding speed... WHILST verifying from Status page on web interface (on router)...
Title: Re: 802.11n ... No way
Post by: jtrout on May 15, 2008, 10:53:30 PM
For the encryption, are you using WPA, I assume? You have to use WPA/AES for 300mbps speeds. What you describe (going down to 130) sounds like you might be using WPA/TKIP?

Title: Re: 802.11n ... No way
Post by: Lycan on May 16, 2008, 03:47:22 PM
130 indicates 20 channel width or the adapter doesn't support  the 40 width.
As for the encryption AES is the only true requirement. AES Cipher is whats needed for 802.11n.