D-Link Forums

The Graveyard - Products No Longer Supported => DIR-655 => Routers => Europe DIR-655 => Topic started by: Smeden2 on March 21, 2008, 02:37:41 PM

Title: VPN not able to connect to LAN.
Post by: Smeden2 on March 21, 2008, 02:37:41 PM
After setting up a VPN server on one of my machines and also setting up a VPN client on a remote notebook I tried to connect.

The connection works, but Iīm not able to connect to my shared resources on my LAN.
Is there something more than port 1723 that needs to be forwarded and the box in the VPN-server that says "Allow access to LAN?"

 ???
Title: Re: VPN not able to connect to LAN.
Post by: AWDL on March 24, 2008, 01:48:55 PM
Doesn't sound like it. What resources are you sharing on your LAN that you are trying to get to remotely over VNC? Do you get an IP in the range of you remote (local) network on the laptop?
Title: Re: VPN not able to connect to LAN.
Post by: Lycan on March 24, 2008, 02:03:12 PM
What are the settings of the NAT endpoint filtering under the Firewall section of the advanced tab? Also is SPI on or off?
Title: Re: VPN not able to connect to LAN.
Post by: Smeden2 on March 25, 2008, 02:21:44 AM
NAT Endpoint filtering is set to Adress restricted on UDP and Port and Adress restricted on TCP. SPI is on.
Title: Re: VPN not able to connect to LAN.
Post by: Smeden2 on March 25, 2008, 02:26:14 AM
Shared resources are discshares among others. I get the IP-adress and get connected alright, but when searching for resources it looks like Iīm not part of the workgroup I have on my LAN.
Title: Re: VPN not able to connect to LAN.
Post by: Lycan on March 25, 2008, 11:25:43 AM
Disable SPI and open the endpoints to independent. See if thats helps.
Title: Re: VPN not able to connect to LAN.
Post by: Fatman on March 27, 2008, 03:55:02 PM
Wait, I just finally read this through again more carefully.

The resources you are trying to access are all SMB based aren't they?  SMB only works within your own layer 2 broadcast range, or if you have a WINS server it becomes a little more granular than that even.  If your VPN is configured to pass this information you can use SMB resources over a VPN, however if not then no go.  If you have a WINS server set up on one of the sides then things get more interesting and you have to make sure that your client has the WINS server configured and the WINS server has the correct zone setup.  However is does not sound like this is the case with you.

More importantly if you are connected and pinging the tunnel is up and there is no way on gods green earth that this router (which is not an endpoint but just a pass through by your description) can see or modify your traffic.  That's the entire point of a VPN.
Title: Re: VPN not able to connect to LAN.
Post by: Smeden2 on March 28, 2008, 12:52:21 AM
So in plain english, what do I need to do to get this working?

Or worse, your saying this router doesnīt support the possibillity to use my local resources when Iīm not home?

 ???
Title: Re: VPN not able to connect to LAN.
Post by: Fatman on April 01, 2008, 09:10:07 AM
It means that it has nothing to do with your router, you need to talk to your VPN servers tech support to ask then what you need to do to get SMB forwarding.
Title: Re: VPN not able to connect to LAN.
Post by: Smeden2 on April 01, 2008, 11:39:27 AM
Well, thatīs me and I just set one VPN up under WinXP networksconnections.
And Iīve read through the documentation on MS website about how to set up an VPN-connection.
Itīs not that complicated I thought, but obviously it is.
There arenīt that many options to set and Iīve tried to chenge it around, but no luck.

Maybe someone got it working and can help me with what I need to do.  ???


Title: Re: VPN not able to connect to LAN.
Post by: Fatman on April 01, 2008, 01:57:07 PM
On the client side it's not that complicated, but the server side requires a haul and a half as I recall.  What version of Windows did you use for the server, perhaps I can find a writeup on what you need.
Title: Re: VPN not able to connect to LAN.
Post by: Smeden2 on April 03, 2008, 02:27:40 AM
I use Windows XP Pro SP2.
Title: Re: VPN not able to connect to LAN.
Post by: Fatman on April 03, 2008, 09:38:19 AM
If you do an ipconfig /all on the server does it tell you that WINS proxy is enabled on your VPN interface?

The feature you are looking for is NetBT Proxy.

Here is a Microsoft article on disabling it (it should be enabled by default), be warned however that I can not and will not specifically recommend anything it tells you to do as it is changing your registry and it is doing the opposite of what we need anyhow.

http://support.microsoft.com/kb/319848/en-us
Title: Re: VPN not able to connect to LAN.
Post by: Smeden2 on April 04, 2008, 04:16:48 AM
Wins proxy according to article is enabled.
However there are some NetBIOS settings in the router that I havenīt tried fiddling with, so my next step is just that.
Result will follow.
Title: Re: VPN not able to connect to LAN.
Post by: Fatman on April 04, 2008, 08:22:30 AM
If your router is just a router, and not a VPN server, which is what you told me the case was then,

The Problem Can Not Be In The Router!! Period!!

Does your client have a static WINS server of the VPN server?

On a point of ignorance, I wasn't aware there were any NetBIOS settings on the DIR-655.