D-Link Forums

The Graveyard - Products No Longer Supported => D-Link Storage => DNS-323 => Topic started by: coop2481 on June 10, 2010, 07:38:30 PM

Title: DNS 323 Raid 1 degraded
Post by: coop2481 on June 10, 2010, 07:38:30 PM
Hello.. I am new to this forum. I have had a dns 323 for about two years and it has worked flawlessly until now. I am running 1.08 filmware. I got an error message the other day that HDD 1 had failed. I powered it down until I got the time to purchase another hard drive. Then I needed some pictures and I started it up again. The dns started and worked, but it said that HDD 2 had failed and HDD 1 was working. Now I cannot get on either of the drives. I have almost 250gb of data on that server and I am unsure about what to do now. I was going to just replace one of the HDD's and then let it auto build, but now I am not sure what I need to do, or which HDD to change. Has anyone else had this issue or have an idea of what I need to do.

Title: Re: DNS 323 Raid 1 degraded
Post by: gunrunnerjohn on June 11, 2010, 04:56:42 AM
Here are three different solutions to reading Linux EXT2/3 volumes on a Windows system.


I'd IMMEDIATELY stop trying to use the NAS and remove the drives.  Attempt to recover your data on a Windows system first!

I guess you've figured out now that RAID of any level is NOT backup.
Title: Re: DNS 323 Raid 1 degraded
Post by: jamieburchell on June 11, 2010, 05:42:53 AM
When you say it told you which drive had failed - are you refering to the status page or to the email the DNS can send? Do they both say the same thing? Does it actually say HDD1/2 or left/right ?

I'm starting to get concerned with the number of people who have had their DNS-323 for about 2 years and then have problems like this. Do the NAS's internals not last very long?
Title: Re: DNS 323 Raid 1 degraded
Post by: coop2481 on June 11, 2010, 01:05:53 PM
Thank your for the replies.

To answer your questions. All my data on the DNS is backed up. I dont have a problem with formatting the drives and trying again.

The DNS started not to respond or show the files so, I figured something was wrong. I looked into the log files and it told me that on the 6th of this month HDD 1 had failed and only one showed up. I then turned off the DNS until I could get another HDD, but I turned it back on and checked the log the again before doing anything and it said that HDD 2 had failed and only showed one HDD again. I did not notice if it said left or right. It froze up so I rebooted it and I reset to factory settings and it was showing the two drives and in the logs it shows that HDD2 has failed. Anytime the DNS freezes up it reports that HDD2 or 1 has failed but does not tell me which one. It says that it is Raid degraded.