D-Link Forums

The Graveyard - Products No Longer Supported => D-Link Multimedia and USB => DSM-510 => Topic started by: ECF on February 20, 2008, 12:51:06 PM

Title: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: ECF on February 20, 2008, 12:51:06 PM
The following firmware provided will roll your firmware from 1.07 only  back to version 1.02 on the DSM-510.

The DSM-510 rev_A1 seems to have an issue detecting HDMI on some TVs with firmware 1.03 and above. Please go to the link below and load the firmware provided. We are working to resolve this issue with firmware that provides all current updates and better functionality with more HDMI televisions.


Click the link below to download the code.
ftp://ftp.dlink.com/medialounge/DSM510/updater/updater.zip

USB firmware update instruction are located on the link below.
http://support.dlink.com/faq/view.asp?prod_id=2714&question=DSM-510

__________________________________________________________________________




Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: suhey on March 03, 2008, 06:38:03 PM
Thank you.  I was having this issue on a Samsung 50" dlp with firmware 1.07.  This TV has HDMI 1.3.  I rolled back the firmware to 1.02 and the issue seems to be resolved.  I look forward to a future firmware that will fix this.
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: rishabrana on March 09, 2008, 07:23:24 PM
Any update on when the fix will be coming?
I'm having issues with DSM 510 using HDMI. I have a Sony XBR 46 inch LCD TV.
After 5 minutes, the DSM 510 is rebooting or sometimes just hangs up with a  black screen.

After updating to to 1.02 neither dvr-ms or avi is working.
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: ECF on March 11, 2008, 04:39:09 PM
I am sorry but I do not have a date at this time. I am very sorry for the inconvenience.
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: pmjobe on March 20, 2008, 08:51:50 AM
I am sorry but I do not have a date at this time. I am very sorry for the inconvenience.
Anything else on this Firmware Rollback.........I don't understand why there isn't a new firmware with all the updates in the 1.07 that can include the HDMI Fix?
Being rollbacked to the 1.02 Firmware, does this mean that we're not getting any of the updates between 1.03 and 1.07?  I can't even FF or RW video when watching something? Why is this? Thanks. So far very unimpressed with the DSM-510. It's VERY inconsistent on working with Nero Media and even worse with Windows Media Player. Is there any other Media Sharing Software that works well with the DSM 510 that I can try?? Thanks!
Paul M. ;D
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: suhey on March 21, 2008, 04:17:14 AM
pmjobe: Try using TVersity.  I have been using it for years and it works great.  You have to make a profile modification for the DSM-510 to work properly.  Search their forums for exactly how to do this.  I also use this with a DSM-520.
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: ECF on March 25, 2008, 09:39:04 AM
We will be releasing firmware 1.08 for the RevA1 that will resolve the HDMI issue and provide all the current updates.
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: ECF on March 25, 2008, 02:52:11 PM
There is now firmware 1.08 available for the Revision A1. This fixes the HDMI issue. This firmware is available to download from the support site. USB update only.

http://www.support.dlink.com/products/view.asp?productid=DSM%2D510

Release notes:
Removes Intel Viiv Zone from the home screen.
Removes Intel Viiv Express wireless setup for Viiv compliant routers.
Removes ability to us a HDMI to DVI converters.
Fix potential compatibility issue with HDMI
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: billbart63 on March 30, 2008, 07:58:51 PM
Need help! I updated my DSM-510 to v 1.06 and it would not detect my HDMI. I am trying to update to 1.08 bt since I can't see my screen how am I supposed to accomplish this?
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: ECF on April 04, 2008, 01:26:43 PM
Please use the composite video output (red, yellow, white) to update your firmware.
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: jpchartier on April 28, 2008, 06:19:46 PM
Firmware 1.08 doesn't seem to work with my brand new Toshiba HDtv. When I change the DSM-510 from Analog to Digital display, the TV displays a PCM sign (when HDMI selected) but no image.
Is there anything I'm not doing right?
Thanks
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: pmjobe on April 29, 2008, 07:30:40 AM
I need to hook my DSM510 up to a Acer 24"Monitor with DVI connections. I hook it up to the HDMI on the DSM510 and DVI on the monitor. The monitor detects the signal but the picture is all washed out. any way this can work being hooked up to just a monitor alone with know computer and watch movies on it through a wireless connection to a computer???? Thank you
Oh yeah, I'm using Firmware 1.08 A1 it won't let me upgrade to firmware A2
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: ECF on April 29, 2008, 11:59:37 AM
pmjobe

A1 and A2 is the hardware revision not the firmware. The 1.08 firmware for the rev A1 does not support DVI video. What firmware are you currently using?




jpchartier

Did you have a chance to see if it worked with any previous firmware or did you just receive this TV after already updating?
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: jpchartier on April 30, 2008, 07:18:18 PM
Did you have a chance to see if it worked with any previous firmware or did you just receive this TV after already updating?


No, I was with 1.07 and upgraded to 1.08. I'll install V1.02 (A1) to see if it works this week-end. I'll get back to you on this. Thanks
JP
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: ECF on May 01, 2008, 02:23:14 PM
The Rev A1 using firmware 1.08 does not have the ability to use a HDMI to DVI converter this feature is broke in the firmware update. It looks like 1.02 is your best bet for firmware if you are going to use the HDMI to DVI converter.
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: jumpdawg on May 02, 2008, 07:59:51 AM
My 510 upgraded to 1.08. Now I am having connect issues and need to know how to go back to an earlier firmware version. I tried to go back from the menu, however the 510 always states that the firmware is up to date at 1.08 and gives no further options to reload any firmware.

How do you go back to a previous firmware level?

This did not work for me to go back to another level:
Code: [Select]
USB firmware update instruction are located on the link below.
http://support.dlink.com/faq/view.asp?prod_id=2714&question=DSM-510

Thanks
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: pmjobe on May 07, 2008, 08:40:12 PM
I've got 1.08 A1 installed and I can't seem to rollback to version 1.02 to try the HDMI to DVI on my monitor...........any ideas?? Thanks
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: ECF on May 08, 2008, 12:03:14 PM
The firmware to roll back to 1.02 works only from firmware 1.07 with was the latest firmware when the issue was addressed then 1.08 was created for rev A1 and rev A2 to resolve issues. 
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: pmjobe on May 12, 2008, 11:07:42 AM
So I need to go roll back my firware to 1.02 again and you're telling me because I have 1.08 A1 installed I can't now. HOW then am I going to use this junk if I can't roll back to a previous firmware. Is there any way to do a factory Reset to the first installed firmware???????????????????????????  I need this fixed!
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: jpchartier on May 12, 2008, 04:23:41 PM
Hi ECF,

The version 1.08 doesn't want to be downgraded to v1.02.
Is there a way to reset completely the unit and then apply v1.02?


Thanks
JP
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: ECF on May 12, 2008, 04:42:39 PM
Downgrading firmware is not a supported function on the DSM-510 or any of our media extender devices.
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: jpchartier on May 12, 2008, 06:41:03 PM
Ok, I was answering your question regarding my previous post.

So, V1.08 cannot recognize my brand new Toshiba HDTV via HDMI and I cannot go back to V1.02.

I guess no hdtv for me via the dsm 510.

By the way, it took me a whole day to install a RJ45 from my pc to my upstairs tv to get the DSM wired.

Is there a V1.09 on the way adressing this issue?

Thank you.
JP
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: ECF on May 13, 2008, 09:26:53 AM
jpchartier

Are you using an HDMI to DVI converter as well? What Hardware revision is your unit?
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: jpchartier on May 13, 2008, 04:05:09 PM
No, hdmi both ways. H/W rev is A1.
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: pmjobe on May 13, 2008, 05:01:39 PM
I'm using HDMI to DMI, now what can I do, because I'm stuck at 108 A1 and need to back to 1.02
Why don't anyone just fix this issue instead of cutting out things that work in new firmware, doesn't make any sense. I need a fix for this problem, not watching my DSM510 until this fix comes out!!!!!!!!!!!!!!!!!
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: ECF on May 14, 2008, 09:34:51 AM
jpchartier

Did previous firmware work using HDMI with this same TV model?

pmjobe

I am very sorry but it seems to be an issue that cannot be avoided to allow HDMI to work properly for all the people using HDMI. I am very sorry for the inconvenience but DVI is not supported on this device.
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: jpchartier on May 14, 2008, 02:24:04 PM
Hi,
No, first try at HDMI, since the HDTV is brand new.
Thanks
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: pmjobe on May 16, 2008, 08:42:04 AM
jpchartier

Did previous firmware work using HDMI with this same TV model?

pmjobe

I am very sorry but it seems to be an issue that cannot be avoided to allow HDMI to work properly for all the people using HDMI. I am very sorry for the inconvenience but DVI is not supported on this device.

You told me in an earlier post that HDMI to DVI was supported with the 1.02 firmware, and now you tell me that it's not even supported by this device! What a bunch of junk. Not very good customer support when you're told 2 totally opposite things about a product..........When's the new firmware going to come out??? 108 is junk
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: ECF on May 19, 2008, 11:20:37 AM
This is not a supported feature of the DSM-510 but it has worked with the 1.02 firmware but there were also many other issues with this firmware using HDMI is why it was updated.
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: kevinsmith121 on May 21, 2008, 06:45:14 PM
Please can you help me, I have a 510 and I have the HDMI compatibility issue. I have 2 TV's that use HDMI and I was happily using the device until I came across the firmware update feature on the DSM-510 I did it and I have lost HDMI. My problem is that I do not have a TV that accepts the composite cable so now I have no display.

I cant take the device back as I bought it over a month ago, YOUR FIRMWARE UPDATE FEATURE BROKE IT!! and after spending over an hour waiting and talking to YOUR technical support department all they could suggest was that I bought a TV that could use the composite cable. "You have to be joking!" I said, but apparently not - cold as ice the agent on the phone told me I have to buy a new TV!!!

WHY IS THERE NOT A RESET BUTTON ON THE DEVICE? Surely it should be a standard offering on a device where a customer can update firmware from the device itself in case it does not work. Your technical support department certainly seemed to think there was one, 10 minutes of my call were spent with them telling me to push the reset button, and me telling them there wasn't one - they seemed to be a surprised as I was! Please ca you explain my next optiom because as far as I am concerned YOU broke it - not me!

Kevin.   
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: ECF on May 22, 2008, 11:50:20 AM
What firmware are you running? Are you able to setup the DSM-510 using composite to your TV and selecting HDMI manually and get a  picture using the HDMI?
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: kevinsmith121 on May 22, 2008, 11:06:54 PM
I don't know now what firmware I am running as the box updated from its on-board feature and did not say. Remember I have not seen the screen since it rebooted after the update.

The problem I have is that I have an HDMI Monitor with no composite input and a TV with a broken composite input - thats the part at which your technical support told me to buy a new TV. I need this fixed without the need to be able to see the screen.

Kevin.
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: ECF on May 23, 2008, 09:36:40 AM
Yeah it looks like you have a little bit of a problem, You will need to update the firmware manually with the 1.08 firmware for the rev A1 then you can use the HDMI with your television.
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: elkana on May 29, 2008, 03:59:52 PM
It seems I have a similar issue reported above when upgarading from 1.02 to any version from 1.03 to 1.07. Hovewer my device is H/W ver A2.

Will the firmware update 1.08 for A2 solve the issue?

elkana
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: ECF on May 29, 2008, 04:13:46 PM
It seems I have a similar issue reported above when upgarading from 1.02 to any version from 1.03 to 1.07. Hovewer my device is H/W ver A2.

Will the firmware update 1.08 for A2 solve the issue?

elkana

What is the problem? It worked with firmware 1.02 and now is not working?
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: elkana on May 29, 2008, 04:53:35 PM
Yes. I have Sony TV.
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: elkana on May 29, 2008, 05:02:25 PM
Actually I've now tried the f/w 1.08 for A2 and it does not seem to work. Had to revert back to 1.02.

I gess I'll have to wait for the next updates :(
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: jpchartier on June 20, 2008, 07:33:25 PM
Hi Elkana, how did you revert from 1.08 to 1.02?
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: joeedwards29 on June 24, 2008, 10:18:34 AM
same issue here... rev A1 with 1.08 update and no more HDMI detection.  Also about 1 month ago the dsm-510 stopped storing wrireless information and continues to revert into setup upon boot (even after I config the wireless, it restarts to set the config, but always comes back as if the setup didn't stick.)

among the many other issues, I was having good luck using WMP11 streaming to the device wirelessly but now, no matter what version I either can't get HDMI or I can't get connectivity.

Why do we have to stick with an older update (v1.02) when there are so many fixes/enhancements 1.03-1.08... I mean, with only 2 video outs you would think HDMI would be priority.
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: ECF on June 24, 2008, 02:56:50 PM
same issue here... rev A1 with 1.08 update and no more HDMI detection.  Also about 1 month ago the dsm-510 stopped storing wrireless information and continues to revert into setup upon boot (even after I config the wireless, it restarts to set the config, but always comes back as if the setup didn't stick.)

among the many other issues, I was having good luck using WMP11 streaming to the device wirelessly but now, no matter what version I either can't get HDMI or I can't get connectivity.

Why do we have to stick with an older update (v1.02) when there are so many fixes/enhancements 1.03-1.08... I mean, with only 2 video outs you would think HDMI would be priority.

1.08 for the rev A1 fixes the HDMI detection issue on the A1 that is why it was created just for the A1.As for your wireless it looks like you may just need to contact technical support for a replacement if it does not save settings it seems to be defective.
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: jumpdawg on October 01, 2008, 10:25:12 PM
After several months of dealing with the 510 and the firmware and connection issues, it is time to ditch the 510 and move on to a different unit from a different company.
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: adirpcb on December 05, 2008, 02:58:25 AM
looks like the 1.08 did not solve all HDMI problems .
I have the DSM-510 A1 with 1.08 and sony lcd 52" xbr4 and sharp 32"
No HDMI for both .

How do I roll back ?
Is a new version on the way ?
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: jroseboom on December 26, 2008, 11:24:10 AM
The 1.08 for A1 "partially" fixed the hdmi detection issue on mine.  However, once the TV is turned off, the dlink forgets it's connected via hdmi and you have to power down, then reboot for it to "re-detect" the hdmi connection.
Title: Re: DSM-510_A1 Firmware Roll Back 1.02 for HDMI detection issue.
Post by: jumpdawg on February 25, 2010, 05:05:22 PM
I finally had enough of this DSM-510 and took it outside and tossed it as far as possible down the street. What a peice of Cr@p the DSM-510 is.