D-Link Forums

The Graveyard - Products No Longer Supported => D-Link Storage => DNS-343 => Topic started by: tallison on March 21, 2010, 08:15:47 PM

Title: UPNP Server Cannot Play .AVI Files
Post by: tallison on March 21, 2010, 08:15:47 PM
I purchased a D-Link DNS-343 appliance.  I setup a RAID-5 configuration with 3x2TB drives.  All went well, and then, I enabled the uPNP Server.  After copying some .avi movies to the server, I tried to view them via my DirecTV DVR.  I see the Media Server and can browse the folders.  However, when I get to a movie (.AVI) it will not play.

The firmware is 1.03.  All of the documentation claims it can play .avi files.  Any ideas?

Title: Re: UPNP Server Cannot Play .AVI Files
Post by: tallison on March 22, 2010, 12:42:47 PM
I also tried to play .mp3 music files to no avail.  I can display .jpg's, but that's about it.  Is there something more that I have to do to stream videos and music?

I can stream these same files from my Windows Vista laptop and from my Linux / MediaTomb server.  I had to configure the MediaTomb to handle the encoding of the media.  I do not see how to do anything of the sort within DNS-343.

Can someone tell me what I'm doing wrong?

Title: Re: UPNP Server Cannot Play .AVI Files
Post by: ECF on March 22, 2010, 04:24:41 PM
Unfortunately I do not have a DirectTV DVR to test this with. There is nothing more to be done in the setup. The DirectTV DVR may not be compatible with our UPnP AV media server and if that is the case not much can be done at this point.

....Does anybody else out there have this working?
Title: Re: UPNP Server Cannot Play .AVI Files
Post by: tallison on March 23, 2010, 09:47:39 AM
I was able to play a .vob file to my DirecTV DVR from the DNS-343, but I cannot play .avi, mp4, .wvm,  and .mp3.  All of these files play without issue from MediaTomb and VUZE. 
Title: Re: UPNP Server Cannot Play .AVI Files
Post by: emporium on May 07, 2010, 03:30:56 PM
Did you ever get a fix for this issue ?

I recently got a DNS-343 in order to offload some of my movies to, and I have the same issue, even when using XBMC (for Mdia Centre) under Windows 7 x64.  DNS343 Server is seen, I can browse the UPnP server and see all the movies (some AVI [divx encoded], some WMV, and I even copied the Sample movie from Windows 7 to keep it simple) , but when I click on the movies, they fail to play.. However if I browse the box Via the Samba share, I can play them.

When I point XBMC to any of my other 2 NAS (Syn*l*gy DS508 and a QN@P TS409 Pro), it can play any of the media without an issue.  Even a copy of the files on the DNS343 which I transfered over in case they had gotten corrupted.

I would have assumed XBMC as the problem, however it can play the same files perfectly well off the other 2 NAS units.. :(

Any info would be much appreciated.
Thnx in advance.

BTW:  I am still using firmware 1.03

Title: Re: UPNP Server Cannot Play .AVI Files
Post by: grimes_mg on June 03, 2011, 06:27:57 PM
Did you ever get this fixed? Did v1.04 (beta or RC) fix this issue?
Title: Re: UPNP Server Cannot Play .AVI Files
Post by: emporium on June 03, 2011, 06:44:02 PM
I ditched all my Dlink units (my DSN-323 and my 2 DNS343 units) shortly afterwards.  I gave up with that.

I got a Synology DS508 shortly after ditching them, and loved it so much that for Xmas last year I also got myself their latest offering (Synology DS1511+).  I love BOTH units.. They are pricier, but well worth the price..

Synology is super quick to address any shortcomings found by thier users.. They offer 3 year warranty on all models..  They are blazingly FAST compared to my old Dlink units.. And rock solid for DLNA stuff, and rock solid for torrent downloads since it is based on the linux version of transmission.

I get a steady 45MB/s writing and 55MB/s reading from my older DS508..  And I get 100MB/s+ READ/WRITE on my DS1511+..  I could barely get 18MB/s on write and 27MB/s on read with any of my Dlink units.. 
I love both synology units, and I don't know why I put up with the Dlink stuff for so long..  And the firmware is light years ahead..

For more budget concious users, the synology DS411j is a great starting point.. Similarly priced as the DNS343, but a lot better and more robust software (actually uses the same firmware as it's bigger brothers, just has slightly slower cpu and less memory, so it is slightly slower).

Good luck with that...