D-Link Forums

The Graveyard - Products No Longer Supported => DIR-655 => Routers => Beta Code! => Topic started by: JFZuckor on March 16, 2010, 09:47:32 AM

Title: Unable to load firmware - DIR-655 A2
Post by: JFZuckor on March 16, 2010, 09:47:32 AM
I have a DIR-655 A2 with Firmware 1.31NA.  I constantly receive emails that there is a 1.32NA version and in fact there is also a 1.33NA version on the web site.  I have tried to upload both versions but have had no success.  I have tried to reboot as well as reset the unit, but to no avail.  The 1.32 version has as part of the file name "A4" which made me suspect that it is only for the hardware version A4, but I cannot find any reference that would support that.  The 1.33 version has no such specification.  However, regardless, neither one works.  It appears to load and gives me all of the appropriate messages, but when all is said and done, I am still at 1.31.  Any assistance would be greatly appreciated.  Thanks.
Title: Re: Unable to load firmware - DIR-655 A2
Post by: bigpapihydro on March 16, 2010, 07:29:19 PM
I had this problem as well. Here's how i solved it, first make sure you are connected wired to the first port. Just to be safe, have no other wires in ports 2-4. also make sure you back up your settings to a file on your pc or you'll lose all settings after update. hope this helps.
Title: Re: Unable to load firmware - DIR-655 A2
Post by: JFZuckor on March 17, 2010, 09:27:43 AM
 :D Unbelievable.  It worked!  However, there are some caveats.  Just removing all the other connections and plugging to port one in fact did NOT work.  However, based on some of the other suggestions, I also did the following:  I held the reset button for 30 seconds or more and then unplugged the unit for about a minute.  I also added one more step and that was to disconnect the connection to the modem.  I figured "the more the merrier".  (Obviously I had saved and restored the configuration also.)  The combination of all of those worked!  Obviously, your suggestion was the key.  Unfortunately, I have been in this business for many years ago and in the old, dark ages, using port one was pretty much a rule of thumb.  I thought, clearly incorrectly, that it was no longer the case.  Of course, the silly question is why this is not clearly documented.

Since I had already tried all of the other steps, you had the key.  I can't even begin to tell you how much frustration you have alleviated and also how grateful I am.  I appreciate your expertise as well as your taking time to help out.  Thanks again.
Title: Re: Unable to load firmware - DIR-655 A2
Post by: HoustonREF on March 21, 2010, 11:55:17 AM
 :D :D :D
Gentlemen - I've got to admit, I was searching for the solution, and I came upon your posts.  I first read bigph20, and laughed.  That had to be the dumbest thing I'd ever thought.  Then I read JFZ's.  So, first I tried Bigph20, and it did not work, per se.  Wanting to isolate this, I tried all the rest of JFZ's, but put the cable back to position 3.  It did not work.  Then, as JFZ said, I tried the cable position in 1, with the modem disconnected, the reset, and the disconnect for 1 minute.  Then I cried because it did work.  Holy S.  I've been at computer stuff since 1971, I'm DEFINITELY at an expert level, especially on hardware, and I never, ever would have thought of this.  D-Link firmware has always been relatively easy to re-flash, this was definitely a new experience. ???

D-Link, thanks for keeping older boxes up to date, and fixing the WAN problem.  But, please either correct the above necessities, or post the solution PROMINENTLY in the notes that accompany the upgrade.

And to both of you gentlemen, my hat is off...  Drink Starbucks?
Title: Re: Unable to load firmware - DIR-655 A2
Post by: t0n3 on May 09, 2010, 05:38:17 PM
Thanks for the info.  I've used many routers and this is the most convoluted process i've ever encountered for a firmware update.  the worst part about it all was that nothing indicated that the firmware update failed except that the version number didn't change on reboot.  i regret buying this router, i'll need a really good reason to consider buying another d-link or recommending them to anyone.
Title: Re: Unable to load firmware - DIR-655 A2
Post by: blainem on July 07, 2010, 03:37:36 PM
I was also unable to update my firmware from 1.21 to 1.34 on my DIR-655 A2.  The router would appear to update, but when it restarted the firmware version was still 1.21.

I followed this process and it updated like a champ.  Itís hard to say what part of this drove it to work, but in any case it worked.  I had backed up my settings, but I was not able to restore them so I had to reconfigure from scratch.
 
I also can no longer log into the router using Google Chrome.  The screen just flashes and does not log me in.  If I enter and invalid password I get a notification, but entering the correct password does nothing.  The login works fine from IE8.  I did not try restoring the settings from IE8 so perhaps that would have worked.

Now the real test will be to see it the Secure Spot redirect issue is resolved.  Since itís intermittent it will be a while before I can be sure.

Thanks and Cheers!
Title: Re: Unable to load firmware - DIR-655 A2
Post by: Local Kine on July 31, 2010, 08:23:18 PM
MAHALO!  This definitely worked. I was looking for answers to solve the "fakepath" bin issue. I also tried to do the update without the reset, etc. But it needs it. I did a 30-30-30 hard reset from http://dd-wrt.com/. Then it took the bin from my download folder. I reloaded my saved configuration and was all set. I never heard of having to use the first port to upgrade. I would like to ditch the OEM firmware and use dd-wrt, but it's not available for the 655. The shareport printer sharing is still a bit flaky for me.

Again, thank you for the info.
Aloha
BC
Title: Re: Unable to load firmware - DIR-655 A2
Post by: EddieZ on August 01, 2010, 01:45:48 AM
Great!
The 30/30/30 trick does not actually work on Ubicom OS. It does only on Linux based router Os...

But who cares, right?  ;)
Title: Re: Unable to load firmware - DIR-655 A2
Post by: alien on August 02, 2010, 07:36:42 AM
Ubicom is also linux, but no open source. ::)
Title: Re: Unable to load firmware - DIR-655 A2
Post by: EddieZ on August 02, 2010, 07:52:20 AM
Ubicom is also linux, but no open source. ::)

Should have been more desciptive... indeed, it is a propriety Linux set specifically designed for the Ubicom CPU's  ::)
Title: Re: Unable to load firmware - DIR-655 A2
Post by: elnando on September 29, 2010, 02:57:46 AM
Many many thanks for this post!
I encountered this problem running a DIR-655 HW: A2. I had already run a couple firmware upgrades and was using 1.32NA. All was great and fine except for those PCs at home running DHCP and hitting the SecureSpot bug :(
I had great hopes when I saw they had finally released a new firmware but seemed like my box just wouldn't care about the firmware upgrade and left me ditched with 1.32. Very annoying. Had to teach my wife how to disable SecureSpot herself (couldn't spend my days doing IT support for her!) and her IT level is close to zero!!!
One last thing to mention is that once you've pushed that reset button, done the firmware upgrade, after restoring your settings you do need to unplug and replug the device for the restored settings to kick in.
Title: Thanks from the future
Post by: joebob on October 16, 2011, 09:48:44 PM
Was encountering the same problem and just a simple upload wouldn't work.  Went over the suggestions by ZF and big, and it worked straight away.  Know that your advice is continuing to help folks.
Title: Re: Unable to load firmware - DIR-655 A2
Post by: JSpill on June 07, 2012, 05:05:17 AM
I am working on a DIR-655 A4.  Mistakenly loaded 1.35NA update firmware.  Now I cannot unload this update, nor can I do the 1.21 NA update reversal that was suggested.  Any file gives me "The uploaded firmware file may not be correct. You may have uploaded a file that is not intended for this device, or the uploaded file may be corrupted.

If the uploaded file is correct, it is possible that the device may be too busy to properly receive it right now. In this case, please try the upload again. It is also possible that you are logged in as a 'user' instead of an 'admin' - only administrators can upload new firmware.

The Gateway will not be reprogrammed."

I've tried every reset I could find here, but there is no way I can change the firmware.  I need to change to 1.35WW.  Any ideas of what to try next?
Title: Re: Unable to load firmware - DIR-655 A2
Post by: davevt31 on June 07, 2012, 09:45:45 AM
There is no "OFFICIAL" downgrade from the 1.35NA firmware.

There is an unofficial work around using a Russian firmware, just do a search for actual instructions