D-Link Forums

The Graveyard - Products No Longer Supported => Routers => WBR-2310 => Topic started by: SoulRed12 on February 26, 2010, 01:47:45 AM

Title: Need help with port triggering
Post by: SoulRed12 on February 26, 2010, 01:47:45 AM
Hello there.

I'm using a DLink WBR-2310 router that connects a cable modem to about 4 different computers in my home. Well my friend and I were testing the online mode of a video game he's developing and it wouldn't work. Thing is, it works with EVERYONE he's tried it with (~5 people) EXCEPT me. Even with someone who is using the same setup as I am: Windows Vista + a router, just perhaps not the same router.

So I read a guide written on the help community of the particular development software he's using for the game.  The guide had the following instructions:

Quote
D-Link Router

    * Browse to your D-Link Router and login.
    * Goto Advanced Tab
    * Select Applications
    * Put in the following values:
    * Select enabled
    * Trigger Port: 47624
    * Trigger Type: Both
    * Public Port: 2300-2400
    * Public Type: Both

HOWEVER. My router's application rules page only has "trigger" and "firewall", no "public port".  Look:

Link to image of my router's application rules page (http://img191.imageshack.us/img191/2548/picture1qjy.png)

That also shows the set up I've got right now, which didn't work (that is, we couldn't connect in my friend's game).  It didn't work; I have a feeling that there's a lot here that I don't understand.

Also here's my port forwarding settings:

Link to image that shows my router's port forwarding page (http://img94.imageshack.us/img94/2527/picture2xx.png)

Note that I have just disabled the port forwarding a few minutes ago. When we tried testing my friend's online game they were enabled.  (Actually I dunno if I even need any port forwarding after having done port triggering...)

Further info; I've got a static IP set up (the one you see in the image above), and the game is attempting to connect through hamachi (https://secure.logmein.com/products/hamachi2/).  I've also tried pf'ing to my hamachi ip; no luck.  Also, I've been to portforward.com, but they don't seem to explain the fields on the application rules page for my router.

So what's the deal here? I'm kind of a newbie at this online stuff, but I'm learning pretty fast. Anyone with more knowledge than me who can give me some suggestions?