D-Link Forums

The Graveyard - Products No Longer Supported => Routers => DGL-4500 => Topic started by: alex81388 on February 01, 2010, 09:48:34 PM

Title: Please Help Me With Basic VPN problems
Post by: alex81388 on February 01, 2010, 09:48:34 PM
Hi all.

This router is working great for me in every way except for the problem that I can't make a very simple VPN connection to my campus down the road. I can make the connection at many other locations, just not through this router.

I've tried to make my settings as lucrative as possible to allow the connection to happen:

Status:
Current Firmware Version : 1.21NA
Current Firmware Date : 2009/07/09

Firewall:
Enable SPI: UNCHECKED
UDP Endpoint Filtering:  Endpoint Independent
TCP Endpoint Filtering:  Endpoint Independent
Enable anti-spoof checking:  UNCHECKED
ALGS: ALL CHECKED

Virtual Server Settings (As specified from previous posts I've found...):
Name IP Address Protocol / Ports Schedule Inbound Filter Edit Delete
IP47  192.168.0.151  47 0 → 0  Always  Allow All     
PPTP  192.168.0.151  Both 1723 → 1723  Always  Allow All     
L2TP  192.168.0.151  Both 1701 → 1701  Always  Allow All     
L2TP2  192.168.0.151  Both 450 → 4500  Always  Allow All 


PLEASE give me any help you can. I really need to be able to do lab work from home when I can't get into campus buildings. Thank you!
Title: Re: Please Help Me With Basic VPN problems
Post by: HankRiker on February 02, 2010, 02:59:17 PM
This router is working great for me in every way except for the problem that I can't make a very simple VPN connection to my campus down the road. I can make the connection at many other locations, just not through this router.

Okay, the obvious question:

Have you tried removing the 4500 from your network, power-cycling your modem, and attempted a VPN to the school without it in the chain?

The router is in your home, not in the school, correct? Are you connecting wired or wirelessly?

I am running FW:1.02, but I am able to VPN out with what seems to be a more restrictive environment.

Use Unicasting: Off
Enable DNS Relay: Off
UDP: Address Restricted
TCP: Port & Address Restricted
Anti-spoof checking: On
All ALG Configs: On
Multicast Streams: Off

If I am hosting the VPN session, I do add the appropriate Virtual Server settings, but nothing onerous.

Let us know if a direct connection from your home works.
Title: Re: Please Help Me With Basic VPN problems
Post by: alex81388 on February 24, 2010, 08:10:53 PM
Thank you for the reply HankRiker.

At this point I have everything working correctly.

This topic can be closed if that is the custom, just wanted to log it for future searchers if they find they have a similar problem.

I called up my ISP and talked to them for a while. It ended up being mostly their issues. The above posted settings ARE WORKING with correct ports enabled by my ISP for necessary VPN access.
Title: Re: Please Help Me With Basic VPN problems
Post by: Wastedfreak on February 27, 2010, 05:44:06 PM
if the VPN is working fine with the modem try dmz the IP Addres of the computer that has the vpn.
Title: Re: Please Help Me With Basic VPN problems (RESOLVED)
Post by: FurryNutz on February 27, 2010, 08:14:05 PM
Good to hear you found some resolution. Hope it works well for you.