• May 27, 2022, 08:53:56 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Can't login to admin page. Seems common.  (Read 13050 times)


  • Level 1 Member
  • *
  • Posts: 1
Can't login to admin page. Seems common.
« on: January 25, 2011, 01:59:13 PM »

I see quite a few threads about login problems so this might be known though I don't see a posted solution.  After pulling my hair out for 3 weeks trying to get this repeater to work (due to the abysmal documentation no doubt), I finally happened across this link in another post: http://forums.dlink.com/index.php?topic=14103.0

This post offers enough details for me to deduce my problem.  All I needed to do was disable the auto channel scan on my Gaming Router (the real gateway).  After choosing a channel manually, voila!  It worked immediately.

The problem I am still having is that the login page forever returns " ERROR: The password is error." I am absolutely certain I am typing the password correctly.  This is the second time this has happened.  I have already done 1 factory reset because the router locks the admin screen after I finish running the setup wizard.  At the end of the setup the router wants to reboot.  After rebooting it never allows another login.  After this happened the first time, I did a factory reset, ran through the wizard again, then typed my usual router passwork very slowly and carefully.  After a reboot, I can't log in again.

What's going on here?


  • Level 1 Member
  • *
  • Posts: 17
Re: Can't login to admin page. Seems common.
« Reply #1 on: April 24, 2011, 09:48:03 AM »

Firstly this unit is notorious for this behavior. you are not mad crazy or dumb, this hardware is crap!

Secondly, If you are changing the IP address, then it's possible you need to type in the new IP address, although that does not sound right as you should not even get the login page. I assume you have tried powering it on and off again, and disconnecting reconnecting your network connection on your computer to refresh everything?

When this happens to me al I have to to is re-set the DAP-1360 and reset my network connection and it usually works.

Try a different browser, if you are using IE, try Firefox etc, I sometimes find that certain devices are allergic to certain browsers.

good luck, you'll need it :)


  • Level 1 Member
  • *
  • Posts: 2
Re: Can't login to admin page. Seems common.
« Reply #2 on: June 15, 2011, 09:39:17 AM »

I just bought the latest and the greatest router, Linksys e4200.  Very fast for sure, but range is really poor inspite of its marketing about super antennas or something.  Range may be good when in wide open space, but mine is in one bedroom, and door is usually closed.  So my PC outside only had poor or fair connection (2 - 3 bars out of 5) and kept dropping connection off.

So off I went to buy a repeater, and ended up with this Dlink DAP-1360.  Well, instructions were non-existent to set up as a reciever,, so called them up to give me proper instructions, and they did have one, sent by email.  Why the heck they did not include in their thick user manual is beyond me.

Anyway, can't log in to admin page too !  Called them up and they said they will call back and never did.  I lost about 8 hours trying to figure this out.  I don't have the luxury of time, so I went to look for another receiver.

Voila !  Found a simple one, 5 minute set up, and I have maximum 5 bars, shown as Excellent.  Rebooted PC and now it is constant at 5 bars.  Perfect, saves time, excellent easy instructions.  This is the one :

Aztech WL556E

Anybody wants to buy my 1 day old DLink DAP-1360, please let me know, 1/2 the price !