• December 12, 2017, 03:41:36 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Child Boards
No New Posts

Beta Drivers!

Beta Drivers for the DWA-542 for Vista and XP

Moderator: Lycan

5 Posts
2 Topics
Last post by daskino
in Re: Success stories with...
on September 23, 2009, 11:38:49 AM
Pages: [1] 2
  Subject Started by Replies Views Last post
New D-Link Web Sites - USA FurryNutz 1 48726 Last post March 07, 2013, 10:31:20 AM
by FurryNutz
DWA-542 End Of Life FurryNutz 0 9599 Last post January 30, 2013, 12:58:01 PM
by FurryNutz
United States Support and FAQ's Here! arod 0 5489 Last post January 19, 2009, 01:18:12 PM
by arod
300Mbps Connection Requirements! Please Read! Lycan 0 4124 Last post November 07, 2007, 09:38:13 AM
by Lycan
Welcome! Lycan 0 3530 Last post August 30, 2007, 04:52:02 PM
by Lycan
DWA-548/DWA-525 Driver problems with Dell Optilplex 9020 Windows 7 kronos212 13 5509 Last post March 16, 2015, 07:31:02 AM
by FurryNutz
DWA-547 problems Xaverous 0 51916 Last post August 04, 2011, 12:41:50 AM
by Xaverous
Problem installing DWA-542 on Windows Home Server (32 bits) Dave 0 2704 Last post July 25, 2011, 11:50:49 AM
by Dave
DWA 525 slow speed. rockemsockem55 7 26913 Last post April 03, 2011, 04:36:17 PM
by codejoy
DWA-542 Won't Connect to 5.0 ghz band. npp9883 2 11488 Last post August 02, 2010, 08:41:50 AM
by zippoking
DWA-510 Windows 7 Ultimate 64-bit Lohita 1 13292 Last post June 23, 2010, 03:35:55 PM
by Andre_NIT
My wlan card not work on Windows 7 ultimate SaaM 0 14782 Last post March 11, 2010, 09:28:27 AM
by SaaM
Will the DIR-615 router work with the DWA-542 Adapter? russ1150 0 7749 Last post November 23, 2009, 09:46:25 AM
by russ1150
Random Disconnects Flinten 0 8236 Last post October 25, 2009, 01:47:56 AM
by Flinten
Can't connect to "N" when router is "Mixed" sting 0 3347 Last post October 14, 2009, 03:29:49 PM
by sting
Fast User Switch Disable Workaround DJMark 0 3385 Last post September 20, 2009, 05:34:24 PM
by DJMark
Fast User Switching and WlanGINA csalas 0 3871 Last post August 27, 2009, 11:21:17 AM
by csalas
Dropping Connection peste19 2 5885 Last post August 04, 2009, 07:33:01 PM
by 745i
Help, please. dpelement 8 6528 Last post May 07, 2009, 08:58:22 AM
by arod
XP Hangs Enraged 3 5635 Last post February 16, 2009, 08:33:23 PM
by Enraged
Pages: [1] 2

 

  • Normal Topic
  • Hot Topic (More than 15 replies)
  • Very Hot Topic (More than 25 replies)
  • Locked Topic
  • Sticky Topic
  • Poll