• December 06, 2021, 04:37:06 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: D-ViewCam app cannot connect over internet.  (Read 10166 times)


  • Level 1 Member
  • *
  • Posts: 2
D-ViewCam app cannot connect over internet.
« on: February 01, 2013, 10:54:09 AM »


You know I just bought over $2,000 worth of these things and I can't get them to work either!  I have tried forwarding all of the ports I can think of.  And calling D-Link tech support?! LMAO!!!! That lady didn't even comprehend that I was using the D-ViewCam software.  She was clueless as to her own product.  Very painful conversation but I tried to power through.  I kept asking her to forward me to someone with more technical expertise and knowledge of IP's and ports.  But finally she just hung up on me.  I tried to call back, hung up on me again.  So if someone here can please tell me what I'm doing wrong that would be awesome!  And despite all of the "UserGuides" I look through, none address this.

So here is what I have going on.  So far I'm just working with one DCS-6113.  I have it run through a Netgear POE router and that is connected to the new U-Verse Motorola NVG510.  I can access the camera on a local machine when the settings for both it and the camera are TCP.  I tried HTTP and nothing.

So on the D-ViewCam app on my iPhone I can see the server and the camera name but it just keeps spinning and I never see the camera video.  And this only works when I am on the wifi of that same network and use the IP address of the server computer.

So why?

1.  Do I not see video when even on my local network?

2.  Why can't I see it at all from the outside world?

Note.  To the world my IP address is  There is no "Virtual Server" on the NVG510 except for an optional pull down one that gives you only three ports and yes I tried changing the server to use those ports as well.  I additionally forwarded all of those ports.  There is a passthrough option on there that I can assign any computer on my network but that didn't work either.

If someone from D-Link is reading this and is a "real Tech" I can be reached at 501-230-3057 .  Thanks!


  • Level 1 Member
  • *
  • Posts: 7
Re: D-ViewCam app cannot connect over internet.
« Reply #1 on: March 01, 2015, 09:55:28 AM »

If you are trying to use the IOS mobile app outside of your home network (via 3G, LTE, ...), you must do the following:

1) Do you have ports 5150 and 5160 forwarded on your router? Are you using your Cable Modem IP address (or a DDNS) instead of the local IP address assigned by your router to the PC hosting your Dviewcam server software? Dlink provides a free DDNS service. I would recommend you use a DDNS (your ISP may change your Cable Modem IP address, the DDNS will deal with this).

2) Do you have the Remote LiveViewer and Playback servers running in your Dviewcam server software?

Even if you do get the IOS App working, you will find that it is not very good for viewing recordings saved on your Dviewcam server. You are forced to select a date/time to search for recordings and an interval from that time to search across. For some unexplained reason, the max interval you can search is 10 minutes!! So for example if you say to search from 3PM with an interval of 10 mins, it only looks for recordings made from 3:00 to 3:10, and if there are none you get a "no recordings found" dialog. How poor is that?? So other than watching a live stream with sound (you must enable the souond in dview cam settings), the IOS app is nearly useless.

I've used the IOS apps from Vivotek and Samsung, and they both allow you to search from one date/time to another and then it plays all recordings save on the server for that time interval. Not sure where Dlink came up with the lame guess your best 10 minute search interval, but that needs to be changed.