• June 24, 2022, 04:12:31 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Airprint from iPhone to HP D110 printer via Bonjour and D-Link DIR-655 problem  (Read 12468 times)

charlie95722

  • Level 1 Member
  • *
  • Posts: 3

I have searched the Dlink, Apple, and HP forums for answers.  Many people have had the problem.  Some have found solutions.  I have tried what I think are all the solutions presented.  However, Airprint works for about 2 minutes on iPhone after restarting the printer, but then goes away.

I tried setting up an Ad Hoc network on the printer with the iphone and it Airprints fine.  PCs, and the Mac print fine wirelessly.  But using Bonjour in Safari (on Mac or PC) shows the printer however clicking on it makes it disappear.  Using the printerís ip address opens the printerís setup menu on Mac and PC.

Bonjour appears to work for about 2 minutes, then goes away.  Noted that in one Help page on HP site, it said that to connect the printer to a Mac you had to do 2 operations within 2 minutes.  Maybe the printer outputs some Bonjour info for that long, but doesnít respond to requests from other Bonjour devices?  Or are they being filtered by the router?

So wireless is working.  Bonjour is working iphone directly to printer.  Problem points to router setup.  All hardware has latest SW/FW.

Most of the forum postings are from 3 months to 1 year old Ė no new data.  Anybody have any other ideas to try?

HP-D110a, Model CN731A, FW: TUL1FN1044AR
DIR-655 B1, Updated to Ver 2.07NA.
iPhone 3GS, SW: 5.1
Set iphone and printer to reserved ip addresses (on router) and DHCP on devices. [did not change the fixed ip addresses for about 15 other wired devices on the router]
Turned on Multicast for both 4 and 6.  (tried on/off/one or the other)
All on same network
Bluetooth off
Channel width 20mhz
QoS off
Advanced DNS off
DNS relay on
Set Endpoint Independent for TCP and UDP
Tried port forwarding UDP 5353 to printer ip
Short GI off
WLAN Partition was off
California
SBCGlobal.net DSL
Speedstream 1600 DSL modem
11bgn
Channel 6
Auto WPA/2
Both Cipher types

Thanks for your help.
Logged

FurryNutz

  • Poweruser
  • ††▲
    ▲†▲
  • *****
  • Posts: 49916
  • D-Link Global Forum Moderator
    • Router Troubleshooting

You need to downgrade to v2.03NA or upgrade to v2.10 or .11 as 2.07 it breaks Shareport.

Some things to try:
Turn off ALL QoS or Disable Traffic Shaping (DIR only) GameFuel (DGL only and if ON.) options. Advanced/QoS or Gamefuel.
Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual.
Turn on DNS Relay under Setup/Networking.
Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking
Ensure devices are set to auto obtain an IP address.]Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking
Ensure devices are set to auto obtain an IP address
.
Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall.
Enable uPnP and Multi-cast Streaming under Advanced/Networking.

Wiki:
http://support.apple.com/kb/ht4356
http://tweaks.com/windows/46495/enable-ios-airprint-support-on-windows/
http://www.netputing.com/handyprint/
« Last Edit: December 15, 2014, 01:44:48 PM by FurryNutz »
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.