• May 16, 2022, 08:41:35 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DWA-160 over DWA-643 Expresscard  (Read 5793 times)

carnagerover

  • Guest
DWA-160 over DWA-643 Expresscard
« on: August 18, 2008, 02:13:00 PM »

Hi all,

I see that Dlink are not currently releasing a PCMCIA card of any type, I have just purchased a DIR-855 that is coming tomorrow.

My new Dell laptop has a expresscard slot instead of a older PCMCIA slot so i need to buy some new hardware to use with it.

I would like someone to answer this question for me, is it a myth that the USB dongle type wireless devices have less coverage and range over a PCMCIA style adapter ?

Should i wait to see if dlink release a Dual band Expresscard or is the USB going to give the same results ?

Are there any downsides to going the USB route ?

Any help would be ideal as i really could do with ordering something a.s.a.p

Thanks

Stu
Logged

Lycan

  • Administrator
  • Level 15 Member
  • *
  • Posts: 5335
Re: DWA-160 over DWA-643 Expresscard
« Reply #1 on: August 18, 2008, 04:08:52 PM »

We only make one expresscard adapter. The DWA-643, it is not Dual Band.
USB has been known to have power output in the past, but thats been cleared up for the most part now.
Logged

carnagerover

  • Guest
Re: DWA-160 over DWA-643 Expresscard
« Reply #2 on: August 18, 2008, 04:33:01 PM »

Thanks for the reply,

I know the DWA-643 is the only expresscard available at the moment, and not Dual Band. That is why i am un-sure which one to go for. I know the DWA-160 is Dual band but i wonder if the 2.4Ghz radio on the DWA-643 is more powerful than that of the DWA-160.

As you say the power problem seems to have been cleared up now so that sounds promising but, there just seems to be to many people trying to warn me off of USB Wifi saying i should wait for some card type solution.
Logged

FromAtoN

  • Level 2 Member
  • **
  • Posts: 58
Re: DWA-160 over DWA-643 Expresscard
« Reply #3 on: August 18, 2008, 06:31:42 PM »

I take it you're running Vista and the DWA-160 Rev B "should" correct Vista problems.  Been running XP and have different problems on A & B revs of the card so I have no experience with a Vista client and this adapter.  Was looking at the only other Cardbus alternative.

Never got any feedback from D-Link folks here on any my DWA-160 posts so I'm having to look elsewhere.  Believe the problems lies with both the DGL-4500 and the adapters.  USB = failure to launch...they should have stuck with Cardbus and Expresscard.

I'd probably stay away from the DWA-643 since it only has a 2GHz radio.  You really want something on 5GHz to use 40MHz channel width and avoid neighboring devices.
« Last Edit: August 19, 2008, 08:44:52 AM by Lycan »
Logged