D-Link Forums

The Graveyard - Products No Longer Supported => IP Cameras => DCS-5020L => Topic started by: Watcher on November 21, 2020, 11:23:29 AM

Title: Version 1.16 and 1.15 reject FireFox, Chrome, Edge and YandexBrowser
Post by: Watcher on November 21, 2020, 11:23:29 AM
What started as an update from MyDLink Lite to MyDlink app, turned into a 5-hout upgrade nightmare.
First the app migrated my configured cameras. So far so good. Next it suggested upgrading the firmware on DCS-960L  (thisr is a different story) and DCS-5050L. The only options were to upgrade or do it later. How bad can it be? After all, the developers must have improved their skills over the past years and started introducing fewer bugs? Wrong.

After the upgrade, I was met with the large-font red text:

The browser you are using may have difficulty receiving images and video. If you experience any issues viewing this page, we suggest using Internet Explorer.

I'm running the latest FireFox! Funnily, if I start the same web interface in the now-defunct desktop Safari (I still keep it around for video setup of DCS-2670L), everything is shown just fine.

In fact, setup for DCS-2332L shows video frame and the setting for motion detection in FireFox without any need for Java or discontinued Adobe Flash plugins (required by the latest and greatest DCS960L). Why can't DLink have uniform firmware?!

Anyway, I'm going to start downgrading the firmware through Safari until the interface work again in FireFox. Maybe all the way back to 1.14.09

PS: Tested it in Chrome, Edge and Yandex Browser. The same red error is shown without an option to see the UI itself. IE 11 worked fine, while Safari cannot upload the firmware file.

PS2: I had to downgrade back to the initial 1.14 before the UI came back in FireFox
Title: Re: Version 1.16 and 1.15 reject FireFox, Chrome, Edge and YandexBrowser
Post by: FurryNutz on November 21, 2020, 12:30:39 PM
Try using IE11x32 or FF ESR v52.9.0 x32
These cameras are not supported and EOL for the most part and the FW won't be updated. So keep on had these two browser that seem to work for Windows.