D-Link Forums

The Graveyard - Products No Longer Supported => D-Link Storage => DNS-323 => Topic started by: ARYLIOA on September 03, 2016, 06:23:41 AM

Title: Need help connecting Clonezilla to DNS-323
Post by: ARYLIOA on September 03, 2016, 06:23:41 AM
I have posted similarly on the Clonezilla board, but the odds of finding a DNS-323 user there are slim, as probably are the odds of finding a Clonezilla user here.  I use both Acronis and Macrium Reflex successfully from Windows.  I am setting up a computer to use Linux, which does not support backup from a running OS.  But neither of those products does file compression if run from a boot CD and just dump my entire drive image to the DNS 323, taking lots of space and hours to do so.  Clonezilla will do compression, and is pretty fast.  I have backed up the system using it to a USB in about 2/3 the size of the just the used area of the drive, and in about 8 minutes.  I really want the compressed images on my DNS-323.   Here is the description of my system and of the problem I am having.

My setup is ZyXEL C1100Z DSL Modem/Router ( The balance of the equipment is set up with Static IP addresses.
Linksys BEFSR41 Router ( set up as a switch
D-Link DNS-323 (, Subnet Mask, Gateway, DNS1, DNS2 The password to the device, if it is significant at all, is the default of admin with no password. (If it is significant, the device is also defined i the setup as MSHome/D-link-2.) This has worked on my local network for some time.

I am trying to get to the directory on the DNS-323 of Volume_1/Linux Images - 15th, entered exactly like that.  Using Start Clonezilla, Device-Image, Samba_Server, DCHP I have tried many combinations but have yet to be successful in mounting the device. It appears to be trying to mount admin@ Images - 15th exactly as I hoped, but fails.

If someone can point me to either the correct sequence of entries in Clonezilla from the point of selecting the Samba DCHP mode, or tell me where there might be a problem with the setup of my LAN or the DNS-323 described above, I would be grateful.  Basically I would prefer to use the Samba route for the backup, but at this point I will gladly take any route that works.  Any help at all will be thankfully welcome.

I have many years of computer experience, but for now would prefer to use the newbie route in Clonezilla just to keep me out of trouble. If using command mode would help with debugging the problem, I'm game.

Title: Re: Need help connecting Clonezilla to DNS-323
Post by: ivan on September 05, 2016, 11:22:17 AM
A question.  Have you activated the CIFS/SMB (samba) server on the DNS-323?

If you are trying to save to a Samba server it needs to be active.
Title: Re: Need help connecting Clonezilla to DNS-323
Post by: ARYLIOA on September 06, 2016, 11:11:21 AM
Have you activated the CIFS/SMB (samba) server on the DNS-323?

I believe I have.  But no experience so it just "looks that way" to me.

SMB List has r/w checked, Share and Path both indicate Volume_1 , User/Group: All and Oplocks: No.

It is only a presumption on my part, but I expected that if Volume_1 is available that includes all its content.

Does that look OK?

My guess is that perhaps the pathway to the unit is not correct.  But again, no experience outside of Windows.
Title: Re: Need help connecting Clonezilla to DNS-323
Post by: ivan on September 06, 2016, 02:07:54 PM
OK, one more thing. 

Have you created an actual user (with password if necessary) and associated that user with Volume_1?  Without a user assigned Samba server does not know where to send anything.

Something else that might help https://mylinuxramblings.wordpress.com/2010/08/19/using-clonezilla-with-freenas-or-network-share-to-backup-a-hard-disk/ (https://mylinuxramblings.wordpress.com/2010/08/19/using-clonezilla-with-freenas-or-network-share-to-backup-a-hard-disk/)  For FreeNas read any NAS box.

Unfortunately I don't have much experience with CloneZilla because it is not happy with the OS/2 HPFS file system and tend to mess things up.  We use DFSee for almost everything to do with hard disks (it is free to use for a period but if you continue to use it or use it commercially you are expected to pay for it).  It does require that you understand what you are doing because you can do nasty things to your disks if you are not careful.
Title: Re: Need help connecting Clonezilla to DNS-323
Post by: ARYLIOA on September 07, 2016, 07:58:49 AM
Thanks, I'll check those out.  Right now the main fire is rolling 3 computers back to W7 from W10.  In a fit of idiocy, I deleted the images I had for all of them when W10 looked like it might stabilize about 6 months ago.  Each takes about 6 hours to reload all my applications and complete the configurations.  Fortunately, I have 19 pages of notes on what I do.

I started with W10 on the release date, and after 13 months am so thoroughly disgusted it is going in storage until such time as it works for me.  There were many annoyances.  File Explorer itself gave me all sorts of trouble with "My Documents", hosted on one of my 2 DNS-323s.  Not only would it list "My Documents" 5 or 6 times in the Navigation Pane, but none of them would expand.  I would have to go directly to the directory on the DNS-323 to expand the tree.

Something in W10 would randomly create strange, empty directories, some with only a single symbol for the name, some with some sort of name using an Asian language of some sort.  The crowning blow was when I discovered two weeks ago that various directories were missing entirely.  Fortunately, I had backups as far back as October on USB media so I am hoping it did not delete anything I need between July and October.  The real problem is not knowing what it deleted until you try to use it.  No thanks to that, Microsoft!

After I recover from my W10-induced breakdown, I will dig into your suggestions and will report back.  While I am not new to the computer game (1964!), obviously one or two things :) have not made it to my "Done That" list.  But I am never too proud to ask for help.  Thanks again.