• December 15, 2017, 01:48:34 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2 3

Author Topic: Run as Windows Service  (Read 1153 times)

arthurlin43

  • Level 1 Member
  • *
  • Posts: 10
Run as Windows Service
« on: October 10, 2017, 06:47:28 PM »

There is a check box in the Systems Setting - Startup page.  However it is grayed out.

Is there a way to enable this feature?

From time to time my Windows 10 host may reboot - and DCS-100 won't run until I login.  It would be really nice to be able to start main console automatically.

ps,
I'm running version 4.2.1.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43913
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Run as Windows Service
« Reply #1 on: October 11, 2017, 10:38:15 AM »

What version of DVC do you have installed?
Logged
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

arthurlin43

  • Level 1 Member
  • *
  • Posts: 10
Re: Run as Windows Service
« Reply #2 on: October 11, 2017, 04:25:13 PM »

I'm using DVC version 4.2.1.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43913
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Run as Windows Service
« Reply #3 on: October 29, 2017, 12:30:56 PM »

I don't believe there is a service feature supported with DVC...i know it starts automatically after log in which can be disabled...
Logged
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

Red90

  • Level 2 Member
  • **
  • Posts: 36
Re: Run as Windows Service
« Reply #4 on: October 31, 2017, 08:28:37 AM »

Sure there is a "run as service" feature....  It will start it up before you log in.  Works fine for me.  You need to have the auto login enabled.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43913
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Run as Windows Service
« Reply #5 on: October 31, 2017, 09:33:57 AM »

Are you referring to a Service feature of DVC that can be enabled or just enable auto log in for the PCs users account to let the program auto start?
Logged
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

Red90

  • Level 2 Member
  • **
  • Posts: 36
Re: Run as Windows Service
« Reply #6 on: October 31, 2017, 11:50:45 AM »

There is a run as service feature.  With this turned on, along with the auto login (within DVC, not Windows), the main console and recording will start when the computer is turned on and nobody is logged into Windows.  You do not need to setup Windows to auto logon to an account for this to work.  You do not need to disable UAC.
Logged

Red90

  • Level 2 Member
  • **
  • Posts: 36
Re: Run as Windows Service
« Reply #7 on: October 31, 2017, 12:13:24 PM »

It must be a new feature with 4.2.1  I can't find a manual for the program for the new version that shows the feature.  Nothing like no documentation to make life simple.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43913
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Run as Windows Service
« Reply #8 on: October 31, 2017, 12:50:45 PM »

Awesome. Thank for you for confirming this.
Logged
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

Red90

  • Level 2 Member
  • **
  • Posts: 36
Re: Run as Windows Service
« Reply #9 on: October 31, 2017, 07:27:13 PM »

Here is the main setup screen that shows the new options.  No idea why it did not make it to the new manual.

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43913
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Run as Windows Service
« Reply #10 on: October 31, 2017, 07:31:29 PM »

Thanks for posting. I can confirm this as well.

Possible it got over looked...
Logged
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

GreenBay42

  • Administrator
  • Level 5 Member
  • *
  • Posts: 527
Re: Run as Windows Service
« Reply #11 on: November 01, 2017, 07:02:38 AM »

The latest manual (4.20) was for version 4.1.1. I will send a request for an update.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43913
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Run as Windows Service
« Reply #12 on: November 01, 2017, 09:41:12 AM »

Thank you.  ;)
Logged
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

arthurlin43

  • Level 1 Member
  • *
  • Posts: 10
Re: Run as Windows Service
« Reply #13 on: November 06, 2017, 09:47:04 AM »

This is what happened in my settings.  Like I said in the initial post - the "Run as Windows Service" being grayed out.
https://ppt.cc/fS9Zhx


Any idea why?
« Last Edit: November 06, 2017, 09:48:59 AM by arthurlin43 »
Logged

GreenBay42

  • Administrator
  • Level 5 Member
  • *
  • Posts: 527
Re: Run as Windows Service
« Reply #14 on: November 06, 2017, 09:54:32 AM »

Did you run D-ViewCam as administrator? Let me install it and see if I can duplicate the issue.
Logged
Pages: [1] 2 3