• February 04, 2023, 07:29:31 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Acquiring Network Address  (Read 12263 times)


  • Level 1 Member
  • *
  • Posts: 1
Acquiring Network Address
« on: January 29, 2011, 09:08:59 AM »

I had to replaced the hard drive, reinstalled Windows XP sp3.

D-link software showing 100% signal strength but when I try to enable connection it shows “Acquiring Network Address” continuously on the network icon and won't connect.

Any help would be appreciated.


  • Level 1 Member
  • *
  • Posts: 1
Re: Acquiring Network Address
« Reply #1 on: January 30, 2011, 11:24:43 PM »

I am having the EXACT same problem! :(

I've been all over google, irc channels and can not find a straight answer

I had to reinstall windows xp this weekend.
Prior to this my laptop was running ubuntu with this card and before that, I had XP installed with all the updates through SP2

Now on reinstalling XP Professional, adding hours of security updates and installing SP3 -
My d-link dwa-652 card detects all the wireless networks BUT can NOT connect to any of them. It does not matter if it is secured or not.

I tried manually uninstalling the card/drivers and adding the ones from dlink website - I tried version 1.50 and 1.60 for xp - which INF file are we supposed to do?

Can someone actually break down the steps properly?

1. disable card?
2. uninstall driver
3. download version 1.50 from dlink website, extract
4. reboot
5. put card in,
6. found new hardware comes up
7. choose location manually
8. locate driver
then what?
I tried something like this and I still get "Acquiring network address"

would appreciate any help
Ethernet works (that's how I installed the updates for windows)
What a pain in the ***.

Thanks for any help people!

also - there are two INF files - which one? driver\2kxp\netathw.inf or netathwx.inf ????
« Last Edit: January 30, 2011, 11:28:24 PM by antigen »