D-Link Forums

The Graveyard - Products No Longer Supported => Routers => DIR-857 => Topic started by: dorsia on June 22, 2012, 04:11:42 PM

Title: DIR-857 SPI Causing Problems (Connected to ATT 2Wire 3801HGV Router/Modem)
Post by: dorsia on June 22, 2012, 04:11:42 PM
I have a DLink DIR-857 router connected behind my ATT 2Wire 3801HGV Gateway (router/modem).

I set the ATT 3801HGV to DMZplus mode for the DIR-857 router (there is no bridge mode on the ATT 2Wire 3801HGV). After that I was having a problem downloading Gawker sites on my Android phone. Sites like gizmodo.com, jalopnik.com & gawker.com. These sites have, I believe, a large number of simultaneous AJAX connections to download images and content. I found that when I disabled SPI under the DIR-857's firewall settings, it resolved the issue. However, I would like to keep SPI enabled.

Since my ATT 2Wire 3801HGV router has SPI which does not cause any issues, I have disabled DMZplus mode and now have to set up duplicate port forwarding settings on both the ATT and DLink routers, which is not ideal. I have the latest firmware installed on the DIR-857 (1.01).

Has anyone reported problems with the SPI? Is this something that can be fixed via a firmware update or another way?

Also the wireless range on the DIR-857 is weaker than on the 2Wire 3801HGV, could there be any settings or any tips on increasing the range?

My laptop is directly connected to the DIR-857 via cat6 cable but the connection is slower than if directly connected to the 2Wire. Any thoughts on why this would be?

Thanks for any help.
Title: Re: DIR-857 SPI Causing Problems (Connected to ATT 2Wire 3801HGV Router/Modem)
Post by: FurryNutz on June 22, 2012, 05:34:34 PM
The problem is not SPI speciiallly as more of the problem with external routers being used with ATT 2wire and Uverse modems with built in routers. This problem is inherent to these modems and the use of any external router.

I most cases bridging these modems will cure this issue however in most cases with 2wire and Uverse modems, this can't be done. Even using DMZ or this DMZ Plus isn't sufficient enough to allow all traffic to be passed to the external router.

Double NAT (http://www.practicallynetworked.com/networking/fixing_double_nat.htm)

There and been some success in using DMZs with external routers and some that this DMZ plus doesn't seem to work well.

You are dealing with 2 routers and 2 firewalls in effect. In some of these cases where the ISP modem will not allow all traffic to be passed to the external router seamlessly and the ISP modem can not be bridged, I would hightly recommend using external AP devices, i.e. DAP 1360, 1522 or 1525 models instead of using an external router. These will provide wireless and wired connectivity and let the ISP modem/router handle the IP addressing and management for connected devices.

There are some places lilke DSL reports and I believe an ATT forum that carries some information on bridging and configuring DMZ plus to work better. I would review this information and see weather it's feasible or not to use an external router with these modems.

Title: Re: DIR-857 SPI Causing Problems (Connected to ATT 2Wire 3801HGV Router/Modem)
Post by: kargo27 on June 23, 2012, 10:07:19 AM
Check this out:

This is from "SomeJoe7777" on the AT&T U-Verse forum:

There is no true bridge mode on the 2Wire routers.  However, you can still configure it such that almost all functions of your own router will work properly.
 
1. Set your router's WAN interface to get an IP address via DHCP.  This is required at first so that the 2Wire recognizes your router.
2. Plug your router's WAN interface to one of the 2Wire's LAN interfaces.
3. Restart your router, let it get an IP address via DHCP.
4. Log into the 2Wire router's interface.  Go to Settings -> Firewall -> Applications, Pinholes, and DMZ
5. Select your router under section (1).
6. Click the DMZPlus button under section (2).
7. Click the Save button.
8. Restart your router, when it gets an address via DHCP again, it will be the public outside IP address.  At this point, you can leave your router in DHCP mode (make sure the firewall on your router allows the DHCP renewal packets, which will occur every 10 minutes), or you can change your router's IP address assignment on the WAN interface to static, and use the same settings it received via DHCP.
9. On the 2Wire router, go to Settings -> Firewall -> Advanced Configuration
10. Uncheck the following: Stealth Mode, Block Ping, Strict UDP Session Control.
11. Check everything under Outbound Protocol Control except NetBIOS.
12. Uncheck NetBIOS under Inbound Protocol Control.
13. Uncheck all the Attack Detection checkboxes (7 of them).
14. Click Save.
 
Your router should now be able to route as if the 2Wire was a straight bridge, for the most part.
 
Inbound port 22 might be blocked, and inbound ports 8000-8015 might also be blocked, and there's nothing that can be done about it.
 
This is how I have my 2Wire configured, and I have a Cisco 2811 behind it doing IPSec, IPv6 tunnels, etc.

---------------------------------------------------------------------------------
Title: Re: DIR-857 SPI Causing Problems (Connected to ATT 2Wire 3801HGV Router/Modem)
Post by: FurryNutz on June 23, 2012, 12:19:13 PM
I was hoping you'd show up Kargo.  ::)

Thanks.
Title: Re: DIR-857 SPI Causing Problems (Connected to ATT 2Wire 3801HGV Router/Modem)
Post by: kargo27 on June 23, 2012, 08:30:04 PM
I was hoping you'd show up Kargo.  ::)

Thanks.

 ;D  No Problem, Furry.

Dorsia may have done this already, but just in case....
Title: Re: DIR-857 SPI Causing Problems (Connected to ATT 2Wire 3801HGV Router/Modem)
Post by: FurryNutz on June 23, 2012, 09:01:50 PM
I figured you would catch this as you seem to have the background and experience with DMZ plus.  :o
Title: Re: DIR-857 SPI Causing Problems (Connected to ATT 2Wire 3801HGV Router/Modem)
Post by: kargo27 on June 24, 2012, 07:27:21 AM
I figured you would catch this as you seem to have the background and experience with DMZ plus.  :o

 :D
Title: Re: DIR-857 SPI Causing Problems (Connected to ATT 2Wire 3801HGV Router/Modem)
Post by: FurryNutz on June 27, 2012, 07:04:10 AM
Any status on this?
Title: Re: DIR-857 SPI Causing Problems (Connected to ATT 2Wire 3801HGV Router/Modem)
Post by: wesmac75 on July 20, 2012, 08:41:07 PM
I have just tried this after a factory reset on both my 2wire 3801 and my DIR 857.  Everything works until I unplug the ethernet cable from my laptop and connected to the DIR.  Wireless signal looks good, but moments later, the signal drops and is unrecoverable.

Thanks for the detailed tutorial, I wish it worked.  Internet access just keeps getting rescinded.  Any clue why?
Title: Re: DIR-857 SPI Causing Problems (Connected to ATT 2Wire 3801HGV Router/Modem)
Post by: wesmac75 on July 20, 2012, 08:49:58 PM
Do you keep the WAN/Internet port hooked into the 2wire's LAN ports?  Why would the signal keep dropping?
Title: Re: DIR-857 SPI Causing Problems (Connected to ATT 2Wire 3801HGV Router/Modem)
Post by: FurryNutz on July 25, 2012, 05:32:46 PM
Yes you need to keep the WAN port connected to the LAN port on the ISP modem.

Only really major problem for wifi signal dropping would be interference from other near by wifi routers or some external interference...