• March 26, 2023, 08:06:55 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Read this "DCS-942L NTP not functioning properly" can be solved.  (Read 4436 times)


  • Level 1 Member
  • *
  • Posts: 20

My Dlink DCS-942Ls had been updated to the latest firmware both 1.12.1608WW and 1.12.1628EU. (I grouped them into two firmware devices). They are all H/W version A1, agent version 2.0.15-b11.  If I setup time to automatic time configuration and sync with NTP servers ( all from drop down list and Thailand NTP server time1.nimt.or.th) , they did not work and I must set time manually every times I power off and on these IP cameras.  I knew that this issues has been raised for long times and still exist in the current firmware.
Simple way to eliminate this problem is specifying NTP server into IP number.  ping your national NTP server URL and then get the IP address , e.g. time1.nimt.or.th has IP , or ntp1.dlink.com has IP  I have tested many ways and the results can be comfirmed that  URL NTP letter cannot sync time but IP number can do.   I also has a DAP-1360 Repeater mode and test with its "System Check" ping test,  the result are success either URL NTP server name and IP number.  NTP protocol is different to ping test. I'm not sure that which parties (ISP, DNS, Router, IP camera device)  should fix this error.    I decided to specify NTP server with IP number to all network devices from D-Link.  Minor risk may occur if a national NTP server change its IP number.
DIR-655 (wifi Router)
DAP-1360 (repeater mode)


  • Level 1 Member
  • *
  • Posts: 20
Re: Read this "DCS-942L NTP not functioning properly" can be solved.
« Reply #1 on: February 09, 2013, 01:46:38 PM »

Interesting, I haven't had a problem(I'm just using pool.ntp.org).  Sound like your camera has no DNS server set?