D-Link Forums

The Graveyard - Products No Longer Supported => DGL-4500 => Routers / COVR => Beta code for the 4500 => Topic started by: Lotus on June 28, 2011, 09:26:41 AM

Title: Problems updating firmware
Post by: Lotus on June 28, 2011, 09:26:41 AM
I decided to pull out the old DGL 4500 from the closet last week and give it another go since I upgraded my internet to 60/5.

I've tried on 2 computers to upgrade the firmware.......any version, and it won't do it. It also says I have the latest version...... 1.15. It keeps giving me an error ........ the file could be corrupted, not downloading the correct firmware for my model or I'm not Administrator...........something along those lines. This is crazy. I'm definitely admin.

I'm at work and can't remember exactly what it said.

Also, my internet craps out when I do speedtests. Whoa, the language filter edits crap? How about poop? Anyway, it resets the modem and kicks everyone off line for a few seconds. AND my husband is lagging like crazy on xbox. I have set both xbox's per the Sticky thread that Furry has posted.

I now remember this is why I put it in the closet. It was the biggest PITA I've ever seen. The xbox issue was what pushed me over the edge with this thing the last time and I had it set up almost exactly like Furry's thread.

I have HW A2
firmware 1.15

I don't know if a hard reset would do any good or not. I'd hate to wipe out all of the crap I've done.

Title: Re: Problems updating firmware
Post by: FurryNutz on June 28, 2011, 09:30:16 AM
Stay with FW v1.15 as it's a stable and good Fw version. Check out the sticky in the main forum for setting up XBL and gaming.
I have a A2 4500 and using v1.21 on my 50Mb/2Mb Internet just put in in the past 2 weeks. Love it and the 4500 is rockin.

What ISP Service do you have? Cable or DSL?
What ISP Modem do you have? Stand Alone or built in router?

Ensure DNS IP addresses are being filled in under Setup/Internet/Manual?
Turn off Advanced DNS Services if you have this option.
Turn on DNS Relay under Setup/Networking.
Setup DHCP reserved IP addresses for all devices on the router.
Ensure devices are set to auto obtain an IP address.
Set Firewall settings to Endpoint Independent for TCP and UDP.

Turn off all anti virus and firewall programs on PC while testing.
Turn off all devices accept for one wired PC while testing.

What wireless modes are you using?
Try single mode G or mixed G and N?
What security mode are you using? WEP, WPA or WPA2? Preferred is WPA2 and AES.
What wireless devices do you have connected?
Any cordless house phones?

also when doing FW updates, you need to go to the Dlink web site and download the zip file for FW, unpack and use the routers web page to update using the .bin file that was unpacked. However I recommend keeping v1.15 for now.
Title: Re: Problems updating firmware
Post by: Lotus on June 28, 2011, 10:15:58 AM
I have Charter cable.
Stand alone modem....Motorola Docsis 3 SB 6120.

Actually, I've been stalking these forums for the last week and Furry, I had done everything that you've just posted.

My wireless is mixed G & N since I have an older laptop using G and my other 2 pc's are N.

use WPA2 and AES.

I have 3 pc's, 2 droid phones, 1 iTouch, 2 hardwired xboxes, 1 wireless printer, all of which are reserved DHCP and xbox have the highest priority.

No other phones in the home.

I still don't understand why it tells me that v1.15  is the latest when there are others. And why is it shutting down my router? That is weird. weird I say...........weird........

I might try doing a factory reset and if that doesn't work, I'm gonna throw it across the floor, take it outside and put a bullet in it.

I'm also going to cancel the 60/5 since I was told by a good friend and Charter, that I would cap out at around 30 meg unless I use a gigabit router. I tried it and can't pull over 25 using my Netgear N. I don't and won't buy a new router when my Netgear N router works just fine with 18/2. That defeats the purpose of paying/having 60/5 for a whopping price of $99 per month. grrrrr!!!

Sorry, I'm really agitated with this thing, yet AGAIN.

Also, my husband is really lagging while palying xbox. He was stuck in black screen for
almost two minutes while in respawn last night. No one on his or the other team was red/yellow bar. The others continued to play while he was walking into a wall for two minutes.
Title: Re: Problems updating firmware
Post by: FurryNutz on June 28, 2011, 10:45:16 AM
I have the same modem and its a great modem.
Yes I would do a factory reset of the router and just test with one wired PC. Turn off all other devices, ALL. LOL.
Turn off Advanced DNS Service if you have this option. Disable game fuel if it's on and any gaming options you maybe setting. Just want to see if one PC is connecting with factory settings mostly.
Not sure why your not seeing good speeds. I'm seeing 50Mb down and 2 up on mine.

Maybe I can teamviewer.com (http://teamviewer.com) in and check your settings for you.

Also make sure the cables are good between the router and modem. I recommend CAT6 and its cheap. I use a 1footer between mine. All others are CAT6. Most cables that you get with modems and routers don't work or not the best. Invest in new.

Don't throw the 4500 away, it's a good router. Just need to make sure all is working well for it.
Turn off any Anti Virus and 3rd party firwalls on your test PC temporarily.
I use gamefule and XBL and don't lag. How is he connecting to the router? wired or wireless? I recommend wired for all gaming.

I think there was a problem with the DLink servers reporting that the router was up to date when it wasn't and there was recent FW versions available. I think Dlink might have shut off the servers doing updates and it's preferred to manually download FW updates and apply them.
Title: Re: Problems updating firmware
Post by: Lotus on June 28, 2011, 11:40:59 AM
We are both wired for xbox.

I replaced all of my cables, including the ones to the xboxes last year. I got the CAT 5e.

With this router, at its current settings, I'm pulling around 40-47 down, 5.1 up. Just lagging like heck with xbox and modem restarting, which is very annoying. My xbox gold ran out so I haven't had the pleasure of experiencing the lovely lag and black screen yet.....thank goodness. I've broken several controllers, one xbox and managed to put a hole in the wall in my kitchen when I threw my last controller across the room. But, that was back when I was grinding it out in "ranked Team Slayer and Lone Wolves" in Halo 3 lol. I have zero tolerance for lag when it comes to gaming. That's why I have basically quit playing. Its not worth the frustration. IMO, Charter has one of the worst internet services for "gaming". I've always had "latency" issues with them, but never lag unless someone from another country or a bad connection got host.

Gaming was the only reason I bought the DGL 4500 a couple of years ago and I put it away after only 3 months of some of the worst gaming I had ever experienced while using this router. I just though that maybe they had new firmware released that would fix some of what I had previously experienced.

I have had zero trouble with the router (Netgear) I've been using, except for Charter's high latency issues and that, of course, is out of my control. For about 3 years, I've cussed Charter, called them to my house, had all wiring, inside and out replaced, even talked to the Supervisor.  They finally admitted they couldn't/wouldn't fix the high latency/ping. It would take replacing a lot of heads and they aren't going to do that for just 1 person complaining about latency while playing a video game. Pretty much anything over 100 miles gives me high ping times. They told me I shouldn't ping Michigan and other states. I should only ping my local/closest state. Living out in the "county" doesn't help matters either. *facepalm*

wut? When it comes to online gaming, you won't get matches with people within 100 dang miles of you. You get matched up with people from all over the county and the world. I want Fios from Verizon but I can't get it where I live.

Sorry, I'm getting frustrated again......lol.

I'll give all of this a try, hopefully, this weekend, I'll have enough time to sit down and concentrate.

Title: Re: Problems updating firmware
Post by: FurryNutz on June 28, 2011, 12:11:58 PM
Understand the frustrations. Hope we can be of help and see if we can get your 4500 going at least. Just need to set up the xbox and use gamefuel rules and some of the lag should clear up. Again, if your setting problems with Pings and the Modem restarting, it's probably an ISP issue and thus the 4500 might make it seem it's having the problem rather then up stream.

One thing you can make sure, make sure the cable modem is getting a clean line and there are not tv splitters on the cable line. The more splitters you have on this line the less signal the 6120 modem will get and it will have problems. I know that some people use cable tv on the same line, just make sure if you have to use splitters, use only one and make it a good quality one or if needed an amplifier might be in order. Just if you have this scenario. I don't use cable Tv here so I have the cable line into the house and directly into the 6120 modem. Keep us posted.
Title: Re: Problems updating firmware
Post by: Lotus on June 30, 2011, 07:00:51 AM
Ok, I finally updated to firmware 1.21NA

I re-entered all of my devices, added them to gamefuel, reserved IP's, etc.

I added the xbox's.

Now, I'm capping out at 20 meg download (wireless) on my pc. 10 meg when testing on my husband's (wireless). All of my pc's are wireless. I do understand that I might not get the full 60 meg going that route but I should at least be getting 50ish wireless.

The speedtests are done on each pc when NOTHING else is running. *sigh* I have them set with the lowest priority but that really shouldn't matter if that is the only pc or anything wireless, for that matter, is running at that time.

I get more than that with the regular router (netgear) (wireless).

I appreciate your time and effort Furry but I have no patience with this router. Life is too stressful right now and I just don't have the time to keep fooling with this problem when I didn't really have a problem to start with. I just decided upgrade my internet and needed to be using a gigabit router in able to get the full benefits of 60/5. So, I tried to give this router another chance.

I will now give up.

No offense to anyone here but I have NEVER seen a freaking router that was such a PITA. I'm not a total n00b at setting these things up. I've set up many and I do have a little bit more knowledge then the average person about some of these things.

I really hated this router a few years ago and now I am reminded once again why I did.

Maybe I will upload pics of me shooting this POS.

@#&%*$ !!!!!!!!
Title: Re: Problems updating firmware
Post by: FurryNutz on June 30, 2011, 08:45:54 AM
Just FYI, it's not recommended to speed test anything over wireless as there are many factors that result in incorrect results and you'll never see a max of what your Max Download packages are as they would be seen over wired. That goes for ANY router. Nature of the beast. Wireless is wireless and is totally different from wired.

And what wireless modes were using after the FW update?
You didn't elate to what you set up on the router?
I could have used Teamviewer to check your settings too.

Care to send me your 4500 and let me test it out for you on my 50/2 internet?
Title: Re: Problems updating firmware
Post by: Lotus on June 30, 2011, 09:17:29 AM
Thanks for the offer Furry.

As my bossman says, I'm "closing my file" on this one.

Not gonna waste anymore of my time with this. Canceling the 60/5, going back to 18/2.

I do understand I'm not going to get the full 60 on wireless but I should be getting more than 20.4 and shouldn't have to spend so much time tinkering with this router to get it.

I was getting 28meg with the netgear (wireless) back when I had 25/3 and had to do very little tinkering with the QoS setup.
Title: Re: Problems updating firmware
Post by: FurryNutz on June 30, 2011, 10:14:06 AM
Good luck in your endeavors.
Title: Re: Problems updating firmware
Post by: Lotus on June 30, 2011, 10:23:08 AM

See, my idea was to upgrade to 60/5 and cancel my tv, just keep internet and stream netflix, hulu, epix, etc. But, I needed to see if I actually saw a big enough difference in that 60/5 then the 18/3 in order to convince my husband it would be worth it. He'd be streaming on his pc while I'm streaming on mine. Also one of us might be streaming while the other is playing xbox, hence why I wanted 60/5 and needed to use my old DGL 4500. But, its not so important that I have to go through so much trouble.
Title: Re: Problems updating firmware
Post by: FurryNutz on June 30, 2011, 10:30:42 AM
All I know is that the 4500 works just fine with my 6120 connecting at 50/2 cable ISP. I xbox, netflix thru boxee box and enjoy it all.

I recommend someone local that can take a look at all of your wireless and router needs and help you find the solution.
Title: Re: Problems updating firmware
Post by: SpencerG on June 26, 2012, 10:19:59 PM
Hey Furry! Networking expert here and this router is upsetting ha ha! There is a lot goin on.. I recently pulled this out and plan to sell my DIR655 to my aunt.. but the 4500 is giving me problems when its relatively new and unused.. lots of latency and disconnects while playing Diablo 3. Anyway my ISP is Cox and I frequently get 30mbit coming out the modem.. I've done most of the tips you've suggested and just reset, upgraded to 1.23NA, reset, and am still trying to optimize this for my network..

Unfortunately I have the DWA-552 pci adapter which cannot do 5Ghz even tho it says Xtreme N (the 3 phones and 2 Macs probably couldnt do 5Ghz anyway) .. and the WPA is in auto and TKIP as well as AES for legacy support..

I went to school for CCNA and completed the program but never took the test :D but I need me some Furry!
Im interested in Teamviewer or whatever proggie you use let me know please

Thx  ;D
Title: Re: Problems updating firmware
Post by: FurryNutz on June 27, 2012, 06:59:43 AM
Sure, send me a PM with a time frame and teamviewer ID and PW. Be wired to the router when we connect. I'll review the router with you.
Title: Re: Problems updating firmware
Post by: SpencerG on June 27, 2012, 06:42:53 PM
All of a sudden tonight my dlink adapter has started dropping me from the network and then dropping every other network I can see as well.. resetting the connection does nothing. My girls Mac stays online and a reset of the PC is required to get the card working again
Title: Re: Problems updating firmware
Post by: SpencerG on June 27, 2012, 07:36:12 PM
Tried the 5Ghz band for fun, the 552 def doesnt support or nor did my laptop for some reason but the Macs connected np.. also now back on the 2.4, my adapter is just dropping then connecting within 10sec. Weird! Download is 8mbs down and 7 up when earlier just after we did that it was 20-22mbs down and 7 up.. Wired is 30mbs down :(
Title: Re: Problems updating firmware
Post by: FurryNutz on June 28, 2012, 06:56:36 AM
What ISP Modem do you have Spencer? Make and model?
I would try and update the adapter card drivers. If your looking for a wireless adapter card or usb adapter, the DWA-160 does 5Ghz. I have 2 of them. Mac books generally support 5Ghz wifi.
Title: Re: Problems updating firmware
Post by: FurryNutz on June 28, 2012, 09:45:04 AM
Any cordless house phones?
Any other WiFi routers in the area? Use InSSIDer (http://www.metageek.net/) to find out.
Title: Re: Problems updating firmware
Post by: SpencerG on June 28, 2012, 10:38:07 AM
Its a scientific atlanta 2100 docsis 2.0.. no house phones. Only 1 other visible network according to the adapter, sometimes 2. Im downloading that ssd software.. I also reset both the modem and router to factory defaults and am connected unsecured atm to test it.. Would just like to get a steady connection at this point. I think I will just make it invisible, all devices will still be able to connect right? Thinking bout their 2 iPhones and my Evo.. Thoughts?
Title: Re: Problems updating firmware
Post by: SpencerG on June 28, 2012, 10:40:34 AM
Speedtest.net is not working for me so to test it atm Im using http://www.speakeasy.net/speedtest/ which is telling me
Download Speed: 10347 kbps (1293.4 KB/sec transfer rate)
Upload Speed: 5501 kbps (687.6 KB/sec transfer rate)

which I'm kinda happy with considering its 1 source.. I was downloading at 2.4-3MBs sometimes.

Edit: I like this program I should have had both routers on to test network strength before I gave the 655 to my aunt lol
Title: Re: Problems updating firmware
Post by: FurryNutz on June 28, 2012, 10:47:24 AM
Check out some of the other speed testing sites listed in the Rource forum:Resource Library (http://forums.dlink.com/index.php?board=305.0)

Is this the modem your ISP have you to use?
One thing I highly recommend checking is the ISP Cable lines going from the outside in to the house and to the modem. Make thats in good condition. If there are any TV line splitters on it, these will lower the signal going to the modem, if a splitter is needed, use online one good quality one. Have the ISP make sure the signal going to the modem is correct.

I would highly recommend asking your ISP if they support Motorola SB 6 series  stand alone modems. These are good modems, I have tested 3 models out. All work well.
Title: Re: Problems updating firmware
Post by: SpencerG on June 28, 2012, 12:16:23 PM
Yea I bought the modem from my ISP. I used the config file I saved and it broke it so I'm back to no configuration and its a steady connection I will have to experiment..
Title: Re: Problems updating firmware
Post by: FurryNutz on June 28, 2012, 12:56:16 PM
Keep us posted...can help more if needed.  ;)