• June 17, 2024, 08:02:24 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Allow public static IP addresses to access devices on DSR-150 with same IP addr  (Read 11536 times)


  • Level 1 Member
  • *
  • Posts: 1

Our church wants to put a DSR-150 between a Century Link C1000Z modem/router and a phone system to better firewall the phone system.  Currently the C1000Z is set up to allow a “Block of Static IP Addresses” using the PPPoE protocol for connect to Century Link.  That works okay but the C1000Z cannot provide the necessary firewalling we want.  The public static IP address are a block of xx.xx.xx.94 netmask IP addresses.  The phone system is configured with three of the public IP address:  xx.xx.xx.89, xx.xx.xx.90 and xx.xx.xx.92, with the gateway is xx.xx.xx.94.

When I put the C1000Z into ‘transparent bridging 0/32’ the DSR-150 does connect successfully to Century Link using the PPPoE protocol.  However it appears that no traffic is passed through the DSR-150 between the public internet and the phone system.

I tried the following setup, but I must be doing something wrong.

Connection Type: PPPoE
Address Mode:  Static IP
Username:  xxxxxxxxxxx@qwest.net
Password:  xxxxxxxxxx
IP Address:  xx.xx.xx.94
IP Subnet Mask:
Authentication Type:  Auto Negotiate
DNS Server Source:  Use these DNS servers  (
MAC Address Source: Use Default    [Century Link said they do not pay attention to the MAC address]

Oddly when the WAN PPPoE login occurs, the Status - Device -WAN1 webpage shows:
IPv4 Address:  xx.xx.xx..94/
with Gateway:
I thought the mask would remain as

I did set IP Aliasing to xx.xx.xx.94 and netmask to supposedly allow the WAN port to know about all the IP addresses on it.

The WAN Routing Mode is set to Classic.

Yet the xx.xx.xx..89, xx.xx.xx.90 and xx.xx.xx.92 IP addresses are not seen by the public network.  Actually xx.xx.xx.94 is not seen by the public internet either.  I cannot ping or access any of these addresses from the public side.  [With the C1000Z in place as a router, I can ping all these IP addresses.]

Even though NAT is disabled, when I connect a laptop to the DSR-150 it does obtain an IP address of so I can access the Admin GUI at

I thought maybe that I should put the xx.xx.xx.94 with netmask subnet in the DMZ, but then the WAN side complained, upon saving its configuration, that I should not have the same IP addresses in WAN as well as DMZ.

What am I setting up wrong on the DSR-150 to get the internal IP addresses visible on the public Internet?
Do I need ot mess with static routing?
DSR-150, Firmware Version: 3.11_WW, Hardware Version: A3


  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49923
  • D-Link Global Forum Moderator
    • Router Troubleshooting


  • What Hardware version is your router? Look at sticker under the router case.
  • Link>What Firmware version is currently loaded? Found on the routers web page under status.
  • What region are you located?
  • For DSL/PPPoE connections on the router, ensure that "Always ON" option is enabled.
  • If the ISP modem has a built in router, it's best to bridge the modem. Having 2 routers on the same line can cause connection problems: Link>Double NAT and How NAT Works. Call the ISP and ask to see if the ISP modem can be bridged. To tell if the modem is bridged or not, look at the routers web page, Status/Device Info/Wan Section, if there is a 192.168.0.# address in the WAN IP address field, then the modem is not bridged. If the modem can't be bridged then see if the modem has a DMZ option and input the IP address the router gets from the modem and put that into the modems DMZ. Also check the routers DHCP IP address maybe conflicting with the ISP modems IP address of Check to see if this is the same on the ISP modem, and if modem can't be bridged, change the DIR router to or .0.254.
    Example of a D-Link router configured for PPPoE with ISP Modem bridged: PPPoE Configuration on a Router

You'll need to contact your ISP to ensure that the ISP modem is in FULL bridge mode and make sure the PPPoE account information and values are correct and correctly entered in to the DSR router. If the DSR router is still not responding after this, I would phone contact D-Link support.he US offers Chat support for consumer products at support.dlink.com. 24/7 as well.
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.