• November 27, 2021, 01:25:53 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: 1.00.19->1.11.02  (Read 4375 times)

Krusher

  • Level 2 Member
  • **
  • Posts: 75
1.00.19->1.11.02
« on: February 28, 2010, 11:54:42 PM »

I logged in my brother-in-law's work tonight to check out his DES-1228 switch and found that the firmware is really old.  There's an upgrade to 1.11.02, but the docs mention some special process to upgrade it.  However, I can't find these docs anywhere.  Can someone here post that link?

Thanks!
Logged

Fatman

  • Poweruser
  • Level 9 Member
  • ****
  • Posts: 1675
Re: 1.00.19->1.11.02
« Reply #1 on: March 01, 2010, 08:19:16 AM »

I don't know what doc your referring to, but between those versions there is no special procedure.
Logged
non progredi est regredi

Krusher

  • Level 2 Member
  • **
  • Posts: 75
Re: 1.00.19->1.11.02
« Reply #2 on: March 01, 2010, 10:46:03 AM »

When I download and open up des1228_fw_11102.zip, there's a readme in there called "DES-1228_A1_Release Note_FW_v1.11.02.pdf".

In the release notes section for 1.11.01 (which applies to .02, my guess), it says:

"This version (v1.11.01) only supports direct firmware upgrade from v1.10.xx. If the device is with firmware v1.00.xx, please follow up the “New Firmware Upgrade Procedure “ document to upgrade the firmware from v1.00.xx to v1.11.01. If the device is with new firmware v1.11.01, it is not allowed to downgrade previous firmware v1.00.xx."

I downloaded v1.11.01 and found the readme file in there which says to upload three files, one at a time.  Then I can upgrade to .02.  It looks like I have some work to do tonight, because it needs to reboot after every load.  :)

In this order...
1228FWU.hex
1228ldr.hex
DES-1228_A1_1_11_01.hex
DES-1228_A1_FW_1.11.02.hex
Logged

poyicameo

  • Level 1 Member
  • *
  • Posts: 8
Re: 1.00.19->1.11.02
« Reply #3 on: June 07, 2010, 07:35:08 AM »

Dear Krusher,

The DES-1228 must follow special rule to upgrade firmware from 1.00.19->1.11.02, because the DES-1228 add some new feature to v1.11.02, and that need upgrade the device boot code (loader code). This upgrade rule is necessary. Thanks for your patience.

Poyi
Logged