D-Link Forums

The Graveyard - Products No Longer Supported => D-Link Storage => DNS-325 => Topic started by: coleman6 on July 21, 2018, 11:08:18 AM

Title: My D-Link Cloud in ShareCenter stopped working
Post by: coleman6 on July 21, 2018, 11:08:18 AM
I need help with 2 issues related to my dns-325 NAS.
For about 5 years I have had a dns-325 NAS with 2 WD Red 3T drives in the bays. It was configured in RAID 1 with auto-rebuild enabled. Recently the RAID was reporting as degraded. Upon a closer look, the left drive was indicating instability. And the configuration was now showing as Standard instead of RAID 1. When I removed the failing drive, the good remaining drive indicated RAID 1. I tried it in both bays alone and it indicated RAID 1. I bought another WD 3T Red drive and thought I would just need to replace the drive and the auto-rebuild would take over. It didn’t. To be safe I copied the entire contents of the good drive (2.25T worth of data) to a back-up 3T drive. Then I proceeded stepping through the config process, choosing RAID 1 again and hoping that it would see the “good” RAID 1 drive and rebuild the newly inserted drive from that drive. It didn’t. It formatted both drives and then I had to copy all the externally backed up data back onto the NAS. The whole purpose of having a RAID 1 configuration was for naught – it simply didn’t work as described. And as of September 2017 the dns-325 is no longer supported for free tech help.
Back up and running, I re-installed the My D-Link Cloud app so that I would be able to access the NAS remotely. I had been able to do this for years through the mobile app specific to the dns-325 prior to replacing the drive, though I didn’t do this often. But now, within the NAS itself, whenever I try to either recover my account or establish a new account with My D-Link Cloud NAS app, I get an “internal server error” preventing me from creating an account that I could link to from the mobile app. Also, on the NAS My D-link Cloud account setup, there is a highlighted link that says “Check to see if account name is available.” No matter what I put in, it returns a “Not available” message – even if it a series of random letters/numbers. I did recently update the firmware to 1.05 from 1.03. After reading forum posts about problems with My D-Link cloud after updating to 1.05, I tried reverting to 1.03 but that made things worse – couldn’t see my files and My D-Link Cloud wouldn’t install. Updated to 1.05 again and could see my files but had the same issue with My D-Link Cloud app not working.
Can anyone help me figure out how to get the My D-Link Cloud app working again? And secondly, can anyone help explain why the RAID 1 setup didn’t work as described and instead of rebuilding my RAID 1, it reformatted both drives? If I ever have another drive failure, I don’t want to go through everything I went through again. BTW, I use Windows 10 Home and Chrome is my default browser.
Title: Re: My D-Link Cloud in ShareCenter stopped working
Post by: FurryNutz on July 21, 2018, 01:01:11 PM
Link>Welcome! (http://forums.dlink.com/index.php?topic=48135.0)

Lets review this first:
http://forums.dlink.com/index.php?topic=41398.0 (http://forums.dlink.com/index.php?topic=41398.0) and http://forums.dlink.com/index.php?topic=73736.msg296123#msg296123 (http://forums.dlink.com/index.php?topic=73736.msg296123#msg296123)

Not sure if the MyDLink cloud service is supporting of this model DNS...I'll see if I can find out some information. I'll have someone come here and help with your DNS drive issue if possible...

Title: Re: My D-Link Cloud in ShareCenter stopped working
Post by: ivan on July 21, 2018, 02:22:12 PM
A couple of points.
1) The RAID array is a Software Raid which means the moment you removed the good disk from its slot and put it in the other one you broke the RAID configuration.  What you should have done was just replace the bad drive with a good replacement and the array would have been rebuilt without problems.
2) The reason both drives were formatted was because you broke the Software Raid configuration thus the firmware had to create a new RAID array.  At least you had your data backed up thus allowing a restore.

Sorry I can't help with the My D-Link Cloud problem as I have never used it.  At work we used more secure ways of accessing clients NAS boxes for backup to our storage array.

One question, after reading the manual, regarding the My D-Link Cloud.  Did the NAS download the necessary program without problems?  Reading the DNS-325 manual it appears that if you dont have that installed you will get the results you are seeing.
Title: Re: My D-Link Cloud in ShareCenter stopped working
Post by: coleman6 on July 21, 2018, 08:22:48 PM
Thanks Ivan. That explains some things. I first left the good drive in its original bay. I thought after putting the new replacement drive in and powering the NAS back on the rebuild would would automatically start. When it didn't, I saw that it was now showing my array as a Standard array. I stepped through the HDD configuration steps but because it was not clear I worried that the format might format both drives. That is what lead to my looking at the "good" drive in both bays by itself - to see if it still showed as RAID 1, which it did. But, as you say, good thing I was able to backup the content on a third drive so that I could copy it back to the NAS.
But the pressing problem now is that My D-Link Cloud no longer works. It worked fine for years and with FW 1.03. But after changing to FW 1.05b03 D-Link cloud had to be re-installed. The installation indicates it is successful but the ShareCenter app is unusable because all it does is bring up a window to create a new account or recover a previous account. If I try to recover my account, I get an internal server error. If I try to establish new account I get "ID rejected, DS rejects request." The remote access was useful for my son who is on the other side of the country. His files account for most of the content on the NAS but he could access as needed until recently.

Thanks very much for your reply!
Title: Re: My D-Link Cloud in ShareCenter stopped working
Post by: ivan on July 22, 2018, 04:36:10 AM
To clear up what happened with your disks. You shouldn't have switched the unit off, just replace the bad disk, the auto rebuild would then have taken over and rebuilt the array - at least that is what has happened in all the times I had to replace a bad disk for clients.

As for the My D-Link Cloud I am wondering if the fact that you have created a new array might mean that you have to create a new account or the other possibility is that something in the firmware update is incompatible with the program - that is just clutching at straws for me.  hopefully someone that knows and uses the program can help. 
Title: Re: My D-Link Cloud in ShareCenter stopped working
Post by: coleman6 on July 22, 2018, 11:23:08 AM
The DNS manual seems to suggest having the unit off when installing and/or removing drives. My first attempt was to keep the good drive in its bay and put a new replacement drive in the open bay. When I powered the unit on, nothing happened. So I had to use ShareCenter to step through formatting a drive and even when choosing RAID 1, it left my "good" drive in RAID 1 but formatted the new drive as Standard. But, all of that is water under the bridge now.

The new array meant I had to reinstall My D-Link Cloud, which I did. But it no longer lets me recover my old account nor establish a new account. It is likely the there is some problem caused by the updated firmware, but I cannot revert to the old firmware because then my files cannot be seen at all, nor can My Dlink Cloud be installed. The issue with reverting back to 1.03 may be that it supports EXT3 file format.  Version 1.05 provide support for EXT4 file format.  I am pretty sure that my original Raid1 array was formatted as EXT3.  When I upgraded to 1.05, it formatted my drives as EXT4. So when I tried rolling back to 1.03 firmware, it couldn't read the newer EXT4 formatted drives. So I had to go back to the 1.05 firmware upgrade. I hope someone can figure this out because My Dlink Cloud was something my son and I both used to access our files remotely.

Thanks for your time Ivan. Truly appreciated.
Title: Re: My D-Link Cloud in ShareCenter stopped working
Post by: ivan on July 23, 2018, 01:25:17 AM
OK, now you have a decision to make that may or may not give you back what you had.  You can revert to the older firmware, reformat the array as Ext3, and restore the data from your backup.  The problem with that is I can't say if doing so will restore your Cloud access.

I'm sorry I can't help more but as I said I have never used the My D-Link Cloud, our industrial clients needed more security so we used much more secure access to their NAS units for remote admin and backup.
Title: Re: My D-Link Cloud in ShareCenter stopped working
Post by: coleman6 on July 23, 2018, 08:28:12 AM
I won't be reformatting the drives again just to put them back in the dns-325 with older firmware. If I have to reformat again, then the decision that I have to make now, it seems, is what new NAS should I buy. Maybe someone else will see this post and have a solution to get My D-Link Cloud working again. If not, I will start looking at other NAS units such as QNAP.