The Graveyard - Products No Longer Supported > Other D-Link Products

DWR-921 - Cannot login once the admin password is set

(1/3) > >>

The rest of the functions on this router are working well to the level that I'm going through it write this post..

My issue is that once I try to change the "admin" password from blank, it refuses to let me log in again.
Actions tried include;

* Reset the router and change password to a complex password
* Reset the router again and change the password to a simple password
* Each router reset used Chrome and IE
* Multiple reboots of the router and restart of laptop
Has anyone else had this experience??

I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this.
Link> Tech Support Contact Information
We find that phone contact has better immediate results over using email.
Let us know how it goes please.

Thanks @FurryNutz, I'll give them a call before I pack it back up and head to Officeworks. I hoped it may have been a known issue with a simple fix, I'll let you know how it goes.

So you change the password, save, and after the router reboots does the browser refresh to the login page?

After reboot, close the browser and reopen. Also clear your browser cache.

Fact that it is happening with multiple browsers, something obviously is broken.

Do all other settings save without issues?

Thanks @GreenBay42, yes, I've cleared caches and deleted cookies but still no dice. The only other settings I've modified are the SSID and it's passkey but they both save without issue verified by the fact that colleagues were connecting to it automatically this morning.


[0] Message Index

[#] Next page

Go to full version