The Graveyard - Products No Longer Supported > DSP-W110

DSP-W110 stopped responding to scheduled on off times

(1/3) > >>

I have 5 DSP-W110 smart plugs. They have been working fine for a few years. All of a sudden this week 4 of them stopped turning on or off according to the schedules they are programmed on. I can manually turn on and off but the schedules are not working. I have tried unplugging them and rebooting, I have tried re-pairing with wireless router. Currently on firmware 1.22, using mydlinkhome app on iphone. Any ideas? I'm stumped.

I have seen a few customers with this issue. I will pass it on to a tech to investigate.

Do you have revision A or B?

I have BETA firmware for revision A. THiS IS UNTESTED SO USE AT YOUR OWN RISK.


1.Hold reset button and then power on the DSP and wait for 10 seconds then release reset button.

2.Connect wirelessly to your DSP SSID. ex: DSP-W110-xxxx

3.Open browser and go to

4.Upload the bin file.

Please let me know how this works for you if you decide to give it a try. Try on 1 device for a day or 2 before testing on your other units.

Is there any update on when this issue will be fixed? Going on vacation soon and I would like my smartplugs to be working. Thank you

No reply yet.

I pulled the BETA since multiple users as well as techs said it failed.


[0] Message Index

[#] Next page

Go to full version