D-Link Wireless Routers for Home and Small Business > DIR-885L

DIR-885L - 5 GHz Wi-Fi Does Not Broadcast

(1/2) > >>

inimitable:
Just set up my DIR-885L. 2.4 GHz Wi-Fi broadcasts and works fine; 5 GHz does not. 5 GHz Indicator light on router is lit but no devices (laptop, phone, iPad, Roku, PS4) see the SSID. All recognized 5GHz band on previous router (different brand).

Hardware version: A1
Firmware version: 1.13

Smart Connect disabled. Different SSID for each band. Settings are standard but have tried changing channel, mode, transmission power, and channel width.

Please let me know if you need further info.

FurryNutz:
Link>Welcome!


* What region are you located?
* Has a Factory Reset been performed?
* Was a Factory Reset performed before and after any firmware updates then set up from scratch?  Link> >FW Update Process

* Was the router working before any firmware updates?

inimitable:
United States (Mountain Time Zone)
Yes, tried a factory reset after firmware update (update was performed after initial setup). Router worked very briefly after initial setup and firmware update.

Have since taken phone and iPad elsewhere and have had no problem connecting to a 5 GHz band, so I don't think it's a problem with the individual devices.

FurryNutz:
I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. This maybe a faulty unit and needs to be RMAd.

inimitable:

--- Quote from: FurryNutz on September 21, 2017, 06:51:21 AM ---I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. This maybe a faulty unit and needs to be RMAd.

--- End quote ---

Will do, thanks for the help!

Navigation

[0] Message Index

[#] Next page

Go to full version