• November 22, 2017, 06:02:14 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2

Author Topic: Android Browser not working after update  (Read 820 times)

ALong123

  • Level 1 Member
  • *
  • Posts: 5
Android Browser not working after update
« on: August 28, 2017, 09:59:37 AM »

Hey, I just updated to 1.11.

Browser was working ok on 1.09.
I use Chrome on my phone, ive tried using the standard browser and still no go on the phone.
All my laptops and PCs are working ok.
I am using SC and have IQOS disabled.
I did follow the proper FW update process that is listed

Any help would be great
Thanks
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43683
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Android Browser not working after update
« Reply #1 on: August 28, 2017, 10:03:28 AM »

Link>Welcome!


  • What region are you located?
  • Has a Factory Reset been performed after updating FW then set up from scratch?


I don't have Android, however Safari browser works on my iPhone. Try a different browser on your phone?

Disable IPv6 on the phone.
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

ALong123

  • Level 1 Member
  • *
  • Posts: 5
Re: Android Browser not working after update
« Reply #2 on: August 28, 2017, 10:23:15 AM »

Im located in Canada, I did do a factory reset after updating the firmware. I manually entered the router settings rather than uploading the config file.
Ive tried using the stock browser that comes with android and still no go
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43683
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Android Browser not working after update
« Reply #3 on: August 28, 2017, 11:40:50 AM »

What OS is the phone using?

Is IPv6 set for Local Only on the router?
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

ALong123

  • Level 1 Member
  • *
  • Posts: 5
Re: Android Browser not working after update
« Reply #4 on: August 28, 2017, 03:30:43 PM »

The phone is a Galaxy S5 Neo running 6.0.1
The router is set Auto Configuration for IPv6
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43683
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Android Browser not working after update
« Reply #5 on: August 29, 2017, 09:06:19 AM »

Please set IPv6 for Local Only then see if this changes anything.
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

ALong123

  • Level 1 Member
  • *
  • Posts: 5
Re: Android Browser not working after update
« Reply #6 on: August 29, 2017, 10:05:41 AM »

Tried it out and still having the same issue
Logged

GreenBay42

  • Administrator
  • Level 5 Member
  • *
  • Posts: 501
Re: Android Browser not working after update
« Reply #7 on: August 29, 2017, 10:28:04 AM »

Set the IPv6 back to auto.

So you are just trying to use Chrome on your Android to access the web UI or is the Internet not working? Can you get to the log in screen? Are you entering the IP address of the router or http://dlinkrouter.local.

Verify your phone is connected to the router and not 3g/4g.
« Last Edit: August 29, 2017, 10:45:44 AM by GreenBay42 »
Logged

ALong123

  • Level 1 Member
  • *
  • Posts: 5
Re: Android Browser not working after update
« Reply #8 on: August 29, 2017, 11:15:05 AM »

I set it back to Auto
Its actually the chrome app and some other apps on my phone, some games. Play store doesnt work as well.
It is connected to wifi and not 3g/4g
*I am using the IP address of the router (192.168.100.1)

I just tried something the last 10min from this post.

I reset FW 1.11 back to factory defaults with the reset button on the back of the router while the ISP modem was completely unplugged. I let everything reset and tried the WiFi again, still no go. So from that I started going back with FW updates. The only FW that actually worked were 1.07 and 1.08.
Im going to configure the router to my household here and see if it works afterwards and I will reply back on here.

The next thing would be to find out what settings have changed from 1.07-08 to 1.09-.11
« Last Edit: August 29, 2017, 11:19:39 AM by ALong123 »
Logged

GreenBay42

  • Administrator
  • Level 5 Member
  • *
  • Posts: 501
Re: Android Browser not working after update
« Reply #9 on: August 29, 2017, 12:27:00 PM »

If you didn't change the router's IP to 192.168.100.1 that means the router is connected to a modem/router (double-NAT). It may be a DNS issue.

On the D-Link router I would either change it to AP mode or make sure the modem is fully bridged. But since all your other devices are working is may be something on the phone specifically. Did you reboot your phone?

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43683
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Android Browser not working after update
« Reply #10 on: August 29, 2017, 01:33:58 PM »

You could downgrade FW back to what worked before to see if the problem continues.

Is this the only device that this happens with?

I got word that someone else tried to replicate this issue on his Android and using v1.11 and couldn't make it happen. All worked.
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

MSuomi

  • Level 2 Member
  • **
  • Posts: 45
Re: Android Browser not working after update
« Reply #11 on: August 29, 2017, 10:04:17 PM »

You could downgrade FW back to what worked before to see if the problem continues.

Is this the only device that this happens with?

I got word that someone else tried to replicate this issue on his Android and using v1.11 and couldn't make it happen. All worked.

Is this the b2-FW? I have 5 Android devices (Note 3, LG V500 tablet, Samsung Galaxy Tab 3 Lite 7.0 VE, Honor 8 and Shield TV) which all work without any problems...
Logged

GreenBay42

  • Administrator
  • Level 5 Member
  • *
  • Posts: 501
Re: Android Browser not working after update
« Reply #12 on: August 30, 2017, 06:15:12 AM »

Android works fine with this firmware. The fact all the other devices work means there is something on the phone, not the router.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43683
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Android Browser not working after update
« Reply #13 on: August 30, 2017, 09:32:24 AM »

Maybe you could give some suggestions to ALong and see if maybe the problem can be found and fixed?

You could downgrade FW back to what worked before to see if the problem continues.

Is this the only device that this happens with?

I got word that someone else tried to replicate this issue on his Android and using v1.11 and couldn't make it happen. All worked.

Is this the b2-FW? I have 5 Android devices (Note 3, LG V500 tablet, Samsung Galaxy Tab 3 Lite 7.0 VE, Honor 8 and Shield TV) which all work without any problems...
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

MSuomi

  • Level 2 Member
  • **
  • Posts: 45
Re: Android Browser not working after update
« Reply #14 on: August 31, 2017, 03:14:15 AM »

Maybe you could give some suggestions to ALong and see if maybe the problem can be found and fixed?

You could downgrade FW back to what worked before to see if the problem continues.

Is this the only device that this happens with?

I got word that someone else tried to replicate this issue on his Android and using v1.11 and couldn't make it happen. All worked.

Is this the b2-FW? I have 5 Android devices (Note 3, LG V500 tablet, Samsung Galaxy Tab 3 Lite 7.0 VE, Honor 8 and Shield TV) which all work without any problems...

I didn't need to set anything special. I straight away updated 890L FW to 1.11b2. I use QOS, SC, NAT, all firewall settings are on and I don't use DNS relay. I don't have IPv6 on my connection and I haven't touched any IPv6-settings. I didn't have to do anything special, all just work straight away... Android machines and everything else too...
Logged
Pages: [1] 2