• October 19, 2017, 12:53:24 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Restricted email password characters  (Read 390 times)

remoteCamsFarAway

  • Level 2 Member
  • **
  • Posts: 84
Restricted email password characters
« on: March 26, 2017, 04:42:52 PM »

Just stored stored my gmail password into the email settings on the DNR-312L.  When I tried to send a test message I got the error

The Password can not contain the following characters: #"&\

Obviously my VALID gmail password contains one or more of the listed characters.  This rule may have applied years ago but is outdated.  This restriction should be removed.  Not only will it not let me send a test message but it will not let me save this password to enable emailing events.  Yes I could change my password to a less secure password but the correct solution is to bring the firmware up to date.

Running the currently latest firmware revision 1.06.07
« Last Edit: March 26, 2017, 04:50:08 PM by remoteCamsFarAway »
Logged

RYAT3

  • Level 10 Member
  • *****
  • Posts: 2075
Re: Restricted email password characters
« Reply #1 on: March 26, 2017, 06:14:54 PM »

Umm, lots of dlink products have this restriction (like on device passwords). I agree,  it is annoying.

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43391
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Restricted email password characters
« Reply #2 on: March 27, 2017, 07:36:52 AM »

I was told that some special characters are support, however it maybe how the characters are used maybe the issue:
0-9,a-z,A-Z,~!@$%^&*()_+-={}[];:|,./<>?

Looks like # " and \ are not supported though...

Just stored stored my gmail password into the email settings on the DNR-312L.  When I tried to send a test message I got the error

The Password can not contain the following characters: #"&\

Obviously my VALID gmail password contains one or more of the listed characters.  This rule may have applied years ago but is outdated.  This restriction should be removed.  Not only will it not let me send a test message but it will not let me save this password to enable emailing events.  Yes I could change my password to a less secure password but the correct solution is to bring the firmware up to date.

Running the currently latest firmware revision 1.06.07
Logged
Cable:100mb/3Mb>Motorola SB6183>DIR-880L>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,826L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L and a Boxee.
Go Here>Router Troubleshooting