• October 16, 2017, 06:49:34 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Email Test Error (SOLVED)  (Read 3374 times)

mobne

  • Level 1 Member
  • *
  • Posts: 4
Email Test Error (SOLVED)
« on: December 09, 2015, 03:01:16 PM »

I don't know what to do any more.

I have tested all firmwares i can find. same in all of them.
I have tried yahoo, gmail and my ISP bahnhof. Non of them can complete the test.

I have followed instructions carful from the providers on how to set it up. Nothing works.

On my dcs-933L it works but not on my dcs-2230
Why is that? Is my camera broken? Sounds so strange.

Followed this guide also:

Procedure: Gmail
SMTP Server Address        smtp.gmail.com
SMTP Server Port           587 or 465
Sender E-mail Address      myname@gmail.com
Receiver E-mail Address    myname@gmail.com
User Name                  myname
Password                   my e-mail account password
« Last Edit: December 10, 2015, 01:38:03 AM by mobne »
Logged

RYAT3

  • Level 10 Member
  • *****
  • Posts: 2074
Re: Email Test Error
« Reply #1 on: December 09, 2015, 05:46:19 PM »

Try full email as username? Just a guess

Joeblow@Gmail.Com
Etc
Logged

mobne

  • Level 1 Member
  • *
  • Posts: 4
Re: Email Test Error
« Reply #2 on: December 10, 2015, 01:37:50 AM »

Try full email as username? Just a guess

Joeblow@Gmail.Com
Etc

Yes of course i use that.
I actually found the issue today.

With Gmail its compleetly necessary to use (StartTLS) and the only port that works is 587.

took me like 7 hours of testing before finding this out :( Yahoo never worked and not my ISP either. The strange is that yahoo worked on my dcs-933l camera, and the exact same settings it had did not work with the dcs-2230. Thats confusing.

So for some other ppl with troubles:
My setup now is:

Sender email address: emailname@gmail.com
Recipient email address: differentemailname@hotmail.com
Server address: smtp.gmail.com
User name: emailname
Password: gmail email password
Port: 587
This server requires a secure connection (StartTLS): startls ON

Logged

Hard Harry

  • Guest
Re: Email Test Error (SOLVED)
« Reply #3 on: December 10, 2015, 02:28:00 AM »

FYI, here are some additional methods of configuring to send through Gmail's SMTP server. Each have their specific requirements. Might come in handy for those devices that aren't compatible with TLS.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43346
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Email Test Error (SOLVED)
« Reply #4 on: December 10, 2015, 07:32:41 AM »

Setting up email on DCS series cameras FAQ - http://forums.dlink.com/index.php?topic=63536.0
Logged
Cable:100mb/3Mb>Motorola SB6183>DIR-880L>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,826L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L and a Boxee.
Go Here>Router Troubleshooting

zzyzxx_x

  • Level 1 Member
  • *
  • Posts: 5
Re: Email Test Error (SOLVED)
« Reply #5 on: December 14, 2015, 07:27:44 PM »

This is so weird.
My cam was working just fine with gmail, with the settings described.
For some unknown reason, without changing anything at all, it doesn't work any more.
And I cannot get it to work, no matter what I try! All I get is "Test error".
What really bugs me, is that I didn't change anything with the cam or the router!
Yipes.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43346
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Email Test Error (SOLVED)
« Reply #6 on: December 15, 2015, 06:22:12 AM »

If it had been working and you haven't changed anything on your side of the ISP services, it could possibly be something on the ISP side of things.

This is so weird.
My cam was working just fine with gmail, with the settings described.
For some unknown reason, without changing anything at all, it doesn't work any more.
And I cannot get it to work, no matter what I try! All I get is "Test error".
What really bugs me, is that I didn't change anything with the cam or the router!
Yipes.
Logged
Cable:100mb/3Mb>Motorola SB6183>DIR-880L>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,826L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L and a Boxee.
Go Here>Router Troubleshooting

zzyzxx_x

  • Level 1 Member
  • *
  • Posts: 5
Re: Email Test Error (SOLVED)
« Reply #7 on: December 15, 2015, 08:47:32 AM »

Agreed. But how to troubleshoot that?
I know from (painful) experience speaking with anyone from Comcast is only a waste of time...
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43346
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Email Test Error (SOLVED)
« Reply #8 on: December 15, 2015, 08:55:09 AM »

Might try a different email account and set up from scratch and see.
Logged
Cable:100mb/3Mb>Motorola SB6183>DIR-880L>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,826L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L and a Boxee.
Go Here>Router Troubleshooting

Hard Harry

  • Guest
Re: Email Test Error (SOLVED)
« Reply #9 on: December 17, 2015, 09:07:57 PM »

Agreed. But how to troubleshoot that?
I know from (painful) experience speaking with anyone from Comcast is only a waste of time...

I feel your pain. Both as a customer and a former employee of a similar ISP; Cox. Did Comcast customer service also get a lot worst in the last 2 years?

Anyway, what settings were you using? Also, is your camera on your Comcast home network?

Something I notice is Comcast says to use port 465 for SMTPS . This makes me think they have started using STARTTLS vs TLS on that port. The whole thing is super confusing though, if your curious, and want to know more, see this blog post.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43346
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Email Test Error (SOLVED)
« Reply #10 on: December 18, 2015, 06:51:57 AM »

Harry, Let me know if any troubleshooting information needs to be added to the FAQ. I'd like the to be a central place users can go to get help on email issues. Email has been a roller coaster ride for many.

Agreed. But how to troubleshoot that?
I know from (painful) experience speaking with anyone from Comcast is only a waste of time...

I feel your pain. Both as a customer and a former employee of a similar ISP; Cox. Did Comcast customer service also get a lot worst in the last 2 years?

Anyway, what settings were you using? Also, is your camera on your Comcast home network?

Something I notice is Comcast says to use port 465 for SMTPS . This makes me think they have started using STARTTLS vs TLS on that port. The whole thing is super confusing though, if your curious, and want to know more, see this blog post.
Logged
Cable:100mb/3Mb>Motorola SB6183>DIR-880L>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,826L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L and a Boxee.
Go Here>Router Troubleshooting

zzyzxx_x

  • Level 1 Member
  • *
  • Posts: 5
Re: Email Test Error (SOLVED)
« Reply #11 on: December 20, 2015, 09:21:03 AM »

OK, so I whipped out the Wireshark to see what's going on in the cam's network segment, and...surprise!
Absolutely NOTHING. Despite the motion detection on, the cam does not send any email.  I'm not sure (yet) if the cam is not detecting motion OR it's detecting the motion but not sending the email. I'll have to figure a way to troubleshoot that next.
The video over the network works fine...
Logged