• November 18, 2017, 07:32:37 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 [2]

Author Topic: My 942L doesn't send email  (Read 17504 times)

Snaggles8

  • Level 1 Member
  • *
  • Posts: 1
Re: My 942L doesn't send email
« Reply #15 on: July 08, 2016, 10:25:18 AM »

As per kope above, I created a non-secure access to a throwaway google account without numbers in the password, used google settings in email page, but use only name and not @gmail.com in the name field. also had to set the security to starttls in order for it to work. only took me a few hours of frustration lol!
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43623
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: My 942L doesn't send email
« Reply #16 on: July 08, 2016, 10:49:01 AM »

Thanks for sharing your information. Hope this helps future users. Enjoy.

As per kope above, I created a non-secure access to a throwaway google account without numbers in the password, used google settings in email page, but use only name and not @gmail.com in the name field. also had to set the security to starttls in order for it to work. only took me a few hours of frustration lol!
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

Altrev

  • Level 1 Member
  • *
  • Posts: 1
  • "Tight lines and smiling faces!"
    • Saltwater Cowboys Charters
Re: Finally got my camera's email working!
« Reply #17 on: August 04, 2016, 12:19:54 PM »

Here's what I did:

First I assigned a Static IP address to the camera:
    1. Reserve the IP address currently assigned to the camera on your router;
    2. Access the camera interface by entering the same IP address into your browser;
    3. Select the Status tab;
    4. Note the IPv4 settings (Address, Subnet Mask, Default Gateway, DNS, etc);
    5. Go to Setup/Network;
    6. Select Static IP Address, and
    7. Enter the same settings that were noted above into the appropriate cells (don't save yet).
Now change the HTTP Port in case your ISP doesn't enable port 80:
    8. Scroll down to the port settings:
       a. Change the HTTP Port to 801,
       b. Enable UPNP Port Forwarding,
       c. Change the UPNP External HTTP Port Forward to 801,
       d. Leave the other two ports (HTTPS, RTSP) the same;
    9. Save the camera settings and let the camera reboot.

While the camera reboots, log into your router again and forward ports 801, 443 and 554 to your camera's Static IP address (I activated both UPD and TCP protocols, which might be overkill, but I wasn't taking any chances).

Log back into the camera using the Static IP Address and new port (192.164.0.14:801), make sure your email settings are correct and run a test.

It worked like a charm for me, and I'm up and running now!
« Last Edit: August 04, 2016, 12:34:55 PM by Altrev »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43623
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Finally got my camera's email working!
« Reply #18 on: August 04, 2016, 12:40:02 PM »

Depending on configuration and router MFr, Static IP addresses should NOT be reserved ON the router at the same time. Static IP addresses should be set on devices out side of the routers DHCP IP address pool. Otherwise using a Reserved IP address for devices ON the router with in the DHCP IP address pool is a good method. Setting a Static and reserving at the same time is not good networking practice and may cause problems.
>DHCP

It's recommended that in this case, cameras, should have a static IP address set on them.

Here's what I did:

First I assigned a Static IP address to the camera:
    1. Reserve the IP address currently assigned to the camera on your router;
    2. Access the camera interface by entering the same IP address into your browser;
    3. Select the Status tab;
    4. Note the IPv4 settings (Address, Subnet Mask, Default Gateway, DNS, etc);
    5. Go to Setup/Network;
    6. Select Static IP Address, and
    7. Enter the same settings that were noted above into the appropriate cells (don't save yet).
Now change the HTTP Port in case your ISP doesn't enable port 80:
    8. Scroll down to the port settings:
       a. Change the HTTP Port to 801,
       b. Enable UPNP Port Forwarding,
       c. Change the UPNP External HTTP Port Forward to 801,
       d. Leave the other two ports (HTTPS, RTSP) the same;
    9. Save the camera settings and let the camera reboot.

While the camera reboots, log into your router again and forward ports 801, 443 and 554 to your camera's Static IP address (I activated both UPD and TCP protocols, which might be overkill, but I wasn't taking any chances).

Log back into the camera using the Static IP Address and new port (192.164.0.14:801), make sure your email settings are correct and run a test.

It worked like a charm for me, and I'm up and running now!
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

rib-butcher

  • Level 1 Member
  • *
  • Posts: 1
Re: My 942L doesn't send email
« Reply #19 on: August 30, 2016, 01:40:31 PM »

Hi all,

My DCS-942L stopped sending emails using my Gmail SMTP settings after getting a new router even after configuring the new router to look like the old one on the LAN. I'd just like to note that I had to specify the IP of my new router within the camera primary DNS settings to get the camera to send emails again. Something which I did not have to define with my old router.

I guess the camera could not resolve the smtp.gmail.com hostname but the lovely lack of error messages when emails failed to send of course helped me to diagnose this ;)

Rob.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43623
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: My 942L doesn't send email
« Reply #20 on: August 30, 2016, 04:39:52 PM »

Link>Welcome!

  • What Hardware version is your DCS? Look at the sticker behind or under the camera.
  • Link>What Firmware version is currently loaded? Found on the DCSs web page under status.
  • What region are you located?

What Mfr and model is the main host router?

I recommend setting a static IP address ON the cameras outside of the main host routers default DHCP IP address pool: 192.168.#.94.  DHCP

Test cameras with uPnP and uPnP Port Forwarding both enabled on ALL cameras: DCS Cloud (L) Series Camera Configuration and Mydlink.com

Setting up email on DCS series cameras FAQ - http://forums.dlink.com/index.php?topic=63536.0

Hi all,

My DCS-942L stopped sending emails using my Gmail SMTP settings after getting a new router even after configuring the new router to look like the old one on the LAN. I'd just like to note that I had to specify the IP of my new router within the camera primary DNS settings to get the camera to send emails again. Something which I did not have to define with my old router.

I guess the camera could not resolve the smtp.gmail.com hostname but the lovely lack of error messages when emails failed to send of course helped me to diagnose this ;)

Rob.
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting
Pages: 1 [2]