• January 31, 2023, 02:50:13 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: New - DNS-345 - Firmware Version 1.05b04 Beta - Comments & Observations  (Read 12353 times)

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49923
  • D-Link Global Forum Moderator
    • Router Troubleshooting

Revision: Firmware Version v1.05b04 Beta - 09/15/2017

Fixed:
Fix the Command injection in CGI exploit, exploitable stack overflow in the binary, and the security issue on Lighttpd configuration

Get it here:
DNS-345

Also FYI:
Link>D-Link NAS Owner's :: Regarding CripTor Ransomware

Let us know how it works for you...
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

AndreyKV_25032019

  • Level 1 Member
  • *
  • Posts: 1

Hi!

Can You help me?

I try upgrading the firmware on my DNS-345 to v1.05b04. But after it rebuted

I tried to upgrade the firmware version to version v1.05b04 on my DNS-345, but after restarting, NAS did not load completely. It is available at the same IP address. Gives me enter password and lets it go to the first page, but there’s almost nothing on it and no buttons are pressed.

How can I get NAS to normal?

Before upgrading version was 1.05, but I dont now subversin after "b0...". Firmvare date was 2014.

Thanks in advance for your reply.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49923
  • D-Link Global Forum Moderator
    • Router Troubleshooting

Link>Welcome!

  • What region are you located?

What browser were you using to update the FW? I recommend IE11 or FF only.
Try a reset on the DNS. You won't loose data, just web page configurations.
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

sjaswal

  • Level 1 Member
  • *
  • Posts: 1

updated to this FW with chrome
having same issue as previous user posted
tried reset (had to hold for ~40sec for reboot/reset
essentially just a network drive now with no control

is there any way to force a FW downgrade?


********************************************************
with IE11 I was always getting some errors, so I used chrome to install FW, but after upgrade it appeared to be broken
so before posting this I downloaded firefox......
wouldn't you know it - the menus work, they do not work anymore with ie11 or chrome

so for me it looks like it only works with Firefox

thanks for having this forum
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49923
  • D-Link Global Forum Moderator
    • Router Troubleshooting

Try setting compatibility mode for the IP address of the DNS in IE11.
Do not use Chrome for ANY FW loading.

updated to this FW with chrome
having same issue as previous user posted
tried reset (had to hold for ~40sec for reboot/reset
essentially just a network drive now with no control

is there any way to force a FW downgrade?


********************************************************
with IE11 I was always getting some errors, so I used chrome to install FW, but after upgrade it appeared to be broken
so before posting this I downloaded firefox......
wouldn't you know it - the menus work, they do not work anymore with ie11 or chrome

so for me it looks like it only works with Firefox

thanks for having this forum
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

lasagna

  • Level 1 Member
  • *
  • Posts: 4

I have my DNS-345 updated to the latest version, I believe beta 06. Is this issue resolved?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49923
  • D-Link Global Forum Moderator
    • Router Troubleshooting

What issue are you referring too?  ???

I have my DNS-345 updated to the latest version, I believe beta 06. Is this issue resolved?
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

lasagna

  • Level 1 Member
  • *
  • Posts: 4

The CGI exploit one
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49923
  • D-Link Global Forum Moderator
    • Router Troubleshooting

Where did you get this Beta06 version?
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.