• November 19, 2017, 04:30:22 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Windows 10 PC connecting to 2.4GHz band by default  (Read 221 times)

zorbo88

  • Level 1 Member
  • *
  • Posts: 2
Windows 10 PC connecting to 2.4GHz band by default
« on: October 27, 2017, 11:40:20 PM »

Hi there, I have a DIR-878 router with SmartConnect enabled so both the 2.4GHz band and 5GHz band share the same SSID. This is great as it cleans up the network without having to switch certain devices back and forth, and I have certain devices which only support the 2.4GHz band so I need to have it enabled.

The problem is my Windows 10 desktop PC insists on connecting to the slower 2.4GHz band on startup every time, and I have to disconnect from and reconnect to the network every time I start up to force it to connect to the 5GHz band.

I think part of the problem may be that I also have a Windows 10 laptop which shares my Microsoft account (therefore they share wifi profile information with one another) and the laptop only has a 2.4GHz radio in it.

Any suggestions? I've poked around inside the router's settings and can't seem to find anything that might fix the problem, and I'm struggling to find anything in Windows to do it either. I've already changed the option in the driver for the wifi adapter (Intel Dual Band Wireless AC-7260) to prefer the 5GHz band but to no avail.
Logged

GreenBay42

  • Administrator
  • Level 4 Member
  • *
  • Posts: 476
Re: Windows 10 PC connecting to 2.4GHz band by default
« Reply #1 on: October 30, 2017, 07:12:40 AM »

Unfortunately there isn't a way to set this on the router, and none that I know of in Windows. The only way to make sure your PC is connecting to 5GHz is to disable smart connect.

Do you notice a significant difference in performance when using 2.4GHz vs 5Ghz?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43640
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Windows 10 PC connecting to 2.4GHz band by default
« Reply #2 on: October 30, 2017, 10:54:28 AM »

Link>Welcome!

  • What Hardware version is your router? Look at sticker under the router case.
  • Link>What Firmware version is currently loaded? Found on the routers web page under status.
  • What region are you located?

What Version of Windows and update do you have installed?
Are the Wireless drivers fully up to date?

You might try looking at the wireless NIC properties and see if there is a option to set wireless modes to only be N or AC. I've seen some properties that support this. You'll have to check with Intel regarding this and see. Might ask them about this issue seen with there adapter and Windows 10 and wireless modes with Smart Connect enabled routers as well.

Hi there, I have a DIR-878 router with SmartConnect enabled so both the 2.4GHz band and 5GHz band share the same SSID. This is great as it cleans up the network without having to switch certain devices back and forth, and I have certain devices which only support the 2.4GHz band so I need to have it enabled.

The problem is my Windows 10 desktop PC insists on connecting to the slower 2.4GHz band on startup every time, and I have to disconnect from and reconnect to the network every time I start up to force it to connect to the 5GHz band.

I think part of the problem may be that I also have a Windows 10 laptop which shares my Microsoft account (therefore they share wifi profile information with one another) and the laptop only has a 2.4GHz radio in it.

Any suggestions? I've poked around inside the router's settings and can't seem to find anything that might fix the problem, and I'm struggling to find anything in Windows to do it either. I've already changed the option in the driver for the wifi adapter (Intel Dual Band Wireless AC-7260) to prefer the 5GHz band but to no avail.
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

zorbo88

  • Level 1 Member
  • *
  • Posts: 2
Re: Windows 10 PC connecting to 2.4GHz band by default
« Reply #3 on: October 30, 2017, 10:42:20 PM »

Thanks for your replies, unfortunately yes I do notice a performance hit when using 2.4GHz. The speed is much less consistent and I rarely hit the 100mbit that my connection is capable of on the 2.4GHz network.

The hardware version is A1 and the latest firmware is installed (1.01). Located in Australia.

Windows 10 with the latest updates installed and the wireless network adapter's drivers are fully up to date, yes. There's no mode that I can see to only connect to AC in the driver's options. There is one to prefer the 5.2GHz band which I have already enabled and the computer still connects to the 2.4GHz band first time every time.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43640
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Windows 10 PC connecting to 2.4GHz band by default
« Reply #4 on: October 31, 2017, 09:32:43 AM »

You might get a external USB wireless adapter to test. Find one thats dual mode and see if same thing happens. I can only surmise that the wireless drivers for your current card and or Windows 10 is at play here...
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

RYAT3

  • Level 10 Member
  • *****
  • Posts: 2079
Re: Windows 10 PC connecting to 2.4GHz band by default
« Reply #5 on: October 31, 2017, 03:38:17 PM »

Try a detailed search on your chipset and drivers with the problem.

I found some obscure setting to change to fix upload speeds in win 7 once.
Logged